View Single Post
Old 07-06-2012, 07:37 AM   #168
Mr. Data
Human being with feelings
 
Mr. Data's Avatar
 
Join Date: Sep 2008
Location: Location
Posts: 5,330
Default

Well, I'm a bit embarrassed again and feel a bit guilty of making your life harder.

I have the problem that I can't keep the Mouse modifier actions in the action lists in a consistent format.

Code:
;BF0CAFC24857E546=Set default mouse modifier action for \"%s %s\" to \"%s\"
In German it would be necessary to have it look like this...
Code:
Standard-Mausmodifikator-Action \"%s, %s\" ändern in \"%s\"
to maintain readability and perspicuity (note the comma dividing the '%s')
This is no problem in the main action list, but in the MIDI editor action lists I can't do this (at least, I haven't found a way to do so), because I've only got...
Code:
[mousemap]
9965C532C14FFE31=Standard-Mausmodifikator-Action 
167FBDFE83A381FB=(Werkseinstellung)
D89CC7186B79C49A=ändern in
which results in a string without the comma at the needed position.

Now I could put the comma in the terms themselves e.g.
Code:
0F86449BA247E523=MIDI-Editor,
but that doesn't work, because I'd end up with two commas right after each other in the main action list. Furthermore, these commas would also appear in the context rolldown menu of the Mouse Modifier page in Preferences.

What can I do?


-Data
__________________
German Language Pack for REAPER? Get it here! ... Donate? Yeah!! | Are you nuts? | Maybe
Deutsche Sprachdatei für REAPER? Hier zu haben! ... Spenden? Klar! | Spinnst wohl!? | Vielleicht
Mr. Data is offline   Reply With Quote