View Single Post
Old 10-01-2015, 02:34 PM   #13
cyrano
Human being with feelings
 
cyrano's Avatar
 
Join Date: Jun 2011
Location: Belgium
Posts: 4,587
Default

Quote:
Originally Posted by ecl View Post
The last thing Im doing is this:

Once you've set the configuration the way you think you will like it, you can run the server:
On OS X/Linux/FreeBSD (OS X will require you to open a terminal and go to the proper directory):
./ninjamsrv configfilename.cfg
On Windows (after opening a command line, and going to the proper directory):
ninjamsrv configfilename.cfg


I open terminal and run the path of the file

/ECL/eclninjamserver

But Terminal tells me this:

-bash: /ECL/eclninjamserver: is a directory
Fine. That's the directory where your Ninjam server lives, I suppose. You just need to add the program to start. Please try in Terminal:

Code:
./ninjamsrv configfilename.cfg
or

Code:
~/ECL/eclninjamserver/ninjamsrv configfilename.cfg
You did open "configfilename.cfg" in a text editor and changed whatever needed to be changed and saved that?

It could be configfilename.cfg has been saved (by you?) under a different filename. Ninjam.cfg, fi. To find that out:

Code:
cd ~/ECL/eclninjamserver/
ls -al
That will list everything in that directory. And you'll see the .cfg file.

Also, note that you need to forward a port in your local router. Your internet box. Port forwarding might be named differently, since you mention you've "opened" a port. That might look like:

Code:
forward 2049 -> 192.168.2.2
But your ip (192.168.2.2 in the example) is dynamic, driven by the DHCP server in the router. It will change some day, to 192.168.2.4, fi. To do this reliably, you might consider setting up your PC with a static ip. That doesn't change and port forwarding will keep working.

I hope this makes a bit of sense. If not, ask.
cyrano is offline   Reply With Quote