View Single Post
Old 08-13-2019, 09:51 AM   #239
analogexplosions
Human being with feelings
 
analogexplosions's Avatar
 
Join Date: May 2011
Location: Brooklyn
Posts: 338
Default

Quote:
Originally Posted by Ideosound View Post
Are you using a dedicated gpu? Is it Nvidia? As their web drivers are pretty bad to be honest. Some version releases are better than others and of course no Mojave support. I swapped to an AMD Gpu and see no graphical errors or have any slowness in navigation or zooming etc. I also use Live and that's running great. If apps aren't using metal then they would be using opencl I guess? That should run fine anyway.

Or maybe your config file isn't quite right? I switched to the iMacPro1,1 smbios and it is totally the best model ID if you have a dedicated GPU to force hardware acceleration. igpu never really worked that well for me (for quicksync encoding) even when I was sure it was set up correctly.
RX 580 here (iMac 17,1 SMBIOS). Acceleration is working correctly, it still just doesn't feel as snappy as it does on Windows. This is in line with my experience on actual Macs too though. Performance in Reaper was AWFUL in the GUI department until some of the recent pre-releases where there is now Metal support. It's so much better, but still lags a bit compared to running Reaper on Windows though.

GUI performance is kind of a minor gripe though compared to my grief with trying to screenshare sessions over Discord on macOS. Since Discord doesn't use Metal at all, GPU acceleration is completely disabled on macOS and that's become such an integral part of my workflow when working with remote clients.
__________________
www.dungeonbeach.com
analogexplosions is offline   Reply With Quote