View Single Post
Old 11-15-2014, 02:42 PM   #114
Human being with feelings
Banned's Avatar
Join Date: Mar 2008
Location: Unwired (probably in the proximity of Amsterdam)
Posts: 4,868

Originally Posted by mertznet View Post
I am working on using OSCII bot to convert MIDI messages into OSC to control my X32 Rack mixer. I am finding that if I send a single OSCsend statement in response to a MIDI command, things work properly. If I issue more than one OSCsend in response to a single MIDI command though, the OSC command becomes a bundle and gets ignored by the X32. I have tried a number of things but haven't been able to develop a workaround.

I hope this makes sense. Any suggestions or recommendations?
When configuring an OSC output, you can (optionally) specify the maximum packet size. Perhaps try setting this to zero to prevent OSCII-bot from sending OSC messages as bundles, doing something like (adjust where appropriate):

@output OSC_to_X32 OSC "" 0 0
Quoted from Justin's sample script:
// @output lines:
// usage:
// @output devicenameforcode OSC "" [maxpacketsize] [sleepamt]
// @output devicenameforcode MIDI "substring match" [skip]

// maxpacketsize is 1024 by default, can lower or raise depending on network considerations
// sleepamt is 10 by default, sleeps for this many milliseconds after each packet. can be 0 for no sleep.

@output localhost OSC ""
˙lɐd 'ʎɐʍ ƃuoɹʍ ǝɥʇ ǝɔıʌǝp ʇɐɥʇ ƃuıploɥ ǝɹ,noʎ
Banned is offline   Reply With Quote