View Single Post
Old 01-16-2010, 06:37 PM   #63
FeatheredSerpent
Human being with feelings
 
FeatheredSerpent's Avatar
 
Join Date: Jan 2010
Location: Atlantis
Posts: 91
Default Everything just works!

Here's a short experience of a completely new system.
Sold my old daw and hardware, started completely afresh - New OS, new audio interface, new computer, new sequencer, new midi controllers, new external drive, and going from 32bit to 64bit across the board.

Maybe I've been lucky, but here's what worked for me.

Laptop is using a core2duo on an intel GM45 chipset, came installed with Vista which got wiped along with everything else on the harddrive, Windows 7 Home Premium x64 installed from scratch.
I double checked that Toshiba had W7 64 drivers for all the devices before I started. They did so all good.

Checked and double checked the drivers for all hardware pieces I planned to buy.
BEWARE that Vista x64 drivers are not a guarantee of compatability with W7, some will work, many won't.
You don't need the Professional version of W7 to get installation compatibility, there is a program you can download from Microsoft that you can run on programs you're not sure of, I have installed all the 32bit programs I wanted to keep from Windows XP no problem.

Reaper v.3.2 x64 installed (insanely quickly for a cubase user!) no problems.
All my 32bit plug-ins, including a UAD-2 Solo/Laptop card installed perfectly and were recognised and integrated into Reaper straight away.
The ESI UGM-96 and I assume all 64bit ESI interface drivers for W7 installed no problem and was recognised and integrated into Reaper also with no problems.
The 2 mini Akai portable controllers (LPK25 and LPD8) were recognised and integrated perfectly with Reaper.

Basically from this I can't see that there are any problems with using 32bit anything either in Windows 7x64 or in Reaper x64, so long as the drivers for your computer hardware are not only up to date but properly coded and not just some sloppy vista update created from drivers that were sub-standard to begin with.

I'm happy that it has been so painless! But like I said maybe I just got lucky with the drivers, then again if a manufacturer can't write a proper driver maybe their gear should be sent back to them.

Main things though are that 32bit plugs and the uad-2 are working exactly as they should in Reaper x64 under W7x64, if it's not working for you then it is either a motherboard device or hardware device with drivers that are not optimum for the system.
FeatheredSerpent is offline   Reply With Quote