View Single Post
Old 08-15-2016, 11:36 PM   #104
juliansader
Human being with feelings
 
Join Date: Jul 2009
Posts: 2,752
Default

Quote:
Originally Posted by run_esc View Post
Actually I noticed something -- when I run some of your scripts, it changes Reaper's keyboard input to French . So it makes some key commands etc that I set up unavailable until I restart Reaper. Rest of the interface remains in English, took a bit of narrowing down, but I'm sure it's happening when I run these (awesome) scripts.
This is very weird...

I am not sure, but I suspect that Windows' own keyboard shortcuts are intercepting and interfering with the shortcuts that you are setting up for the scripts. For Windows 7, the default shortcut to change language is Shift+LeftAlt, and Shift+Control to change keyboard layout. Windows can remember a different language for each application, so if you accidentally change language while trying to use the scripts, it will probably only change for REAPER.

Personally I have deactivated most of Windows' keyboard shortcuts, including the ones that use the Win key, so that I can use all of them for REAPER commands.

If these Windows shortcuts are not the source of the problem, could you please let me know which scripts are causing the problem, and which shortcuts you are using? Hopefully we can quickly solve any bugs!

Last edited by juliansader; 08-16-2016 at 03:05 AM.
juliansader is offline   Reply With Quote