View Single Post
Old 01-31-2019, 01:56 PM   #9
lexaproductions
Human being with feelings
 
Join Date: Jan 2013
Posts: 351
Default

Quote:
Originally Posted by cfillion View Post
If you're using "ReaScript: Close all running reaScripts" (action 41898), this bug was fixed some time ago:
I'm not using that function as I have other scripts running that I don't want to kill at that moment

Quote:
Originally Posted by cfillion View Post
Sounds like a bug (scripts should not be able to cause crashes)!
Well that's what I thought, because I'm pretty novice at this and I don't want to compromise Reaper's stability.

Quote:
Originally Posted by cfillion View Post
which version of REAPER are you on,
I tried Reaper 5.77 and 5.965, same result

Quote:
Originally Posted by cfillion View Post
How are you "killing an already defered script"
I might not have used the right terms when I said "deferred". Here's a full explanation:
I have "Script A" running in the background. It's a window showing the current region in a window.
Then I trigger "Script B" which monitors if "Script A" is running (using GetToggleCommandState), and kills it at the end of current bar. The Way Script A is kill is simple; I just re-instantiate it, and Reaper kills it instead of making a 2nd instance of the script.

The Problem is: When I trigger "Script B", as soon as it kills "Script A", Reaper Crashes. I've confirmed that, if I don't trigger the kill, Reaper doesn't crash.


Quote:
Originally Posted by cfillion View Post
can you post the crash report?
Code:
Process:               REAPER [29796]
Path:                  /Volumes/VOLUME/*/ReaLiveDev.app/Contents/MacOS/REAPER
Identifier:            com.cockos.reaper
Version:               5.96.500 (5.96.500)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           REAPER [29796]
User ID:               501

Date/Time:             2019-01-31 15:37:48.833 -0500
OS Version:            Mac OS X 10.11.6 (15G31)
Report Version:        11
Anonymous UUID:        48421833-45CE-0A6E-E670-0E640B1D81D1


Time Awake Since Boot: 770000 seconds

System Integrity Protection: disabled

Crashed Thread:        0  reaper  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BAD_ACCESS (SIGSEGV)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000020
Exception Note:        EXC_CORPSE_NOTIFY

VM Regions Near 0x20:
--> 
    __TEXT                 0000000100000000-0000000100ad7000 [ 10.8M] r-x/rwx SM=COW  /Volumes/VOLUME/*/ReaLiveDev.app/Contents/MacOS/REAPER

Global Trace Buffer (reverse chronological seconds):
12.349460    libextension.dylib        	0x00007fff866fa533 tearing down extension request for pid 29799
23.491569    libextension.dylib        	0x00007fff866fa533 tearing down extension request for pid 29799

Thread 0 Crashed:: reaper  Dispatch queue: com.apple.main-thread
0   com.cockos.reaper             	0x00000001006dd41e ReaScript_RunDeferred() + 238
1   com.cockos.reaper             	0x00000001000e067b runMiscTimers() + 1947
2   com.cockos.reaper             	0x00000001000df446 Main_OnTimer(HWND__*, unsigned long) + 166
3   com.cockos.reaper             	0x000000010063ba09 MainProc(HWND__*, unsigned int, unsigned long, long) + 8089
4   ???                           	0x5fbfd33000000001 0 + 6899465357266780161

========================================================>
Crash Log Ending
========================================================>


Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x000000010b188600  rcx: 0x0000000000000000  rdx: 0x0000000000000000
  rdi: 0x0000000108135410  rsi: 0x0000000000000000  rbp: 0x00007fff5fbfbcc0  rsp: 0x00007fff5fbfbc70
   r8: 0x000000010b1c2800   r9: 0x000000000000000a  r10: 0x0000000000234200  r11: 0x0000000000000000
  r12: 0x0000000000000001  r13: 0x0000000000000010  r14: 0x000000010b188608  r15: 0x00000000ffffffff
  rip: 0x00000001006dd41e  rfl: 0x0000000000010246  cr2: 0x0000000000000020
  
Logical CPU:     8
Error Code:      0x00000004
Trap Number:     14


Binary Images:
       0x100000000 -        0x100ad6ff7 +com.cockos.reaper (5.96.500 - 5.96.500) <9096C7B2-2841-2A61-15BB-E7BFCA4059C4> /Volumes/VOLUME/*/ReaLiveDev.app/Contents/MacOS/REAPER
       0x100dc1000 -        0x100df8fff  com.apple.audio.midi.CoreMIDI (1.10 - 88) <51E79766-51D8-3A95-A7FD-18E7E11528F3>
__________________
MP 12 Core 3.46GHZ 48GB OSX10.11.6, MBP 17" 2011 OSX10.12, RME Fireface UFX, MCU,
Reaper 5, DP9, PT 11, Logic Pro X, Bidule, M5 3, BFD2, SD2, Omnisphere, Wave Altiverb, PSP, VB3, Izotope, Scuffham, Soundtoys 5, Slate All Plugins.
lexaproductions is offline   Reply With Quote