View Single Post
Old 12-11-2018, 10:56 AM   #7
explodingPSYCH
Human being with feelings
 
Join Date: Sep 2015
Posts: 190
Default

Quote:
Originally Posted by effitall View Post
I think I follow what you're suggesting and think it makes sense. Perhaps a description:

Let's say you have auto-punch time-selection as your recording method. You punch in on the downbeat of bar 24 for a duration of 8 bars (24-32). You expect there to be a crossfade at the beginning and end of the punch. This means that your actual recording has to be longer than the 8 bars by the duration of your crossfade time split between the beginning/ending of your punch. (Recording actually starts at say 23.4.95, and ends at say 32.1.05 for a 0.0.10 duration crossfade.)

That's all fine and dandy and should be doable. Reaper just has to remember to start recording BEFORE, and record LONGER than, you told it to, and then overlap the previous take past the punch start point, and overlap before the punch stop point. The amount of the overlap/recording start/stop points is half of the crossfade value.

I can see some potential issues to be aware of when setup like this, but it's nothing major and could be a nice time saver. I usually just manually slip my tracks and get the crossfades just right after the recording.
That's interesting, but not what I'm suggesting. My suggestion just entails having the described action reference the setting for said action.

If you are in Takes mode, and you record over an item no crossfade is made between the new and old item, even though Takes mode is defined as "splitting" and creating a new take. The "splitting" does not take into account if you have "overlap and crossfade when splitting" activated.

To recreate this, do the following:
1.) Check "overlap and crossfade items when splitting, length" (Media Item Defaults)
2.) Record a blank audio item
3.) Record another blank audio item over a section of the first audio item
4.) Inspect the point at which they meet. There will be no crossfade. There will either be a fade in/out or an abrupt change.
5.) Manually split an audio item. You will notice a crossfade is created.
6.) Go into Tape mode and repeat steps 2-4. Now there will be a crossfade. This mode correctly references the Media Item Default setting.

This means you can never have a crossfade created automatically when overlapping recordings in Takes mode. However, it works perfectly (and even over-rides creating fade in/outs at the point where the two items meet) in TAPE mode.

The action is not correctly referencing the Default Media Item settings in the same way it does in other situations (eg: manually splitting and Tape mode)
explodingPSYCH is offline   Reply With Quote