View Single Post
Old 12-05-2016, 07:43 PM   #2198
wol
Human being with feelings
 
Join Date: Oct 2013
Posts: 75
Default

Ok it seems I found a solution, no longer have the random midi messages.

To Justin/schwa: the problem was setting the track height with SNM_ChunkParserPatcher, but imo this is not the bugged code since it is used for other things too without problems. Maybe Reaper updates the midi item when setting the chunk and throws midi messages?

Note too that setting the track height with GetSetMediaTrackInfo() does not update UI so I had to add TrackList_AdjustWindows(false); UpdateTimeline(); to make it work.
wol is offline   Reply With Quote