View Single Post
Old 02-14-2020, 01:28 PM   #6578
Dberman
Human being with feelings
 
Join Date: Jan 2020
Posts: 28
Default

Quote:
Originally Posted by Funkybot View Post
Happy to hear it works now!

Ok so, without getting too deep into it...S1, Logic, and Cubase modes should all work VERY well. I didn't use Reaper mode because for some reason Behringer didn't map a button. MCU Std and MCU User modes are out because they only use 1 fader and 1 master, whereas the other DAW modes use 8 [virtual] faders and 1 master. The Waveform MCU mode is very bizarre in terms of what buttons they mapped and to which widgets - stay away from that one. So feel free to experiment with the other MCU DAW modes and pick a favorite as a starting point. They should all work pretty well. It's really about what default widgets you want to see and which overlay you want to use.
@Funkybot, I tried most of the modes, and of course there are different mappings. At this point I'm trying to figure out a couple things. The .mst and .zon file you posted are for S1 mode, but when I press buttons in MIDI-OX, the addresses don't always match your widget definitions and actions in the zone file. For example, the button labeled F1 on the X-Touch is 90 36 7f in your widget, but MIDI-OX says it's 90 4a 7f in S1 mode. The Reaper action assigned to the F1 widget in your zone file actually triggers when I press the button labeled Solo, which doesn't match either MIDI address.

Like I said, I'm trying to understand so I can customize on my own. I copied what I thought were the relevant widgets and actions to my original files, but didn't get the same results. Is that because of the MIDI addresses?
Dberman is offline   Reply With Quote