View Single Post
Old 05-10-2015, 11:48 AM   #13
ivansc
Human being with feelings
 
Join Date: Aug 2007
Location: Near Cambridge UK and Near Questembert, France
Posts: 18,891
Default

O.K. You appear to be getting a rough ride here, but it is partly because you ae venting rather than helping us help you.

A checklist that MIGHT help solve this.

First thing to do is launch reaper using the factory settings.
This IS one of the "launch" options.
At least this way we know we are dealing with a plain vanilla install with no accidentally-pressed buttons!

Connect a USB lead from the Mtrack to your computer and plug in a pair of headphones in the headphone socket of your MTrack.
Plug your guitar lead into one of the inputs and make sure "instrument" is selected for that input rather than "mic".
You might have to fiddle with the A/B button and.or the "mix control on your MTrack, but you should now be able to raise the gain on the input and see the signal LED go green when you play. If not, check the dumbass things, like the lead IS plugged into the guitar and the guitar volume is turned up! (we have all done it)
Hopefully you can now hear your guitar through the phones.
In one directio of the MIX control you should now hear nothing, in the other all guitar.

Next.

In reaper, go to Options/Preferences/Audio Device.
Select ASIO in the Audio System box
In the ASIO Driver box your MTrak should now be showing - if the Enable Inputs box is not ticked, tick it.
Once the box is ticked, you should see an entry under first, probably something like MTrack USB 1, then click on the last box and select the largest number you can find.
In your case it will probably only be MTrack USB 2, but that is OK.

Do the same for the output range and you will have set up your basic I/O configuration properly.
Next click on the ASIO Configuration button and Reaper should open the ASIO config screen for your MTrack.
This will show (among other things) your ASIO buffer size as it is currently set.
For the time being, if it is set to 512 or less, you are good to go. DO NOT try and set this too low to start with or you will have issues with recording.
Click OK to leave the setup menu and we can start looking at inserting a track in Reaper and recording something.
From the main page, go to the Insert menu and go down to the Track button, which will open a new track in Reaper.
The Input that you are using on your Mtrack should now show up on the bottom row of this new track. To the right of it is the Record Monitoring button.
This cycles through off, on and auto each time you click on it.
I set mine as Auto all the time.

With your headphones on and the mix control on your MTrack set in the middle (12 o'clock) position press the record arm button at the top left of the new tracks settings - it will turn red when you have this right.
Assuming you followed the above exactly, press the big red button on the transport controls at the bottom left of your screen and reaper should start to record whatever you play.
But remember you HAVE to either be listening with your headphones or have the main outs of the MTrack connected to an amp & speakers.
Let us know how you get on.

P.S. Here is a link I found on setting up the MTrack Plus in Reaper. Unfortunately it doesn't show the MTrack ASIO configuration screen, so I had to guess at some of the above.

http://m-audio.com/kb/article/1662
ivansc is online now   Reply With Quote