Thread: IPlug - Youlean
View Single Post
Old 04-19-2017, 09:42 AM   #58
Human being with feelings
Soundbytes's Avatar
Join Date: May 2006
Posts: 58


IControl.cpp (629)
This is in IKnobLineControl:: Draw() - scaledInnerRadius could be stored as a member variable and updated in AfterGUIResize instead of here.
IControlGroup.cpp(67) - I don't yet understand what is going on there.
IControlGroup.cpp(83) - same here
IControlGroup.cpp(216) - ...

if (mPlug->GetGUIResize()) controlSize -= 3;
Which three controls need to be kept out of the equation here? Maybe Gui Resize Controls? What if I decide to allow Gui Resizing but do not need the resize Controls? Or a different number of them?

IGraphics.cpp(1099) - IGraphics::IsDirty()
I would always advocate to keep the housekeeping code separated from the actual render cycle. Even if it means adding a few more member variables to the class.
You might also consider using a function pointer to select the appropriate way to recalculate the rect. After all the evaluated condition only changes once in the entire lifetime of the plugin.

IControlGroup.cpp(263) Sorry I have no more time to comment on these today.
(I'll be back tomorrow)

BTW - I understand that IPlug naming conventions are a bit silly but still I think we should stick to those to maintain consistency. Would you consider renaming the viewSelector and handleSelector classes to something like IViewSelectorControl and IHandleSelectorControl?

Finally: I hope I do not come across too picky. I do very much appreciate your effort and frankly this is like an early christmas gift for me.
Soundbytes is offline   Reply With Quote