View Single Post
Old 01-29-2016, 02:43 AM   #78
Brado231
Human being with feelings
 
Join Date: Sep 2012
Location: Oz
Posts: 195
Default

Quote:
Originally Posted by The_Nimaj View Post
My faderport is also in a powered USB hub. That shouldn't make a difference, and yes, the power cable is only for the motor. How are you closing REAPER? Pressing the X or File -> Close, etc. Perhaps I can try exactly what you're doing and see what the issue is. Also, does the fader return to the zero (bottom) position on close?
Sorry for the delay getting back. Have been running quite a few tests and noticed a few new things that I hadn't previously....

I'll start out with my config to give you an understanding of what I am running (to maybe give you some ideas):

Macbook Pro 15 Mid 2014 with 2 x USB 3.0 ports - 2 USB hubs (see below) plugged into these
Bootcamp Windows 7 Ultimate installation (this is where I run all of my main audio stuff including Reaper)
MAC OSX Yosemite (10.10) - I run Reaper here too but mainly for testing - nothing production
Belkin 7-Port Powered USB 2.0 hub x 2
Faderport plugged into Belkin USB 2.0 hub
Faderport has 1.3.8 firmware
Currently have Reaper 5.15 pre6 64-bit installed on both OS's along with your latest version of Faderport XT.

Ok, now for what I found....

The MAC version works perfectly and DOESN'T have the problem I described. I just noticed this. When I exit Reaper on MAC the fader goes all of the way to the bottom as you mentioned and all lights on the Faderport turn off. Perfect!

The Windows version exhibits the issue everytime (leaving lights on). I exit Reaper by pressing the X in the top right corner. I tried having the Faderport plugged directly into the MAC, as well as plugged into the USB hub as normal, and both ways have the same issue, so it shouldn't be related to the USB hub as you say. Also, the MAC version works fine when plugged into the USB hub, so I think that can be crossed out as a potential problem.

The Windows version DOESN'T move the fader to the bottom on exit like the MAC version does.

All I have to do in Windows to have the lights left on is:
1. Load Reaper
2. Select the Master track so the Output light is ON, or create a track and set record arm to on to turn on the Rec light on the Faderport.
3. Press X in top right corner to exit Reaper.
4. When back in Windows the lights on the Faderport are stuck on (Rec and/or Output - Have also seen Loop stay on).
5. If I load Reaper again the lights instantly turn back off when Reaper detects the Faderport.

That's pretty much it. Very easy to reproduce for me. Happens every time. Don't want to lights to stay on permanently (even when im not home and computer isn't there) and eventually burn them out. I currently need to remember to unarm everything before exiting Reaper to make sure they are off.

Thanks heaps for your help. It is very much appreciated!

EDIT: Oh btw, the Stop light always turns off on exit in both Windows and MAC OSX. It's just those other lights that seem to have an issue.

Last edited by Brado231; 01-29-2016 at 02:54 AM.
Brado231 is offline   Reply With Quote