View Single Post
Old 06-17-2011, 04:03 PM   #10
Guido
Human being with feelings
 
Join Date: Nov 2007
Posts: 674
Default

Quote:
Originally Posted by hamish View Post
If I record audio and MIDI to a click in REAPER, and then change the project tempo, there is no problem. The MIDI and audio stay in sync. (with audio items timebase set to Beats (position/length/rate))

Perhaps misleadingly it does not matter what the MIDI item timebase is set to, it will always change rate with a project tempo change.

Also, if I record audio without a click, set timebase to time, map the tempo every two bars I can then import or create a 2 bar MIDI item, and when looping it will fit to the audio perfectly.

It seems the problem is when we have tempo changes that are occuring within the duration of the MIDI item.

One way this happens is when we record audio and MIDI without a click, and then go to map the tempo. In this case the only way to keep MIDI and audio aligned is to check 'ignore project tempo information' in the MIDI item properties, with the original project tempo in the 'use: xxx BPM' field. When this is done the audio and MIDI stay in sync, and the MIDI eventas will move onto the project grid.

I haven't done an import of full length MIDI item into a project with tempos changes, is this where OP is having the problems?
Bingo!

Hi,

You have it correct Hamish...the problem with using "ignore blah blah", is that u have to go into EACH MIDI items Properties separately...with many MIDI items it is not practical. AND if i remember correctly the last time i did it..if u then split that item,weird things happen to ur data.

IMHO, the timebase setting for both midi and audio should behave consistently. to me this is a long standing bug. But I love Reaper! Its kinda like my wife I..er..nm ^^

Thanks for all the responses^^ I kinda gave up^^ Thanks

Guido

EDIT..in response to ur asking of where my prob is...I often record Midi and audio w/o a click, and I would like to line up the grid with my already recorded performance.
Guido is offline   Reply With Quote