View Single Post
Old 12-19-2010, 04:25 AM   #164
eric71
Human being with feelings
 
Join Date: Feb 2008
Location: Finland
Posts: 160
Default

I've had a weird wine (regression problem?) with one particular vst, and I thought this might be the best place to ask for help. A few months ago I settled on using Mandriva after having used Debian based distros for years. I had fully up to date wine, wineasio 0.7.5 and up to date REAPER. I tried the DrumCore free version and the KitCore demo versions. Both worked very well, and I eventually bought KitCore. It worked nicely in REAPER under wine. In a fit of distro hopping, I decided to try the latest Unity Linux (based on Mandriva, but it had some newer packages). I installed wine, wineasio and REAPER there, as well as KitCore (not the demo). When REAPER scanned it the first time, it threw up an illegal operation error, and it's not available in the VSTi list.

I figured it was a wine regression, so I reinstalled Mandriva 2010.1, set it all up just like I had it before, and now I'm getting the same scanning error with it. I've attempted different versions of wine and older versions of REAPER, and I can't get it to work.

I can only think it has something to do with having installed DrumCore or the KitCore demo before the full version the first time around. But the Kitcore website has moved and the demo doesn't seem to be available anymore - so I can't repeat the sequence. The full kitcore install just replaces the vst .dll from the demo version - it's named the same.

In the past when I've seen these type of errors, using native gdiplus from Windows helped. But I haven't had to do this for a long time. And there is already a wine version of it in the system32 folder, so to copy the windows one in, it would overwrite wine's version. Not sure how to proceed.

Does any wine/vst experts have suggestions? It's the one plugin I've spent some money on, and it did work before I messed with things. I'd like to get it back. I've had to reinstall XP, and I'm not happy about it.
eric71 is offline   Reply With Quote