View Single Post
Old 12-07-2019, 08:45 PM   #1
Joe90
Human being with feelings
 
Join Date: Aug 2019
Posts: 610
Default RT SPIKES AND DROPOUTS - Please assist.

I'm getting major real time spikes and freezes on heavy projects. It's worst when opening or closing the midi editor, but also happens when stopping transport, and soloing or muting a track. If I select multiple midi parts and try to open them together it gets especially bad. I'll often get a major freeze for a few seconds, the RT CPU spikes, and a weird graphical glitch where the mixer on my second screen goes fuzzy and out of focus then refreshes (this weird graphical thing has been happening a lot since 6.0, it happens when autosaving too sometimes). The main issue is the RT spikes though.

Please see this gif (apologies that it looks a bit odd - trying to record two different res screens at the same time) - you can see I double click the midi parts, everything freezes, then when it unfreezes I get a big RT spike and dropouts in the audio, and it's just as bad when closing the midi editor, you can also see the fuzzy mixer refreshing that I mentioned (ignore the fx slots disappearing on the mixer, that's something to do with the gif recording).

https://gifyu.com/image/vDvA

I've tried rolling back, tried a portable install, tried disabling/enabling live processing on the midi editor, as well as the media buffering, makes no difference to the RT spikes, it doesn't happen on every project, but once it 'kicks in' it's a nightmare.

II know people will say it's a rogue plugin, but I've tried going through and disabling them in batches and there is no one plugin causing the issue, if I disable enough of them then the behaviour stops, but it's not one specific plugin - it happens when a project passes a certain threshold of FX use, and I think it's related to anticipative FX, and some of the issues raised here with APFX and complex routing - https://forum.cockos.com/showthread.php?t=225636

I expect someone will also note the high PDC amount on some of the tracks and say this is the main issue. I'm pretty sure it's not. I can make a test project with a bunch of reafirs and pro-q's in linear phase mode, get the PDC up to 20000, and none of these issues occur - I'd bet my hat that it's related to APFX, but if I turn off APFX then Reaper becomes woefully underpowered, so it's a tricky one. Hoping someone can help.
Joe90 is offline   Reply With Quote