View Single Post
Old 01-17-2019, 12:08 AM   #8
drichard
Human being with feelings
 
Join Date: Jun 2016
Posts: 446
Default

This is an old thread, but I'm seeing some issues as well with MIDI. Somehow the audio and MIDI recording compensations differ.

Audio works, or at least I can make it work perfectly. Following Justin's advice I was able to get audio to be sample accurate. I compensate at the output manual offset. In my case, 26 samples of compensation gives sample accurate audio recording.

But I am not seeing a solution to the MIDI compensation problem. I looped a MIDI output back to a MIDI input, created some 1/4 notes exactly on beat, and recorded them to a new track via the loop. In the new track the MIDI notes are ahead of the beat by a fairly significant amount. I tried various output compensation settings, but they did not help the problem. While changing the output compensation offset didn't seem to help the MIDI timing, it does mess with the audio timing.

I can work around this. When choosing between MIDI or audio record accuracy, accurate audio timing/compensation is much more important to me than MIDI. I'm not a very precise keyboard player so I tend do edit my timing anyway, and this is simply one extra step. But I think it's something that Justin and Schwa should be aware of.



Quote:
Originally Posted by Tycho View Post
When recording midi, all events are placed on the timeline before they were played, with the offset increasing as the buffer size is lowered. For instance, at a buffer size of 256, midi notes played will show up on the timeline about 1/16 of a note (at 120bpm) ahead of where they were actually played. At 64smpl buffer they will show up around 1/8 note ahead of time. I always have to go in and slide all the notes over to the right to get them to line up. This does not happen with audio, only midi.

In the attached image you will see first a midi track, which is clearly shifted forward on the grid, then an audio track which, save for some sloppy playing, is generally in the correct position. and finally the grid quantized click track I was playing to.

The offset is not variable, all notes are placed on the timeline at a fixed offset ahead of where they were played, meaning I can just bulk slide all of the material and that fixes it.

I have "Use Audio Driver Reported Latency" checked with "0" for both output and input manual offset. Unchecking it doesn't fix the issue. setting the manual offset has no effect. setting the midi input driver mode to "QPC" in timestamp options has no effect.

this happens with all the midi interfaces I have, integrated usb interfaces on the midi controllers themselves as well as an iconnectmidi2. this issue has persisted across three machines and various versions of reaper. can't quite remember when it started but it's been a few years I think.

I appreciate any insight anyone might have on this issue.
Thanks
-Scott
drichard is offline   Reply With Quote