View Single Post
Old 05-14-2020, 05:27 PM   #2
xpander
Human being with feelings
 
xpander's Avatar
 
Join Date: Jun 2007
Location: Terra incognita
Posts: 6,021
Default

Quote:
Originally Posted by XilburQost View Post
UPDATE: I think I found the solution: In the MIDI editor, select the option View > Piano Roll Timebase, and select Source Beats.
I wouldn't recommend that as a fix to snap problems. That timebase has limitations which might bite you later, especially if you forget that setting.

I would rather change the MIDI editor mouse modifiers to better suit the snapping. Check the context for the note insert method you are using and change the default to snapping action, or use the modifiers which already have snapping in there.

As an example, if you use left drag to draw the notes, the default action in MIDI piano roll left drag context is Insert note, drag to extend or change pitch. That will snap to grid, but if you also have Ignoring snap selected in there, that's what happens.
xpander is online now   Reply With Quote