View Single Post
Old 05-13-2019, 09:30 AM   #14
Human being with feelings
Join Date: May 2019
Location: London
Posts: 4
Exclamation Faderport 16 NOT working with latest reaper - Presonus transcript

Hi all,
unfortunately I can't get the Faderpot to respond as it should in Reaper (latest version updated May 12th 2019) - I have reached out to Presonus a number of times and even they have given up.

Here below the full transcript - Hopefully this will keep Reaper users from purchasing the unit for now..It's an unfortunate situation as we I can't really tell when and if Reaper/Presonus will allow for such integration and while I adore the faderport as a hardware unit I just can't experience the same workflow I have in Reaper in Studio One - Reaper is, to me, a much more well thought daw and it sort of feels like even though the Faderport is allegedly a MUI universal controller (aka no problem with Reaper on paper) customer will be forced to eventually transition to Studio One... Stuck between a Rock and a hard place!

p bonanno Thursday at 00:37
How do I set up my Faderport 16 with Reaper?

Avatar Technical Support Thursday at 16:27
Hello Bonanno,

To use your FaderPort within Reaper you'll first need to ensure the FP is set to MCU mode.
Power off the FaderPort
Hold the first and second "Select" buttons on the FP
Power the unit back on
Once the unit has powered up and displays "Select Control Mode" across the top of the scribble strips you can release the Select buttons
Select "MCU"
Press the eighth "Select" button ("EXIT" will be displayed on the scribble strip above this Select button)
You are now in MCU mode on your FaderPort and will remain in MCU mode even if you power the device off. To change to a different mode execute the steps listed above but select a different mode (such as HUI or Studio One mode).

Step 2 - Configure a Control Surface within Reapers Preferences
Open Reaper
Click the "Options" drop down menu and select "Preferences
Click on "Control Surfaces" within the Preferences menu
Click "Add"
Select "Mackie Control Universal" as Control Surface mode
Select "PreSonus FP" as your MIDI input and MIDI output

p bonanno Friday at 00:04
Hi, I just tried the above with my new Faderport 16 and it did not work
Also, "exit" was on my 7th select button, not the 8th

Technical Support Friday at 17:08
Hello p,

Please send me your computer's System Info file.

*NOTE: If you own PreSonus hardware, you will need to have your PreSonus hardware attached to the computer by USB or FireWire and powered on when you do this.

p bonanno Friday at 17:41
Hi Nick,
thanks for your prompt response, much appreciated.
FYI my equipment list is:
Reaper 5.977
Focusrite Clarett 8Prex
and the new Faderport 16 obviously

PC has Win 10 and it's a dell G5 i7

not sure whether you needed these info but just in case
Please find in attachment the file

Best Wishes



Technical Support Friday at 20:22
Hello P,

Thank you for getting back with us.

The NFO file shows your Faderport shows as connected and installed.

Have you tried different USB ports?

Id also like you to test the unit within Studio One, its Native DAW.
This will determine any Hardware Failure.

Let me know if you have any questions.

Nick Maggio
PreSonus Technical Support Rep

p bonanno Friday at 20:28
Hi Nick,
i have just tried and it does indeed connect to studio one and responds as it should

i guess the unit is absolutely fine then... the problem is still with reaper then

what would you advice as next step?

Avatar Technical Support Today at 14:54
Hello P,

Thank you for getting back with us,

At this point we would recommend reaching out to the Manufacturer of the DAW in question.
Reaper support for the Faderport is conducted within their Forums.
There may be some more information within those forums.
Please let me know if you have any more technical issues?


Nick Maggio
PreSonus Technical Support Rep
kingriot is offline   Reply With Quote