Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 09-19-2017, 04:33 PM   #1
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 1,715
Default "Ignore mousewheel on track panel faders" broke in mixer + no undo

No undo points are created for the volume/pan value change under this condition.

Edit. Narrowing it down in posts 7 and 8...



REAPER 64 / Windows 7
Present in 5.50, and 5.40, at least.

Last edited by FnA; 11-09-2017 at 03:59 AM.
FnA is offline   Reply With Quote
Old 11-07-2017, 01:03 AM   #2
jeranx
Human being with feelings
 
jeranx's Avatar
 
Join Date: Nov 2012
Location: Région de Caen, Normandie
Posts: 782
Default

Quote:
Originally Posted by FnA View Post
No undo points are created for the volume/pan value change under this condition.



REAPER 64 / Windows 7
Present in 5.50, and 5.40, at least.
Hi FnA.

Coming from reading this one :
https://forum.cockos.com/showthread.php?t=199207
where I'm not sure to understand everything.

I think ("behavior/mouse related to ignoring mouse wheel on faders are making no difference over the envelope fader") this is normal or at least, I have the same behavior here. For the case you show here it's normal it doesn't affect the fader (as it's not a TCP one), unless you tick the "all faders" box.

I think. Bye
__________________
https://hearthis.at/jeranx-qd/
https://soundcloud.com/thierry-vastel
Un peu fort et .. au casque
jeranx is online now   Reply With Quote
Old 11-07-2017, 04:40 AM   #3
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 1,715
Default

Thanx jeranx.

At least for an English speaker the wording in the mouseover information that appears at the bottom of the preferences window is ambiguous, but I feel the "mixer " at the end tends to overrule the "mixer" at the start.

At any rate, I think the difference in undo behavior between having the box checked or not indicates a bug.

I will research the TCP behavior and make gif and stuff later. I think something is wrong in the TCP too but it's kind of a complicated difference.
FnA is offline   Reply With Quote
Old 11-07-2017, 05:14 AM   #4
jeranx
Human being with feelings
 
jeranx's Avatar
 
Join Date: Nov 2012
Location: Région de Caen, Normandie
Posts: 782
Default

Quote:
Originally Posted by FnA View Post
Thanx jeranx.

At least for an English speaker the wording in the mouseover information that appears at the bottom of the preferences window is ambiguous, but I feel the "mixer " at the end tends to overrule the "mixer" at the start.

At any rate, I think the difference in undo behavior between having the box checked or not indicates a bug.

I will research the TCP behavior and make gif and stuff later. I think something is wrong in the TCP too but it's kind of a complicated difference.
I've tried and for me no undo problem



Maybe an other setting of yours.

Good search. Bye
__________________
https://hearthis.at/jeranx-qd/
https://soundcloud.com/thierry-vastel
Un peu fort et .. au casque
jeranx is online now   Reply With Quote
Old 11-07-2017, 05:31 AM   #5
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 1,715
Default

Congratulations on post #666. An honor for me.

This thread is mixer specific. Also you need to try with only the one box checked. And you also may need to interject some other undoable actions and step back through them to see.
FnA is offline   Reply With Quote
Old 11-07-2017, 05:40 AM   #6
jeranx
Human being with feelings
 
jeranx's Avatar
 
Join Date: Nov 2012
Location: Région de Caen, Normandie
Posts: 782
Default

Quote:
Originally Posted by FnA View Post
Congratulations on post #666. An honor for me.

This thread is mixer specific. Also you need to try with only the one box checked. And you also may need to interject some other undoable actions and step back through them to see.
Didn't see I was in "Mixer bug reports".

Sorry, being such a "beast"


__________________
https://hearthis.at/jeranx-qd/
https://soundcloud.com/thierry-vastel
Un peu fort et .. au casque

Last edited by jeranx; 11-07-2017 at 11:34 PM.
jeranx is online now   Reply With Quote
Old 11-07-2017, 03:31 PM   #7
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 7,244
Default

The broken "Ignore..." option in mixer I can confirm here, the "no undo" not completely.
It may be a little unexpected but here it creates an undo point when I'm moving the mouse away from MCP (I assume that may be intended to not get undo points clutter).



R5.62(pre)

Last edited by nofish; 11-07-2017 at 03:38 PM.
nofish is offline   Reply With Quote
Old 11-07-2017, 08:45 PM   #8
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 1,715
Default

Thanks nofish. That's one thing in common anyway. The part you can confirm. (See edit below)

I could have sworn that when I reported this, that having both "ignore" boxes UNchecked, I would still get undo points. I even seem to recall that they seemed to use a timer of sorts to reduce undo spamming. But now I get no undo points with either both off or just the track fader box originally reported. Checked the mouse move strategy you showed. Nothing, even if I click in arrange.

I do get an undo point for every click of the wheel on extended mixer send knob. No preference seems to prevent wheel from working on that. But I think that has been the case for as long as I can remember.

I could report strange behavior in the tcp too, but will hold off for the moment.

Trying 5.51x64 windows 7 right now. Dual monitors. Logitech mouse.


Edit. Was using Default Commala 5 theme. Noticed a volume adjustment undo Point appear when moving mouse to extended mixer. Then realized it was when entering the number at the top of the meter after further trials. Switching to default v5 theme made a big difference. Apparently there are certain areas that set it off. Can still sneak out with out undo points through mute buttons for example.

Last edited by FnA; 11-07-2017 at 10:38 PM.
FnA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:40 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.