Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER General Discussion Forum

Reply
 
Thread Tools Display Modes
Old 11-29-2017, 10:55 AM   #41
Vagalume
Human being with feelings
 
Join Date: Nov 2015
Posts: 349
Default

I had a little time last night to test Reaticulate. One of the things that I thought was that if you are using a library with so many articulations, for instance Spitfire Symphonic Strings, and you want to add the whole V1 you will have to scroll a lot. I know this is not really important, but perhaps it would be possible to change the GUI so more articulations are seen. I don’t know how it is the best way to achieve it, anyway I have modified a screenshot in photoshop to make myself understood because my English is poor.




I tried to do the same as you did in your video with chamber Strings V1, but using SSS:
As I said yesterday it worked but this Error message appeared: bank conflict on same channel SSS- V1 Core. Maybe the message has to do with the Kontakt factory banks, in fact SSS V1 Core and V1 Decorative share an articulation (both have Sul Pont) and both patches sound at the same time when selected with this concrete articulation, no idea. Besides Reaticulate doesn’t select V1 Core flautando, of course it is possible to do it with the mouse in the patch itself. Finally, this message appears every time I add a second bank except If I use 2 patches of Spitfire Chamber Strings, with this library the message doesn’t appear. Some screenshots, maybe I did something wrong...





Last edited by Vagalume; 11-29-2017 at 11:06 AM.
Vagalume is offline   Reply With Quote
Old 11-29-2017, 11:15 AM   #42
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by Vagalume View Post
I know this is not really important, but perhaps it would be possible to change the GUI so more articulations are seen. I don’t know how it is the best way to achieve it, anyway I have modified a screenshot in photoshop to make myself understood because my English is poor.
I do understand what you mean. This goes more generally to the point of having the UI adapt better to different widths. I need to give some thought to this, and it'll be a longer term to-do item for sure.


Quote:
Originally Posted by Vagalume View Post
Maybe the message has to do with the Kontakt factory banks, in fact SSS V1 Core and V1 Decorative share an articulation (both have Sul Pont) and both patches sound at the same time when selected with this concrete articulation, no idea.
This is exactly the reason for the warning. It's safe to ignore in this case. I've committed a fix for that (as it was reported over on The Sound Board) and it'll be in the next release.

As for the Masse conflict, this is expected as these patches definitely do conflict (the patches themselves use the same UACC numbers and so they conflict). The only way to deal with this is to put them on different channels in Kontakt, and use dedicated source and destination channels in the Reaticulate bank configuration.

For example, Strings on source and destination channel 1, and Brass on source and destination channel 2 (with the Kontakt patches assigned accordingly). But then you would need to switch your controller to the appropriate channel as well. (I think perhaps the UX could be improved there.)

The same issue applies with Albion ONE Strings being on the same channel as SSS. The underlying patches themselves conflict and so can't be on the same channel.


Thanks for the feedback!
tack is offline   Reply With Quote
Old 11-30-2017, 09:55 AM   #43
swiiscompos
Human being with feelings
 
swiiscompos's Avatar
 
Join Date: Mar 2011
Location: Lausanne (CH)
Posts: 1,095
Default

Hi, this look great but for some reason the Reabank files don't seem to match any of my libraries (all Spitfire), any idea why that would be the case? I'm on mac if that makes any difference (but I don't think it should).
swiiscompos is offline   Reply With Quote
Old 11-30-2017, 10:15 AM   #44
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by swiiscompos View Post
for some reason the Reabank files don't seem to match any of my libraries (all Spitfire), any idea why that would be the case?
Make sure you set the patches to "Locked to UACC". (The little note field for each of the Spitfire banks says "Set patch to UACC", and in general that message will give patch configuration information if relevant.)

The factory banks using Spitfire send UACC (CC32) events to trigger articulations, not the out-of-box note-based keyswitches.
tack is offline   Reply With Quote
Old 11-30-2017, 12:17 PM   #45
Mordi
Human being with feelings
 
Mordi's Avatar
 
Join Date: May 2014
Location: Norway
Posts: 432
Default

I would have liked to see how one uses this in practice, after it's set up. The basic workflow. Do you enter step record-mode and go from there, or is there a way to just place the edit-cursor down where you want an articulation to start and then press one of the given articulations?
Mordi is offline   Reply With Quote
Old 11-30-2017, 02:36 PM   #46
swiiscompos
Human being with feelings
 
swiiscompos's Avatar
 
Join Date: Mar 2011
Location: Lausanne (CH)
Posts: 1,095
Default

Quote:
Originally Posted by tack View Post
Make sure you set the patches to "Locked to UACC". (The little note field for each of the Spitfire banks says "Set patch to UACC", and in general that message will give patch configuration information if relevant.)

The factory banks using Spitfire send UACC (CC32) events to trigger articulations, not the out-of-box note-based keyswitches.
Thanks, I totally missed that. It sorks perfectly now!
swiiscompos is offline   Reply With Quote
Old 11-30-2017, 05:22 PM   #47
mikeroephonics
Human being with feelings
 
mikeroephonics's Avatar
 
Join Date: Nov 2006
Posts: 2,452
Default

This looks really interesting! Thanks so much for coming up with this idea and bringing it to life!

I can't seem to get it to work. I ran the Action "Script: Reaticulate_Main.lua", then clicked on the [Add Reaticulate FX] button to add the "JS: Reaticulate" effect to a TCP, but the JS is in offline mode and I can't get it to come online. The FX window reads: "The following effect plug-in could not be loaded."

I'm not sure why.

Aside from that, I have one question regarding Bank/Program Change entry: Can this plug-in let you insert a Bank/Program Change Message at the edit cursor position by clicking on an articulation in Reaticulate's GUI? This would be a very intuitive and fast way to insert articulations note-by-note.

I wrote a Feature Request for faster Bank & Program Change Entry which you might find interesting:

FR: Faster Bank & Program Change Entry & Editing
https://forum.cockos.com/showthread.php?t=158415
__________________
Please check out these MIDI requests: http://forum.cockos.com/showthread.php?t=103192
Thanks.
mikeroephonics is offline   Reply With Quote
Old 11-30-2017, 06:02 PM   #48
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by Mordi View Post
I would have liked to see how one uses this in practice, after it's set up. The basic workflow. Do you enter step record-mode and go from there, or is there a way to just place the edit-cursor down where you want an articulation to start and then press one of the given articulations?
Workflow will of course vary by individual. You can step record articulation changes in the MIDI editor, or perform them live. (Articulations are activated either by clicking on them, or via one of the actions.)

I'm but a lowly hobbyist, but I find I do some kind of hybrid, where I sketch in something rough by triggering an articulation in the vicinity of what I want (longs for chords, legato, basic shorts, pizzicato), hack away at something live recording, and then go in afterward in the MIDI editor and massage the articulations (and other MIDI events) to be more specific.

Quote:
Originally Posted by mikeroephonics View Post
I can't seem to get it to work. I ran the Action "Script: Reaticulate_Main.lua", then clicked on the [Add Reaticulate FX] button to add the "JS: Reaticulate" effect to a TCP, but the JS is in offline mode and I can't get it to come online. The FX window reads: "The following effect plug-in could not be loaded."
Wow, I'm afraid I've never seen that before either. What happens if you manually insert the Reaticulate JSFX (and drag it to the top of the chain)? Or what happens if you restart Reaper and try?

Quote:
Originally Posted by mikeroephonics View Post
Aside from that, I have one question regarding Bank/Program Change entry: Can this plug-in let you insert a Bank/Program Change Message at the edit cursor position by clicking on an articulation in Reaticulate's GUI? This would be a very intuitive and fast way to insert articulations note-by-note.
Yes, but it works by step-input in the MIDI Editor. So you open the MIDI editor, enable step input, and then any activated articulation will be inserted at the edit position.

The exception to that is if a program change is selected: in this case, the activated articulation will replace the selected program change, even if it happens to not be at the edit cursor.

Quote:
Originally Posted by mikeroephonics View Post
I wrote a Feature Request for faster Bank & Program Change Entry which you might find interesting
Yeah, a bit related to the way Reaticulate works, isn't it. At least in that one aspect of Reaticulate provides a simple GUI to inject program changes into MIDI items. The idea of a most recently used set of articulations being more easily accessible is interesting.
tack is offline   Reply With Quote
Old 11-30-2017, 08:39 PM   #49
pcartwright
Human being with feelings
 
Join Date: Jan 2009
Posts: 915
Default

Quote:
Originally Posted by mikeroephonics View Post
I can't seem to get it to work. I ran the Action "Script: Reaticulate_Main.lua", then clicked on the [Add Reaticulate FX] button to add the "JS: Reaticulate" effect to a TCP, but the JS is in offline mode and I can't get it to come online. The FX window reads: "The following effect plug-in could not be loaded."
Not sure if this helps, but...

This happened to me when I tried to use the script immediately after downloading (using ReaPack). I needed to restart Reaper before the JSFX was accessible and usable.
pcartwright is offline   Reply With Quote
Old 11-30-2017, 08:49 PM   #50
mikeroephonics
Human being with feelings
 
mikeroephonics's Avatar
 
Join Date: Nov 2006
Posts: 2,452
Default

Quote:
Originally Posted by tack View Post
Wow, I'm afraid I've never seen that before either. What happens if you manually insert the Reaticulate JSFX (and drag it to the top of the chain)?
I got it to work by manually inserting the JS. Also, I had the offline problem with two machines (my laptop and DAW PC, both on Windows 7, if that matters.)

This is a very cool utility which I'm definitely looking into this weekend! I actually built a .ReaBank for my Vienna Symphonic Library 'Horizon Series' libraries, which is over 10,200 lines long. I'm going to see how Reaticulate can help work with such a daunting amount of articulations.

Thanks for all the work you put into this!
__________________
Please check out these MIDI requests: http://forum.cockos.com/showthread.php?t=103192
Thanks.
mikeroephonics is offline   Reply With Quote
Old 12-01-2017, 03:16 AM   #51
o_e
Human being with feelings
 
Join Date: May 2016
Posts: 234
Default Installation

Hi,

After installing via Reapack, when I try to lauch reaticulate_main, I get the following error warning (see screenshot), what am I missing?
Attached Images
File Type: jpg Bildschirmfoto 2017-12-01 um 11.09.29.jpg (15.8 KB, 158 views)
o_e is offline   Reply With Quote
Old 12-01-2017, 06:01 AM   #52
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by o_e View Post
After installing via Reapack, when I try to lauch reaticulate_main, I get the following error warning (see screenshot), what am I missing?
Reaticulate_Main.lua first looks for the source code in .../Scripts/Reaticulate/app/main.lua and if it can't find it, it thinks this must be a binary install and tries to load a different thing. This is dormant code though, part of an experiment to see if precompiled binaries were faster (it was not measurably faster) -- it must mean ReaPack didn't install it properly.

Does Scripts/Reaticulate/app/main.lua exist for you?

Hopi ran into this as well (on Windows) and found that with a fresh profile the problem went away. Hopi did you ever find root cause?

Unfortunately I've not been able to reproduce it.
tack is offline   Reply With Quote
Old 12-01-2017, 08:30 AM   #53
o_e
Human being with feelings
 
Join Date: May 2016
Posts: 234
Default

Quote:
Originally Posted by tack View Post
Reaticulate_Main.lua first looks for the source code in .../Scripts/Reaticulate/app/main.lua and if it can't find it, it thinks this must be a binary install and tries to load a different thing. This is dormant code though, part of an experiment to see if precompiled binaries were faster (it was not measurably faster) -- it must mean ReaPack didn't install it properly.

Does Scripts/Reaticulate/app/main.lua exist for you?

Hopi ran into this as well (on Windows) and found that with a fresh profile the problem went away. Hopi did you ever find root cause?

Unfortunately I've not been able to reproduce it.
Hi,

Thanks for the quick answer!

I'am on Mac OS 10.9.5 aka Mavericks and in Scripts/Reaticulate is no folder 'app', only one folder 'actions'.
What do you mean with 'a fresh profile'?
Is there a way to get the 'main' folder manually somehow?

Edit: When in browse Reapack and type in 'reaculate' a lot of scripts are shown, a part of them not installed. When I try to install them via rightclick nothing get installed (see screenshot https://imgur.com/NXU9Wun)..

Last edited by o_e; 12-01-2017 at 08:56 AM. Reason: update
o_e is offline   Reply With Quote
Old 12-01-2017, 09:04 AM   #54
sfiks
Human being with feelings
 
sfiks's Avatar
 
Join Date: Dec 2012
Location: NY
Posts: 115
Default

Quote:
Originally Posted by o_e View Post
Hi,

Thanks for the quick answer!

I'am on Mac OS 10.9.5 aka Mavericks and in Scripts/Reaticulate is no folder 'app', only one folder 'actions'.
What do you mean with 'a fresh profile'?
Is there a way to get the 'main' folder manually somehow?

Edit: When in browse Reapack and type in 'reaculate' a lot of scripts are shown, a part of them not installed. When I try to install them via rightclick nothing get installed (see screenshot https://imgur.com/NXU9Wun)..
This is how it looks like on my Mac OS 10.8.4
Attached Images
File Type: png scripts folder.png (37.8 KB, 638 views)
sfiks is offline   Reply With Quote
Old 12-01-2017, 09:20 AM   #55
o_e
Human being with feelings
 
Join Date: May 2016
Posts: 234
Default

Quote:
Originally Posted by sfiks View Post
This is how it looks like on my Mac OS 10.8.4
As I said, in my folder ..Scripts/Reaticulate there is only one folder 'actions' the others are missing. How can I get them?
Could this be an OS problem? I can't hardly believe that..

o_e is offline   Reply With Quote
Old 12-01-2017, 09:42 AM   #56
sfiks
Human being with feelings
 
sfiks's Avatar
 
Join Date: Dec 2012
Location: NY
Posts: 115
Default

Quote:
Originally Posted by tack View Post
I welcome all bug reports, suggestions, and other feedback, either here, or on the GitHub issue tracker.
Thank you for this very helpful tool. I love it!
I noticed insignificant "bug" that doesn't affect the flow and sound,
just irritates a little bit

when i run 1st articulation

//! c=long i=tremolo g=3 o=note-hold:25/note-hold:106
91 Tremolo ordinary Volume - CC1

and change CC1 from 0 to 127 it does what it suppose to do,
but 2nd articulation gets selected on the GUI:

//! c=textured i=pizz g=3 o=note:29/note:106/cc:01,0
96 Pizz. ordinary Volume - VELOCITY

Somehow value 0 of CC1 (volume of 1st articulation) affects the 2nd articulation. The 2nd articulation doesn't get triggered - it's just gets selected on GUI.

Could I code something to get rid of that?

Thank you,
Slava
__________________
my web place
sfiks is offline   Reply With Quote
Old 12-01-2017, 09:52 AM   #57
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by o_e View Post
As I said, in my folder ..Scripts/Reaticulate there is only one folder 'actions' the others are missing. How can I get them?
Could this be an OS problem? I can't hardly believe that..
I honestly don't know what the root cause is, but it can't be just Mac because Hopi is running Windows and saw the same thing.

Hopi found that when he did a fresh portable install to another location and installed ReaPack and SWS there (all other things being equal -- including OS) he was not able to reproduce the problem and things installed fine.

If you're comfortable, it would be helpful to do a complete backup (Options / Preferences / General) and pass the resulting zip file to me. It'd help me reproduce.

Meanwhile you could install it the old manual way:
  1. Download https://github.com/jtackaberry/reati...ve/release.zip
  2. Extract the reaticulate-release folder within the zip to your REAPER Scripts/ directory -- %AppData%\REAPER\Scripts on Windows
  3. Rename reaticulate-release to Reaticulate
  4. Move jsfx/Reaticulate.jsfx up to the Effects/ directory (which exists on the same level as Scripts/) -- %AppData%\REAPER\Effects on Windows
  5. In Reaper, open the Actions dialog and click the "Load ..." button in the bottom right
  6. Navigate to Scripts/Reaticulate/actions/ and select all files in that directory, and then click the Open button

Quote:
Originally Posted by sfiks View Post
Somehow value 0 of CC1 (volume of 1st articulation) affects the 2nd articulation. The 2nd articulation doesn't get triggered - it's just gets selected on GUI.
I'm afraid I don't fully understand what you mean. Could you insert a ReaControlMIDI log after Reaticulate and show me what output events are being emitted by each of those two articulations, and then clarify what you actually expect to happen?

Thanks!
tack is offline   Reply With Quote
Old 12-01-2017, 10:30 AM   #58
o_e
Human being with feelings
 
Join Date: May 2016
Posts: 234
Default

Quote:
Originally Posted by tack View Post
If you're comfortable, it would be helpful to do a complete backup (Options / Preferences / General) and pass the resulting zip file to me. It'd help me reproduce.
What exactly do you need?
The whole ~/Library/Application Support/Reaper folder?
Is it that what you mean? It is about 240mb big..
o_e is offline   Reply With Quote
Old 12-01-2017, 05:27 PM   #59
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by o_e View Post
What exactly do you need?
The whole ~/Library/Application Support/Reaper folder?
Is it that what you mean? It is about 240mb big..
I was thinking of a configuration export (via the "Export Configuration" option from Preferences | General) but on second thought, since you have a Mac, this won't be quite as thorough as it may need to be, given I'm on PC.

I actually suspect there's a bug with ReaPack.
tack is offline   Reply With Quote
Old 12-01-2017, 09:56 PM   #60
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,304
Default

Quote:
Originally Posted by o_e View Post
When I try to install them via rightclick nothing get installed (see screenshot https://imgur.com/NXU9Wun)..
Can you send me a video or gif (http://cockos.com/licecap/) of this not working in action? If there's a bug I'd love to fix it (it works here on macOS 10.10). Does the Transaction Report dialog (shown when installation is finished) lists anything in the Errors tab?

@tack I strongly recommend packaging every required files in a single Reaticulate package. Listing every single file as individual packages begs for partial installs/updates and clutters the package list.

Index example: http://sprunge.us/FLOU (I would have suggested the @provides tag if you used reapack-index but you seem to have built the index yourself! )
Result: https://i.imgur.com/LyaJEZf.gif

Last edited by cfillion; 12-02-2017 at 05:51 AM. Reason: new gif
cfillion is online now   Reply With Quote
Old 12-02-2017, 04:18 AM   #61
o_e
Human being with feelings
 
Join Date: May 2016
Posts: 234
Default

Quote:
Originally Posted by cfillion View Post
Can you send me a video or gif (http://cockos.com/licecap/) of this not working in action? If there's a bug I'd love to fix it (it works here on macOS 10.10). Does the Transaction Report dialog (shown when installation is finished) lists anything in the Errors tab?
Which part exactly do you want to see in the gif?
o_e is offline   Reply With Quote
Old 12-02-2017, 05:12 AM   #62
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,304
Default

Quote:
Originally Posted by o_e View Post
Which part exactly do you want to see in the gif?
Trying to install the missing packages with right click > Install/update selection and it failing to install everything (with the download progress dialog visible and, at the end, Transaction report).

Like this (except here it works): https://i.imgur.com/gXmuJ9t.gif
cfillion is online now   Reply With Quote
Old 12-02-2017, 09:22 AM   #63
o_e
Human being with feelings
 
Join Date: May 2016
Posts: 234
Default

Quote:
Originally Posted by cfillion View Post
Trying to install the missing packages with right click > Install/update selection and it failing to install everything (with the download progress dialog visible and, at the end, Transaction report).

Like this (except here it works): https://i.imgur.com/gXmuJ9t.gif
I tried to make a gif of a fresh install, this time everything goes flawlessly, so sorry for the noise!
o_e is offline   Reply With Quote
Old 12-02-2017, 10:35 AM   #64
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by cfillion View Post
@tack I strongly recommend packaging every required files in a single Reaticulate package. Listing every single file as individual packages begs for partial installs/updates and clutters the package list.
Oh, yes, this makes much more sense.

The directory structure, maybe less so. I really would like Scripts/Reaticulate/{actions,app,img} but of course everything is nested under the category, so it ends up as Scripts/Reaticulate/MIDI Articulations/{actions,app,img}

I can set the category name to '.' which creates the directory tree I want, even if the ReaPack UX is a little dubious as a result. (You may have noticed that I used this kludge already to get Reaticulate-factory.reabank at the top level.)

Is there a non-kludgy way to accomplish that?

Quote:
Originally Posted by cfillion View Post
but you seem to have built the index yourself!
I did. I didn't hand-sling it of course, but a trivial python script was all it took. Ultimately it came down to my not being able to make reapack-index behave how I wanted (notably not be dependent on git commits, but also some directory structure aspects), and so I figured it would have been easier just to build my own index.

Thanks for the tip!

Unfortunately the user experience of upgrading isn't all that it might be (on Windows anyway): when I refresh the package, first a "ReaPack Query" dialog pops up warning of obsolete packages, but at the same time, a progress bar pops up over top the query dialog, hanging there at 50%. I had sat there staring at it for a good half minute, thinking ReaPack hung, when I noticed the presence of the ReaPack Query dialog, which is actually modal but yet was initially underneath the progress dialog.
tack is offline   Reply With Quote
Old 12-02-2017, 11:02 AM   #65
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

I see there is an unintended consequence to setting category name='.' which is that when I bump the version number, ReaPack ends up deleting all the files. :/

Edit: Keeping the category name but prefixing all file paths with ../ seems to work. How much am I tempting fate here?

Last edited by tack; 12-02-2017 at 11:10 AM.
tack is offline   Reply With Quote
Old 12-02-2017, 01:05 PM   #66
rogpfreck
Human being with feelings
 
Join Date: Oct 2017
Posts: 7
Default

Great job with the http://reaticulate.com/ website and video. Although haven't quite got through the Custom Bank video part as yet. That needs some serious concentration!

Installed on Mac (OS High Sierra, 10.13.1). Works well with Albion One and CS2.

Thank you!
rogpfreck is offline   Reply With Quote
Old 12-02-2017, 04:19 PM   #67
daeavelwyn
Human being with feelings
 
daeavelwyn's Avatar
 
Join Date: Dec 2014
Posts: 131
Default

OMG ! Thanks so much man for your work ! It's awsome !

A trivial question : How can I change the background color to fit more with my theme ? :-D
daeavelwyn is offline   Reply With Quote
Old 12-02-2017, 04:41 PM   #68
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by daeavelwyn View Post
A trivial question : How can I change the background color to fit more with my theme ? :-D
Hm, it should automatically use your theme's background color. Which theme are you using?
tack is offline   Reply With Quote
Old 12-02-2017, 04:46 PM   #69
daeavelwyn
Human being with feelings
 
daeavelwyn's Avatar
 
Join Date: Dec 2014
Posts: 131
Default

I'm using cubic pack 2 (https://stash.reaper.fm/theme/2016/CubicPack2.zip)

here is the screenshot : https://imgur.com/a/7NOoh

And whatever is the them i'm using it's brown ...
daeavelwyn is offline   Reply With Quote
Old 12-02-2017, 04:49 PM   #70
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 1,299
Default

A question that hasn't been asked yet: tack, where can we donate?
_Stevie_ is offline   Reply With Quote
Old 12-02-2017, 05:16 PM   #71
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by daeavelwyn View Post
And whatever is the them i'm using it's brown ...
Yeah, that was a silly bug. I've fixed it, and it'll land in the next release (I hope tomorrow), but meanwhile hopefully you can live with the horribly ugly UI.
tack is offline   Reply With Quote
Old 12-02-2017, 05:22 PM   #72
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by _Stevie_ View Post
A question that hasn't been asked yet: tack, where can we donate?
I'm truly humbled that you feel compelled to compensate me for my work! But please take all the money you're inclined to give me and instead donate it to MSF (Doctors Without Borders) [Canada / US] or the EFF.

Last edited by tack; 12-02-2017 at 05:46 PM.
tack is offline   Reply With Quote
Old 12-02-2017, 05:23 PM   #73
daeavelwyn
Human being with feelings
 
daeavelwyn's Avatar
 
Join Date: Dec 2014
Posts: 131
Default

Quote:
Originally Posted by tack View Post
Yeah, that was a silly bug. I've fixed it, and it'll land in the next release (I hope tomorrow), but meanwhile hopefully you can live with the horribly ugly UI.
Not sure I will survive
daeavelwyn is offline   Reply With Quote
Old 12-02-2017, 05:29 PM   #74
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 1,299
Default

Quote:
Originally Posted by tack View Post
I'm truly humbled that you feel compelled to compensate me for my work! But please take all the money you're inclined to give me and instead donate it to MSF (Doctors Without Borders) or the EFF.
Done!
Ah, Jason, you're such a great person! *group hug*
_Stevie_ is offline   Reply With Quote
Old 12-02-2017, 05:42 PM   #75
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Thanks Stevie.
tack is offline   Reply With Quote
Old 12-02-2017, 10:00 PM   #76
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,304
Default

Quote:
Originally Posted by tack View Post
I see there is an unintended consequence to setting category name='.' which is that when I bump the version number, ReaPack ends up deleting all the files. :/
Fixed this path parsing bug for the next update, thanks! However, category names should not contain dot, dotdot, or any other special names (such as Windows device names). There will likely be additional validation for this in the future.

Quote:
Originally Posted by tack View Post
Edit: Keeping the category name but prefixing all file paths with ../ seems to work. How much am I tempting fate here?
This is the correct way. You can go back using .. up to <resource path>/Scripts/<your repo> (type="..." on <source> or <reapack> must be used to write elsewhere than Scripts in the resource directory).

Quote:
Originally Posted by tack View Post
Unfortunately the user experience of upgrading isn't all that it might be (on Windows anyway): when I refresh the package, first a "ReaPack Query" dialog pops up warning of obsolete packages, but at the same time, a progress bar pops up over top the query dialog, hanging there at 50%. I had sat there staring at it for a good half minute, thinking ReaPack hung, when I noticed the presence of the ReaPack Query dialog, which is actually modal but yet was initially underneath the progress dialog.
This is first time I heard this happens. Is that window shown underneath the progress dialog every time for you, or was it just this one time?

Last edited by cfillion; 12-03-2017 at 08:35 AM.
cfillion is online now   Reply With Quote
Old 12-03-2017, 08:45 AM   #77
tack
Human being with feelings
 
tack's Avatar
 
Join Date: Jan 2014
Location: Ontario, Canada
Posts: 451
Default

Quote:
Originally Posted by cfillion View Post
This is first time I heard this happens. Is that window shown underneath the progress dialog every time for you, or was it just this one time?
It's consistent:

https://www.youtube.com/watch?v=wMSrQBZkxUk
tack is offline   Reply With Quote
Old 12-03-2017, 09:53 AM   #78
sfiks
Human being with feelings
 
sfiks's Avatar
 
Join Date: Dec 2012
Location: NY
Posts: 115
Default

Thanks again, Jason!
I don't have 88 keys keyboard and it was always clumsy
to work with XSample library play instruments using key-switches.
Not anymore! I continue working on articulations for those!

Here are 23 out of 48 articulations for
XSample Solo strings score instruments.
(If somebody's interested, let me know and I'll expand it

//----------------XSample/Strings score ----------------

//! g="XSample/strings" n="strings score"
Bank 02 1 Strings score

//! c=legato i=vibrato g=3 o=cc:00,00
00 vibrato cc1

//! c=legato i=legato-vibrato g=3 o=cc:00,01
01 senza vibrato cc1

//! c=default i=vibrato-con-sord g=3 o=cc:00,02
02 vibrato con sord. cc1

//! c=default i=legato-vibrato g=3 o=cc:00,03
03 senza vibrato con sord. cc1

//! c=long i=tremolo g=3 o=cc:00,04
04 tremolo cc1

//! c=long i=harmonics g=3 o=cc:00,05
05 harmonics cc1

//! c=short i=spiccato g=3 o=cc:00,06
06 spiccato velocity

//! c=short i=marcato-quarter g=3 o=cc:00,07
07 marcato velocity

//! c=textured i=pizz g=3 o=cc:00,08
08 pizz. velocity

//! c=textured i=pizz-bartok g=3 o=cc:00,09
09 pizz. bartok velocity

//! c=textured i=col-legno g=3 o=cc:00,10
10 col legno velocity

//! c=fx i=fx g=3 o=cc:00,11
11 finger velocity

//! c=fx i=note-sixteenth g=3 o=cc:00,12
12 sul pont. short velocity (C-b, V-c)

//! c=fx i=sul-pont g=3 o=cc:00,13
13 sul pont. cc1

//! c=fx i=tremolo-sul-pont g=3 o=cc:00,14
14 sul pont. tremolo cc1

//! c=fx i=tremolo-harmonics g=3 o=cc:00,15
15 harmonics tremolo cc1

//! c=fx i=legato-gliss g=3 o=cc:00,16
16 harmonics gliss. cc1

//! c=default i=legato-gliss g=3 o=cc:00,17
17 harmonics gliss. con sord. cc1

//! c=fx i=tremolo-harmonics-a g=3 o=cc:00,18
18 harmonics gliss. tremolo cc1

//! c=default i=tremolo-harmonics-a g=3 o=cc:00,19
19 harmonics gliss. tremolo con sord. cc1 (C-b)

//! c=fx i=legato-gliss g=3 o=cc:00,20
20 harmonics gliss. artificial cc1 (V-no, V-la)

//! c=fx i=run-major g=3 o=cc:00,21
21 glissandi cc1 (V-c)

//! c=default i=run-major g=3 o=cc:00,22
22 glissandi con sord. cc1 (V-c)

//! c=fx i=run-major g=3 o=cc:00,23
23 short gliss. cc1 (C-b)
__________________
my web place
sfiks is offline   Reply With Quote
Old 12-03-2017, 10:21 AM   #79
cfillion
Human being with feelings
 
cfillion's Avatar
 
Join Date: May 2015
Location: Québec, Canada
Posts: 2,304
Default

Quote:
Originally Posted by tack View Post
Ah yes, I see what's causing this (fixed for next update). Thanks for the video! It only happens when downloading the index + finding the obsolete packages is quicker than the progress dialog opening delay (100ms).

(It's less likely to happen when using Synchronize packages.)

Last edited by cfillion; 12-03-2017 at 11:22 AM.
cfillion is online now   Reply With Quote
Old 12-03-2017, 01:17 PM   #80
sfiks
Human being with feelings
 
sfiks's Avatar
 
Join Date: Dec 2012
Location: NY
Posts: 115
Default

Here is a quick demo with XSample V-no I (play instrument)
Full screen is recommended

sfiks is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:22 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.