Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 05-08-2019, 08:15 PM   #1
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default Help! Very weird 'error creating project file' and offline items issues Mojave

Hi everyone,

I'm experiencing a really strange behavior here at the end of a recording session, and after days searching the web I still can't find any fix and I'm on the verge of dispair... So thanks a lot if someone here can help me !
Hope it's the right place to post..

I'm running reaper64 on a Mojave i9 32g MBP, and all the weird stuff happens only on one session.
The faulty project is 6 songs and all the tracking is done. Drums were recorded at a friends' studio with a saffire pro 40 with an older MBP (late 2011 Mavericks), guitars bass and vocals were tracked home with my apollo twin. All drums and strings have been edited on the fly so the total amount of items is quite large
Things have been a bit messier than usual (using different computers, other people handling the software..), so even though i'm ever so careful, I can't be 100% sure I've not messed around with something. Anyway tracking went fine until the end, and the problems appeared on the next day.
I'm running only authorized 64bit AU and VST plugins and cpu and ram usage is low.

So reaper behaves like this:

Loading the project with 'recent project' menu loads the project with all drums and strings items online and all vocals items offline
Loading the project with Open>select rpp file loads the project with all items online except the last folder of 3 vocals tracks. Loading the project by double clicking in finder behaves the same.
Loading the project via Open>Open with all fx offline (recovery mode) causes reaper to crash after prompting the offline plugin window
With no plugin in the components and vst folders, reaper crashes on load no matter which way the project is laoded.

Working on project is fine for a while but reaper suddenly crashes at apparently random actions.
After Save or Save as, reaper either crashes, or more often starts to behave very weird and slow (playback does not start, mouse modifiers behave weird, impossible to Close Project, Quit Reaper, or open another project, shortcuts in menus are replaced by '?',..). Then reaper either crashes at random actions or freezes, and the only thing I can do is Force Quit the app (reaper doesn't appear as '(not responding)' in the force quit window)
Now and then a peak building window pops up, and eventually the "Error Creating Project File" message will show
I've tried checking and unchecking every auto-save preferences boxes, but there seem to be no way to have anything saved

Copying project files to a different folder or external drive changes nothing.
Uninstalling and re-installing reaper changes nothing.
No scripts are running.
Changing audio device from the twin to the aggregate device changes nothing.
Impossible to load session from external drive on 2011 MPB (Critical Memory Error message)
Project Settings>Path to save media files causes reaper to crash on clicking the Browse button

I cannot even remember all the things I tried, and I understand that it might be a saving path issue, or a 'too many items to handle' problem. But nothing I've tried seems to do the trick and I'm stuck. All the audio files seem to be there in the folder but I just can't do nothing with this session !

Please someone tell me there's something I can do!


Crash logs I find in Console are too long to be posted here

EDIT : I don't know if this is relevant or not, but i'm using EasyOnTheEyes Theme
EDIT 2 : I've been really happy with everything I've done since I got the new MBP like two month ago. I havent been quite air gapped on this particular recording session, and used shared connections with windows phones, could it explain something ?

Last edited by mrrenard; 05-09-2019 at 02:39 PM.
mrrenard is offline   Reply With Quote
Old 05-08-2019, 08:29 PM   #2
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default

https://drive.google.com/file/d/1ull...ew?usp=sharing
mrrenard is offline   Reply With Quote
Old 05-09-2019, 04:56 AM   #3
mespotine
Human being with feelings
 
mespotine's Avatar
 
Join Date: May 2017
Location: Leipzig, Germany
Posts: 1,202
Default

Did it work before and if yes, which Reaper-version was the one, where the problematic behavior started?
__________________
Ultraschall-API - a Lua-functions-library4Reaper: https://forum.cockos.com/showthread....98#post2067798
Reaper Internals - Developerdocs4Reaper: https://forum.cockos.com/showthread.php?t=207635
mespotine is offline   Reply With Quote
Old 05-09-2019, 07:24 AM   #4
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default

Hi
Everything worked fine until the day after tracking was done. I don't remember which version it was exactly but it was last wednesday and I think there's been only 2 updates since then
My reaper is now up to date as I've re-installed and it several times and repaired permissions

Please tell me if it's not the right place to post or if I missed important informations !


PS : i cannot paste crash reports here (looks like they're too long for the forum to handle) but i'll be happy to upload other print screens of specific crashing scenarios if that helps. Please tell me what would be needed.

Last edited by mrrenard; 05-09-2019 at 07:29 AM.
mrrenard is offline   Reply With Quote
Old 05-09-2019, 07:47 AM   #5
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default

It may (or may not - I don't know) be related to what is discussed here :

https://forum.cockos.com/showthread.php?t=175046

or here

https://forum.cockos.com/showthread.php?t=116137


But again I've already tried everything I could think of, and nothing seems to allow me to work on the project and save changes
mrrenard is offline   Reply With Quote
Old 05-09-2019, 02:15 PM   #6
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default

Anyone here has an idea of what could explain this behavior and/or what to do to fix it ?
Please help me save 11 precious days of hard work !
+ I have a recording session this weekend and I'd like to be sure it's going to work...

Last edited by mrrenard; 05-09-2019 at 02:34 PM.
mrrenard is offline   Reply With Quote
Old 05-10-2019, 06:26 AM   #7
mespotine
Human being with feelings
 
mespotine's Avatar
 
Join Date: May 2017
Location: Leipzig, Germany
Posts: 1,202
Default

You can split the crash-report into multiple posts. This should help Justin to find out, what is happening.
__________________
Ultraschall-API - a Lua-functions-library4Reaper: https://forum.cockos.com/showthread....98#post2067798
Reaper Internals - Developerdocs4Reaper: https://forum.cockos.com/showthread.php?t=207635
mespotine is offline   Reply With Quote
Old 05-11-2019, 06:21 AM   #8
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default

Hey!
First of all thanks a lot to you mespotine for not letting me alone in my shit storm !

My question was exactly which part of which crashing scenario log was needed, because I have dozens of crashlogs and I wanted to be sure to put here only relevant material..
So I went back to the studio today to try stuff again and decided to upload here only those from today.

So what I did today was try to not copy all the files but move them to a new folder on desktop. Behavior was identical. BUT I then tried to copy only the .rpp file directly to the desktop and this allowed me to do a Save As with create a new folder and copy all files ! This also let me see the exact count of items in the project when building peaks : 34293 (see picture in folder)
I was finally able to work some changes on this new copy of the project and save ! Even the last 3 tracks were online. For a few minutes I really thought my pain was over, until reaper crashed the first time i tried to open a plugin. (see crashlog in folder).
In the present session I have only trusty fabfilter plugins, with a few instances of one uad plugin and only one instance of soundtoys decapitator. With this new copy of the project which behaves a little better, I was able to open it on recovery mode and I could bring every plugin back online one by one without reaper crashing.

Eventually reaper became slow again after a save and went back to the weird behavior (impossible to close project or quit, funny stuff showing in menus, playback not starting) and finally crashed when trying to open a plugin window (see crashlog in folder)

I tried to freeze tracks, hoping that diminishing the number of items would help but rendering did not start : No render target file - target drive/ path does not exist, is unavailable, or in use. (see picture in folder)

Here's the folder with crashlogs and picture :
https://drive.google.com/open?id=1FH...6hYlUwC1VwM8Ma

I've also noticed that the present version of reaper is 5.97. Is Reaper 6 coming soon and could it explain the weird behavior ? I've been working with this software for almost 10 years now and never had such headaches...

Again, thanks a lot to anyone who is ok to take time and try to help. I'm not really a computer guy and never had to be one to work with this amazing software, this is very, very confusing to me..
mrrenard is offline   Reply With Quote
Old 05-23-2019, 08:23 AM   #9
mrrenard
Human being with feelings
 
Join Date: Feb 2012
Posts: 17
Default

hi everyone

this is the first time I have such a problem and need such help so it's possible i'm doing it wrong.
I have fist done intensive research during a week, then tried to be as thorough and precise as possible (describing every scenario, giving crashlogs and printscreens, etc..) so that people who know these stuffs could have all that's needed to try and understand the matter.

I don't know how to interpret the dead silence on this 'once in a lifetime issue' thread.
I've always heard that the best thing about Reaper was the amazing community behind it, but i'm sorry to have to admit that it does not work for me so far.

So please if anyone can be kind enough to explain to me what I'm doing wrong
I just can't believe that 11 days of hard work are just useless for no apparent reason !

BIG BIG THANKS to anyone who has any sort of input !!
mrrenard is offline   Reply With Quote
Old 05-24-2019, 05:59 AM   #10
Ollie
Super Moderator (no feelings)
 
Ollie's Avatar
 
Join Date: Dec 2007
Location: On or near a dike
Posts: 9,710
Default

Quote:
Originally Posted by mrrenard View Post
Loading the project with 'recent project' menu loads the project with all drums and strings items online and all vocals items offline
Loading the project with Open>select rpp file loads the project with all items online except the last folder of 3 vocals tracks. Loading the project by double clicking in finder behaves the same.
Loading the project via Open>Open with all fx offline (recovery mode) causes reaper to crash after prompting the offline plugin window
With no plugin in the components and vst folders, reaper crashes on load no matter which way the project is laoded.

[...]

All the audio files seem to be there in the folder but I just can't do nothing with this session !
I'd focus first on the offline (=missing) files (edit: looks like you did already). That the folder contains the files doesn't help with wrong path references stored in the .RPP. The only thing you could do to fix that is either editing the paths in an editor, or re-importing these files into the project and saving the project (with a new name so you don't destroy the original .RPP).

Same goes for the missing render path, which is stored in the .RPP as well. Even if the path seems right, the volume names might be different on different computers.

Re the crashes, your logs show an (at least to me) elusive exception and varying Fabfilter plug-ins in the same thread, which may or may not be involved in the crash. However they are all AU plug-ins and I think it's still recommendable to use VST instead, for stability.

The most interesting part in the crash reporter logs is always the header with the thread information below. Your screenshot shows a crash in thread 2 but cuts off where it gets interesting.

Generally, working on a project on different computers can bring issues when e.g. the plug-in versions differ (one version may write config chunks that make the other version stall) or their location varies, and resources and paths differing between the computers can cause headaches too.

Recording multiple songs in the same project isn't always recommendable, at least not if they are fairly complex and threaten to end up with big masses of media files, lots of tracks and plug-ins etc.. One screenshot shows that there are more than 34,000 items in the project, that and that your older Macbook doesn't even want to load it indicate that this project might be pushing things to (and maybe beyond) the available resources.
Ollie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:50 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.