Old 05-11-2013, 12:07 PM   #1
tlindstrom
Human being with feelings
 
Join Date: Dec 2012
Posts: 7
Default KONTAKT not responding to MIDI keyboard (SOLVED)

Hello! My KONTAKT 4 and KONTAKT 5 samplers do not seem to respond to MIDI signals from my keyboard controller. The channel does respond to the keyboard it seems, but instead of a thick, normal volume signal, I get a thin red line, what is this?

Playing the virtual piano in Kontakt does make sound, and inputting notes manually in the piano roll also works. Notes input by the keyboard however, are muted, and do not make a sound.

All my other VSTs, including other Native Instruments products, work as they should.

I've also tried in FL Studio, where everything works as it should.

I have no idea what is going on, I have a feeling I'm overlooking something very obvious... Anyone?
tlindstrom is offline   Reply With Quote
Old 05-11-2013, 12:12 PM   #2
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 16,505
Default

That is showing the velocity of the incoming MIDI notes.

If the Kontakt keyboard and Reaper's MIDI Editor piano roll are triggering sounds then it sounds like your keyboard is sending notes on a different MIDI channel

Record some notes and View them in the Event List. Then make sure that the MIDI Channel in your Kontakt instrument is set to the same channel.
__________________
DarkStar ... interesting, if true. Inspired by ...

My top 40 FRs, as voted by you (updated for August 2016)
DarkStar is online now   Reply With Quote
Old 05-11-2013, 01:38 PM   #3
tlindstrom
Human being with feelings
 
Join Date: Dec 2012
Posts: 7
Default

Thanks a lot!!! That was indeed the problem, I set my Kontakt instrument to OMNI, and then it worked.

My keyboard sends its signals to channel 7, while Kontakt was only reading channel 1. (While in FL Studio and Cubase, it seems my keyboard uses channel 1, or maybe all the channels)

A follow-up question then, how do I control what channel my MIDI controller sends to? Seems really basic, but I don't understand how to do this!
tlindstrom is offline   Reply With Quote
Old 05-12-2013, 01:08 AM   #4
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 16,505
Default

So, in Reaper, the recorded notes are on MIDI Channel 07, but in FL Studio and Cubase they are on MIDI channel 01? That seems odd - unless you are forcing them onto Channel 07 in Reaper (or to 01 in the others).

To check, right-click the RecArm button, select, Input:MIDI, then "Map Input to channel", and select "All channels".

From what you have said, you should not need to change the channel, but most MIDI controller keyboard let you change the MIDI channel. Read the ....

(You didn't mention which controller you have.)
__________________
DarkStar ... interesting, if true. Inspired by ...

My top 40 FRs, as voted by you (updated for August 2016)
DarkStar is online now   Reply With Quote
Old 05-12-2013, 05:19 AM   #5
tlindstrom
Human being with feelings
 
Join Date: Dec 2012
Posts: 7
Default

Ah, that's it, the MIDI controller (M-Audio ProKeys 88) had its channel set to 7. I didn't consider the possibility that this could be controlled from there.. That's what I get for never properly learning how MIDI and sound routing works...

Anyway, thanks again!! Problem resolved 100%
tlindstrom is offline   Reply With Quote
Old 05-09-2015, 05:56 PM   #6
aspiringSynthesisingAlch
Human being with feelings
 
Join Date: Feb 2014
Posts: 277
Thumbs down kontakt 5 + no midi in...

I'm the latest sufferer on this particular annoyance.

I'm trying the standalone and still even midi learns aren't being detected.

file > options > midi lists my MK-461 USB MIDI KEYBOARD (currently port a)
all midi outputs are off.

with the (v)keyboard I can play one note at a time

however, even with midi set to omni / confirmed midi channel on keyboard, nothing is recognised, the MIDIjack doesn't light up like it does when vmidi is detected and played..

win 7 x64 (currently asio4all with behringer usb, reasynth works ok with midi, just trying to learn some multi-timbral )



strange, no?
aspiringSynthesisingAlch is offline   Reply With Quote
Old 05-11-2015, 07:21 AM   #7
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Posts: 10,433
Default

Quote:
Originally Posted by aspiringSynthesisingAlch View Post
I'm trying the standalone and still even midi learns aren't being detected.

file > options > midi lists my MK-461 USB MIDI KEYBOARD (currently port a)
all midi outputs are off.

with the (v)keyboard I can play one note at a time
Humm, if Kontakt lists your keyboard, then it should also be learning the midi. Which controls are you trying to get to Learn Midi?

Quote:
however, even with midi set to omni / confirmed midi channel on keyboard, nothing is recognised, the MIDIjack doesn't light up like it does when vmidi is detected and played..

win 7 x64 (currently asio4all with behringer usb, reasynth works ok with midi, just trying to learn some multi-timbral )
I'm totally confused what you're saying hear. What does your behringer have to do with it, if your Keyboard is USB?

If you're getting Reasynth to work in Reaper then you should also be able to get Kontakt to work?

Maybe try explain your setup and problems a little better.
Tod is offline   Reply With Quote
Old 05-15-2015, 07:04 AM   #8
aspiringSynthesisingAlch
Human being with feelings
 
Join Date: Feb 2014
Posts: 277
Default solved - midi kontakt

Sorted, there's another option ya need to set...
Options > Engine > send MIDI to outside world...

Quote:
I'm totally confused what you're saying hear. What does your behringer have to do with it, if your Keyboard is USB?
I should have said behringer USB audio interface
aspiringSynthesisingAlch is offline   Reply With Quote
Old 05-17-2015, 08:45 PM   #9
tofran
Human being with feelings
 
Join Date: May 2015
Posts: 2
Default

I found this first post similar to my problem I guess. I don't know if it right place to ask and if anybody can help me. I am sorry if I am postin this in wrong one. I am totally new to REAPER.
I run win8 and I wanted to use Syphonic Choir with Wordbuild. I normaly use Abletone 8 Live and I coulden't find a way to run this under this enviromnet I found easy tutorial doing this with Reaper on Youtube. After some time I got it working but only with Virtual Keyboard. My MIDI contorller M-AUDIO Keystation 61 refuses to cooporate in the way I wish to... similar to the first post. I run easly some of my VSTs (Eighty Eight2) I can hear and play and record no problems, but if I try say Xpand2 it shows me only the red little lines when I hit keybord (this works only with Virtual keybord, Same symphonic choir routed with Wordbuild. I have BEHRINGER GUITAR LINK USB as Audio Device and I have my headphones connected to it. I enable all MIDI devices. i don't simply know what is wrong... Please if you know what to do, give me step by step instruction as I am totally new to it.

regards
tofran is offline   Reply With Quote
Old 05-19-2015, 04:18 PM   #10
Tod
Human being with feelings
 
Tod's Avatar
 
Join Date: Jan 2010
Posts: 10,433
Thumbs up

Quote:
Originally Posted by tofran View Post
Please if you know what to do, give me step by step instruction as I am totally new to it.
Hi tofran, and welcome to the forum.

I don't know if I can help you or not but I'll try to point out a few things.

>Preferences>Audio>MIDI Devices: Make sure your devices are there and enabled.

Quote:
After some time I got it working but only with Virtual Keyboard.
Well if you got it working with the virtual keyboard then it must be a matter of your input settings, as long as you've got Device settings that I show above set up correctly.

On your midi track, right click on the Arm button and select Input: MIDI>Your Midi selected in MIDI Devices>All Channels.

Then Arm the track and right click on it again. This time select Monitor Input.

Now you should be able to hear when you play your keyboard. If you can't, then click on the I/O button and make sure you've got your VSTi set up as a Send. If not then just select your VSTi track as a Send and set the Audio:Non _ MIDI:All=>X, "X" being the midi channel you want to go to your VSTi.

Tod is offline   Reply With Quote
Old 05-23-2015, 12:21 AM   #11
tofran
Human being with feelings
 
Join Date: May 2015
Posts: 2
Default

Hi Tod,
Thank you for your reply. I have tried all of this before... I found some old posts on other sites mentioning 'compatibility' problems that particular Xpand VST can cause... I managed to get it working with virtual keyboard at least. I will be still experimenting.
Thank you
tofran is offline   Reply With Quote
Old 05-24-2017, 04:38 AM   #12
Teebs
Human being with feelings
 
Teebs's Avatar
 
Join Date: Mar 2013
Location: Bomaderry. New South Wales
Posts: 16
Default

Hi there hope someone can help not sure if im in the right place,
I'm getting no sound from abbey road drummer. I was able to get Kontakt to learn no problems. but when i play there's no sound I hit record all the Midi data is in the right place but no sound. yet if i manually draw a note in the same midi item it reads it and there is sound. but not when it came from my v drums.
this is not an issue with superior drummer.
Any help would be appreciated thanks in advance
it's driving me nuts.
Teebs is offline   Reply With Quote
Old 05-24-2017, 04:44 AM   #13
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 16,505
Default

V drums is probably sending the MIDI notes out on MIDI channel 10. Change the MIDI channel for the Abbey Road instrument in Kontakt to 10.

When you draw in a MIDI note, by default it will be on MIDI channel 1 (and I reckon that that is what Abbey Road is currently set to).
__________________
DarkStar ... interesting, if true. Inspired by ...

My top 40 FRs, as voted by you (updated for August 2016)
DarkStar is online now   Reply With Quote
Old 05-24-2017, 06:19 AM   #14
Teebs
Human being with feelings
 
Teebs's Avatar
 
Join Date: Mar 2013
Location: Bomaderry. New South Wales
Posts: 16
Default

Wow!

thank you so much. that's all it was
much appreciated.
Teebs is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.