Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 06-13-2017, 04:01 AM   #1
artao
Human being with feelings
 
Join Date: May 2014
Posts: 64
Default [SOLVED] Audio Routed to SOME Effects (and synths) Simply Passing Thru Unprocessed

SOLVED ---- It's entirely an issue with Reaper's incredibly flexible (but also complicated and confusing) routing system, combined with how it treats VSTi and VST plugins differently. It's all about the routing, both audio in and the plugin's pin routing.
Solution is here >> http://forum.cockos.com/showthread.php?t=173586
Also, there is a video showing how >> https://youtu.be/atCnoFGu1mI

Okay. Please bear with me here. (NOTE: I added a video for clarity. This is a totally new project however, not the one I describe below. It still shows the problem just fine tho >> https://youtu.be/-DLlk88vVYU )
So today I decided to play with envelope followers. So I make a track with my mic as input, then make another track with the Arturia Arp 2600V. I route the audio from the mic track to the synth track.
To make things easier on myself, I recorded some audio into the mic track so I didn't have to keep making sounds into the mic while figuring this stuff out.
It took awhile to figure out exactly how to use it, but I was able to route the mic audio via the envelope follower to the cutoff of the VCF. That's all fine and good. Okay.
HOWEVER! I am also hearing the raw audio from the mic. I have turned off Master Send on the mic track, and set the Receive on the synth track to Pre-Fader.
I do not want to hear the mic coming out of my synth track. I only want the mic audio to affect the synth via the envelope follower I set up.

To double check my setup and make sure it wasn't some weirdness with the Arp 2600V, I then created another track with Reaktor 6 on it, and loaded up the included Classic Vocoder ensemble. Then I routed the mic track into this new track, again pre-fader.
I definitely get vocoder sounds, but AGAIN!! I'm also getting the raw unprocessed mic sound coming out of my vocoder track.
WTF is going on here. This is NOT the behavior I expect, and I cannot figure out for the life of me how to make it stop.

AGAIN to double check myself, I created yet another track, but this time simply put an effect on it (Corkscrew chorus effect) and again routed the mic track to this new effects-only track. With THAT one now, I'm only getting the processed audio, not the raw mic sound.
This is exceedingly frustrating.

If I set either the synth or the vocoder to input audio rather than MIDI, then I can't control them with my MIDI keyboard. That makes it virtually useless unless I want to program everything on the piano roll or a sequencer. ... And, of course, doing so makes absolutely no difference regarding the raw mic audio passing straight thru to the track output.

To check myself further, I put TAL Vocoder II on another new track and did the mic-to-track routing exactly the same as with the others. THIS time, I only get the vocoder effect, not the raw mic audio. And I of course had to switch the input to MIDI so I could control the vocoder. Works just fine there.

So again, I made a new track and loaded Reaktor 6 into it, then loaded a distortion effect in Reaktor (as opposed to an instrument). AGAIN I get the raw mic audio passing straight thru, unprocessed, as well as the Reaktor processed audio. If I turn down/off the distortion effect completely, I STILL hear the raw mic audio. And Reaper's built-in wet/dry control is set to entirely wet, so that's not the issue.

So I made ANOTHER track, this time with ReaPitch on it. This time, I get no raw mic audio passed thru. Only the processed audio. If I turn the wet and dry outputs down, I get no audio whatsoever.

THEN I decided to be clever, and deleted ALL of the tracks except the recorded mic track. I made a second track and, as before, routed the mic to it pre-fader.
On this new track, I put ReaPitch and set it to something wild, just to be sure I was hearing the effect and only the effect.
That's all I got.
SO! On the exact same track, I then inserted Reaktor 6 after ReaPitch. I also disabled ReaPitch (but left it on the track). I loaded up a user ensemble (Distorbox) and again set it to some wild settings so I could be sure I was hearing the effect.
Well, I certainly heard the effect, but I also heard the raw mic audio passed thru it.
So I re-enable ReaPitch, and, sure enough, now I get the ReaPitch affected audio going thru Distorbox (Reaktor), but at the same time I'm ALSO getting the ReaPitch affected audio passing straight thru/past Reaktor. I know this because I tried turning off Distorbox in several different ways: from turning the volume all the way down to bypassing it to turning off Reaktor's audio engine.
Every. Single. Time!!! The audio just passes right by/thru Reaktor as if it isn't there.
So I add another straight effect (Therapy, which is inherently wild and unpredictable) after Reaktor, and disable Reaktor and ReaPitch.
Sure enough, I get ONLY the audio processed by Therapy. Enable ReaPitch, I get both effects in serial. Enable Reaktor, I get all three in serial BUT! I also still get ReaPitch passing straight thru Reaktor unprocessed and into Therapy. I know this because, again, I tried turning down/off Reaktor (Distorbox) in numerous ways. And yep! There's the ReaPitch audio passing right thru Reaktor unaltered. With Distorbox turned back up, it seems I get BOTH the ReaPitch audio AND the Distorbox audio flowing into Therapy.
GGAAAAAHHHHHHHHH >
This is making me want to smash stuff. Seriously. SMASH!!!! >
From what I'm experiencing, this makes Reaktor virtually useless as an effects processor. But I recall using it before as such without this problem, so I don't know what's going on here.

So what the hell IS going on here? This is exceedingly, EXCEEDINGLY irritating and frustrating. This makes absolutely no sense to me. Why are some plugins (particularly Reaktor) simply passing the raw mic audio directly thru? I have set every single track up in EXACTLY the same way every time. Some of them pass the audio straight thru along with the processed audio, and some don't. GAAAHHHHH >
This can't possibly be right. I've clearly done something wrong, but for the life of me cannot figure out what.
I'm quite possibly doing something totally obvious and idiotic, but what? I've never before had this problem.

Last edited by artao; 06-14-2017 at 12:40 AM. Reason: problem solved
artao is offline   Reply With Quote
Old 06-13-2017, 05:42 AM   #2
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Germany
Posts: 3,088
Default

I don't decently understand the issue, but did you take a look at the pin routing in a multiple channel track ? (just click on the {2 in 2 out] or similar button at a plugin's header and then the small [+]....

-Michael
__________________
www.boa-sorte.de
mschnell is online now   Reply With Quote
Old 06-13-2017, 07:56 AM   #3
artao
Human being with feelings
 
Join Date: May 2014
Posts: 64
Default

Okay, so I made a video showing this problem. This is an entirely new project from what I described above. A far simpler project, but it shows the issue perfectly well, I think.

https://youtu.be/-DLlk88vVYU

Quote:
Originally Posted by mschnell View Post
I don't decently understand the issue, but did you take a look at the pin routing in a multiple channel track ? (just click on the {2 in 2 out] or similar button at a plugin's header and then the small [+]....

-Michael
I hadn't looked at the pin config. Good idea. I did so now, and nothing I did made any difference. Thanks tho, I hadn't thought of looking there.

It's so weird, because I've never encountered this problem before.
artao is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.