Old 06-15-2017, 06:41 PM   #1
Publicradio
Human being with feelings
 
Join Date: Apr 2008
Posts: 123
Default Prevent muting when record-disarming a MIDI track

When I disarm a MIDI track, I understand that the track would send an 'all notes off' message. Otherwise, if I was holding down a key when I disarmed, or a recorded key was playing back, it would just sustain forever.

However, when I disarm a track, the whole track becomes muted. I would like the notes to get cut off, but for the final release, or reverb tail, to finish playing.

I guess I would want this for audio tracks, too: the audio cuts off, but the reverb tail finishes unless I actually mute the track. Is this possible?
Publicradio is offline   Reply With Quote
Old 06-16-2017, 02:27 AM   #2
slipstick
Human being with feelings
 
Join Date: Apr 2016
Location: UK, near Europe
Posts: 625
Default

Isn't that going to depend on the instrument/VSTi that you're using not on Reaper? The synths I've used don't cut the sound off when you disarm recording, they play to the end of the current note release.

Steve
slipstick is online now   Reply With Quote
Old 06-17-2017, 05:16 PM   #3
Publicradio
Human being with feelings
 
Join Date: Apr 2008
Posts: 123
Default

Really? They cut off for me no matter what VSTi I use. In fact, it will hold the release until I re-arm the track. So If I'm playing a patch with a 1 second release tail, disarming the track will mute the track completely, but even if I come back an hour later and re-arm it, it will immediately play the end of the release tail.

This is even true if I have the VSTi sending to another track with reverb on it. Disarming will mute the track and the send, and then when I re-arm I'll hear the release and the reverb tail.
Publicradio is offline   Reply With Quote
Old 06-17-2017, 11:13 PM   #4
mschnell
Human being with feelings
 
mschnell's Avatar
 
Join Date: Jun 2013
Location: Germany
Posts: 3,222
Default

Quote:
Originally Posted by Publicradio View Post
Disarming will mute the track and the send, and then when I re-arm I'll hear the release and the reverb tail.
So the VSTs are stopped (getting no Sample clock). This is the normal (but configurable) behavior with (un-)mute, but AFAIR not with (dis-)arm.

-Michael
__________________
www.boa-sorte.de
mschnell is offline   Reply With Quote
Old 06-18-2017, 05:21 AM   #5
Publicradio
Human being with feelings
 
Join Date: Apr 2008
Posts: 123
Default

OK, I think I found it. In preferences, there's a setting that says 'Run FX when stopped (good for certain VSTi)' and in my settings it is unchecked. When I check this, release and reverb tails play through.
Publicradio is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:08 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.