COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 03-29-2014, 11:00 AM   #1
dbroc
Human being with feelings
 
Join Date: Mar 2014
Posts: 4
Default shift problem with ninjam

hello

System configurations: Mac OS X Snow Leapard and Lion

I'm just trying Ninjam with a friend over the internet for the 1st time
We have both good bandwidth
I have installed a private server
Everything seems to work fine
We are both connected and play together

BUT

whatever is the BPI, one hear the other with a shift!?
For example, with a BPI=8
- for the first user, everything is good: the 1st beat of the remote user starts at the 1st beat of the next measure
- for the remote user, the 1st beat of the other user starts in the middle of the next measure (or the current measure), anywhere (beat 3, 4 etc) !!

When we disconnect and try again, sometimes it is the opposite!

I have looked after many posts but I did'nt find anyone who had the same problem

Thank you
dbroc is offline   Reply With Quote
Old 03-29-2014, 03:34 PM   #2
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 576
Default

My gut reaction is to say "it's a latency problem" (but given it's on MacOS, I'm surprised). I think you're maybe using local monitoring rather than hearing your local sounds through ninjam. Your signal path must be:

source => computer => ninjam => ears

You can't do "source => ears" before that and expect it to work well, so check you're definitely only able to hear your local sound through ninjam (e.g. if you mute yourself in ninjam you shouldn't hear yourself).

If it's not just a latency problem, it's something very strange... Can you try out on one of the public servers and see if there's anyone there who can help?
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is offline   Reply With Quote
Old 03-30-2014, 01:55 AM   #3
dbroc
Human being with feelings
 
Join Date: Mar 2014
Posts: 4
Default

thank you for your answer

We tried several things, such as clicking on each button, disconnecting/reconnecting and so on

I am not sure to understand exactly what actions do you suggest?
Just "mute" the inputs should resolve our problem?


How to contact people on "public servers"? Sorry we are very new here!
dbroc is offline   Reply With Quote
Old 03-30-2014, 03:22 AM   #4
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 576
Default

I am still trying to work out what the cause of the problem is - I have not yet suggested a solution. I'm trying to eliminate a common cause.

You have a sound source - e.g. a guitar - plugged into your computer.

Many sound cards have a "local monitor" option which routes the sound coming in directly to the sound output.

That effectively bypasses the computer (and hence ninjam).

However, you must not do this. You will have to check your sound card settings to see whether it has this feature, whether it is on or off and how to turn it off.

Also, make sure you are using headphones that stop you hearing anything that is happening locally. The only way sound should get to your ears is through the sound card output (and hence your headphones).

Once the sound gets from your sound card it gets to ninjam somehow. I am assuming you are not using Reaper as you didn't list it. So I am assuming you are using the ninjam standalone client. (Reaper is much nicer.)

In the standalone client, when you connect, you will see your local channel(s) at the top and any remote channels for other participants on the server you have connected below, with chat to the right.

You should be able to hear three things:
- the metronome
- your local sound
- any remote sound

There is an overall mute "button" (check box). If you press this, you should hear none of the above.

Each of the above has its own mute button, too. So pressing that mute button should just stop you hearing that item. (Don't leave the metronome muted.)

The test you are doing here can use either the overall mute button or the local mute button(s) but either way, you should not hear yourself when these are muted.

The client can also record your session locally, which may help trying to work out what is happening - see Options->Preferences.

The public servers are listed on the Cockos ninjam site. Go to http://www.cockos.com/ninjam/ and click the link labelled "public servers" at the top.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is offline   Reply With Quote
Old 04-01-2014, 12:41 AM   #5
dbroc
Human being with feelings
 
Join Date: Mar 2014
Posts: 4
Default

Thank you

Yes, we have already tried all ninjam options and buttons, preferences and so on (channels, mute all/one, metronome, output.wav etc)
We also used headphones
We don't use Reaper yet, because we understand that it is not mandatory and that ninjam should work nicely with just the standalone version

As a conclusion, you mean the sound card should have to be configured
But we use only the built-in sound cards of Macbook pro's, that cannot be configured (not with the standard OS options anyway). Could it be the problem in itself?
I would be quite surprised because I found no post explaining that we have to buy a wonderful soundcard in order ninjam to work correctly!?

We did not try a public server yet but we will!


Again, thank you very much trying to help!
We are going to continue our tests
dbroc is offline   Reply With Quote
Old 04-01-2014, 03:59 AM   #6
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 576
Default

Yeah, Macs generally suffer no problems but latency issues are so common it was worth a go dismissing it. If you've tried the test I suggested (mute yourself in ninjam and that stops you hearing yourself) and it works, then it shouldn't be an issue.

That leaves me a bit lost.

You're saying if you play in 8bpi and play an eight note scale, one note per beat of the metronome starting at the beginning of an interval, say "C D E F G A B C", then the remote user will hear you play "_ _ _ C D E F G" and the rest "overflowing" into the next interval?

But if the remote user plays "C D E F G A B C" starting at the beginning of an interval (i.e. just what you played), you will hear it starting at the beginning of an interval (i.e. correctly)?

And it can be either way around at random?

Try to find a public server with someone willing to help (ask in chat). Each of the two of you should ask what the third participant hears. That may narrow down the problem.

If nothing else works, try Reaper - if only to help pinpoint where the problem lies. Remember the standalone client is nearing 10 years old, whilst Reaper is generally no more than a few days or weeks old.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.

Last edited by pljones; 04-01-2014 at 04:15 AM.
pljones is offline   Reply With Quote
Old 04-01-2014, 02:10 PM   #7
dbroc
Human being with feelings
 
Join Date: Mar 2014
Posts: 4
Default

Yes, that was the kind of problem you describe: a shift of 1 or 2 BPM for one user above two
user 1: 1-2-3-4-5-6-7-8
user 2: 2-3-4-5-6-7-8-1
and probably not a latency problem
we have local latency but limited generally to less than a beat

but we progress

this evening, it worked almost well!
but it is hard to find why...
muting/not muting doesn't change a lot
we just have tried relaunching the server with different BPM/BPI disconnect/reconnect clients, kill all other applications
Changing the BPM and relaunching the server seems to be the best solution to cope with our strange problem

The conclusion is : we will have probably to try several times before we can play together with a stable solution

I hope it will go easier with a nice soundcard

Could it be possible my Macbook is not sufficient to act as a server while running a Ninjam client?

Last edited by dbroc; 04-01-2014 at 02:19 PM.
dbroc is offline   Reply With Quote
Old 04-01-2014, 03:00 PM   #8
pljones
Human being with feelings
 
pljones's Avatar
 
Join Date: Aug 2007
Location: London, UK
Posts: 576
Default

Muting yourself should change whether you can hear yourself. If it doesn't, that's a problem in itself.

I can't really think that with two players, running client and server should be a problem. I don't really know enough about Macs to advise, though.
__________________
Quote:
Originally Posted by Tony Williams
...Playing fast around the drums is one thing. But to play with people for others, to listen to, that's something else. That's a whole other world.
pljones is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 06:41 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.