Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 06-10-2017, 12:34 PM   #1
Luster
Human being with feelings
 
Join Date: Nov 2015
Posts: 306
Default Inconsistent vertical scroll behaviour and partly broken scrollbar

Ok. We have several possibilities within Reaper to influence the track height and part of the bug seems to be the SWS extension but it also happens with native actions so I post here in hope for some feedback.

Steps to reproduce normal behaviour:
  1. New project, insert a lot of new tracks.
  2. Go with mouse over TCP and hold CTRL while scrolling with the mousewheel so all tracks aren't visible any more (=increasing track height)
  3. Now vertical scroll through arrangement
-> Starting by track one scrolling down the list every top track in view is aligned with the top border of the window meaning one "tick" on the mousewheel translates to moving up/down one track (height) in arrangement exactly.


To provoke the erratic behaviour use the action "View: Adjust selected track heights (MIDI CC relative/mousewheel)" one or all tracks.


-> The vertical scrolling is not aligned anymore and it needs a lot more ticks with the mousewheel to "travel the same space".


Extra goodie:
When using the action "Xenakios/SWS: Toggle selected tracks height A/B" the same happens but also the scrollbar doesn't get updated and interacts now unreliable.


Dear devs, in case you are fixing this - please consider this FR:
http://forums.cockos.com/showthread.php?t=191647


It would just make sense.


With best regards.
Luster is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:16 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.