Old 01-13-2019, 12:17 PM   #1
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 1,602
Default Update of MIDI Editor while using nudge script (MIDI_SetAllEvts) very slow

This is something I noticed today.

This is the scenario:

- the project has around 27 tracks, all with several MIDI items
- I execute my "sr_Nudge notes right by 10 sticks.lua" script by pressing AND holding a hotkey
- the action is triggered around 5-10 times per second
= in the MIDI editor, the notes don't move until I release the key, which is pretty annoying. In contrast, a gradual movement in the arrangement can be seen. So I suspect the MIDI editor to be the culprit here.

This does not happen, when the project is smaller (less MIDI items).
Is there anything we can do about this?
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is online now   Reply With Quote
Old 02-01-2019, 03:53 PM   #2
_Stevie_
Human being with feelings
 
_Stevie_'s Avatar
 
Join Date: Oct 2017
Posts: 1,602
Default

Not sure what happened, but this has been solved with 5.966 Pre1.
__________________
My Reascripts forum thread | My Reascripts on GitHub | Stephan Römer - film composer
If you wish to donate for my scripts: please consider an organization like: animal shelter, doctors without borders, UNICEF, etc...
_Stevie_ is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:55 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.