Old 11-14-2018, 05:57 AM   #1
solarfall
Human being with feelings
 
Join Date: Sep 2013
Posts: 17
Default MIDI Editor causes high CPU use

I got this strange issue where cpu suddenly jumps from 0% to 70% whenever i open a MIDI editor. I also get cracking and popping audio. Problem disappears when the window is closed. Happened when i was working with a client and it was pretty bad since i didn't manage to solve the problem.
solarfall is offline   Reply With Quote
Old 11-14-2018, 06:55 AM   #2
mccrabney
Human being with feelings
 
mccrabney's Avatar
 
Join Date: Aug 2015
Location: Dunth, NC
Posts: 1,640
Default

need substantially more info, what are your midi editor settings?
__________________
check out MPL's amazing RS5K manager
FR: select midi recorded in most recent engagement of record/overdub.
mccrabney is offline   Reply With Quote
Old 11-14-2018, 07:09 AM   #3
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,162
Default

It's probably because of Preferences->Audio->Buffering->[ ] Allow on tracks with open MIDI editors (will increase MIDI preview latency)

being DISABLED. This means that whenever you select a track that has MIDI items on them, and you have a lot of things that track sends to (or receives from), all the sends/receives for that track will be shifted onto just one core, for the fastest possible MIDI preview. This disables anticipative processing, which is obviously going to push your CPU more, and once RT audio thread topples over, you get crackles.

Enable this option and tweak the render-ahead time for anticipative processing if you don't want the default 200 ms latency when previewing notes from MIDI editor.
EvilDragon is offline   Reply With Quote
Old 11-21-2018, 06:57 PM   #4
swiiscompos
Human being with feelings
 
swiiscompos's Avatar
 
Join Date: Mar 2011
Location: Lausanne (CH)
Posts: 1,095
Default

Quote:
Originally Posted by EvilDragon View Post
It's probably because of Preferences->Audio->Buffering->[ ] Allow on tracks with open MIDI editors (will increase MIDI preview latency)

being DISABLED. This means that whenever you select a track that has MIDI items on them, and you have a lot of things that track sends to (or receives from), all the sends/receives for that track will be shifted onto just one core, for the fastest possible MIDI preview. This disables anticipative processing, which is obviously going to push your CPU more, and once RT audio thread topples over, you get crackles.

Enable this option and tweak the render-ahead time for anticipative processing if you don't want the default 200 ms latency when previewing notes from MIDI editor.
Thank you! I had this problem for a while and had no idea what could cause it.
swiiscompos is online now   Reply With Quote
Old 11-23-2018, 11:00 AM   #5
SymboliC
Human being with feelings
 
SymboliC's Avatar
 
Join Date: Dec 2013
Location: istanbul
Posts: 193
Default

Quote:
Originally Posted by EvilDragon View Post
It's probably because of Preferences->Audio->Buffering->[ ] Allow on tracks with open MIDI editors (will increase MIDI preview latency)

being DISABLED. This means that whenever you select a track that has MIDI items on them, and you have a lot of things that track sends to (or receives from), all the sends/receives for that track will be shifted onto just one core, for the fastest possible MIDI preview. This disables anticipative processing, which is obviously going to push your CPU more, and once RT audio thread topples over, you get crackles.

Enable this option and tweak the render-ahead time for anticipative processing if you don't want the default 200 ms latency when previewing notes from MIDI editor.
Thanks for the tip.

Probably this was the cause I was talking about when saying "Open MIDI Editor pushes CPU so hard" in another thread...

And about compensating this with "tweaking the render-ahead time", should I try to decrease it to a value until hearing cracks again?
__________________
...and creativity surrendered to technical difficulties.
SymboliC is offline   Reply With Quote
Old 11-23-2018, 12:08 PM   #6
EvilDragon
Human being with feelings
 
EvilDragon's Avatar
 
Join Date: Jun 2009
Location: Croatia
Posts: 22,162
Default

No, tweaking look-ahead time is more about striking the balance between CPU utilization and how much latency you get when previewing notes in the MIDI editor.
EvilDragon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 05:22 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.