COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :

Go Back   Cockos Incorporated Forums > Other Software Discussion > WDL users forum

Reply
 
Thread Tools Display Modes
Old 02-19-2020, 08:39 PM   #1
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 293
Default Why does my 2-2 plugin show up in Pro Tools for MONO clips?

I don't know if this is a bug in my plugin or in Pro Tools 2019 but for some reason my stereo-in/stereo-out (2-2) plugin shows up in AudioSuite for mono clips.

Now, if my plugin was also defined as "1-1" or "1-2" I would understand but it is only 2-2. So why is it showing up in AudioSuite for mono clips?

BTW - it does NOT show up as a track insert effect on mono tracks

Seems like a bug in Pro Tools, IMO. Yes/no?

Last edited by Nonlinear; 02-24-2020 at 11:35 PM.
Nonlinear is offline   Reply With Quote
Old 02-24-2020, 04:07 PM   #2
Nonlinear
Human being with feelings
 
Join Date: Apr 2018
Posts: 293
Default

According to some experienced Pro Tools folk this is how AudioSuite works. Mono clips can be processed with stereo plugins and only one side comes back.

That's a weird approach, IMO. Could produce some strange results with some plugins. Oh well...
Nonlinear is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:33 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.