Old 01-30-2020, 03:02 PM   #1
MagicRat
Human being with feelings
 
Join Date: Mar 2015
Location: In a hat
Posts: 32
Default Jagged edges on moving objects

... After rendering. OS x.

This happens one clip out of seven, all with different sizes and frame rates.

I have tried all kinds of rendering settings but the problem persist.

Help?
__________________
Macbookpro 2011.
MagicRat is offline   Reply With Quote
Old 01-31-2020, 01:10 AM   #2
FixItInPost
Human being with feelings
 
Join Date: Jun 2018
Location: South Africa
Posts: 21
Default

Hi MagicRat,

Are the jagged edges you mention similar to the “combing” effect decribed here?
Do the jagged edges always occur on the same clip or is it random?
FixItInPost is offline   Reply With Quote
Old 01-31-2020, 01:21 AM   #3
MagicRat
Human being with feelings
 
Join Date: Mar 2015
Location: In a hat
Posts: 32
Default

Hi,

yes that is exactly how it looks, after rendering. Inside Reaper there is no problem. And it is the same clip. It is also the only clip recorded with a proper video camera, the ones with no problem are recorded with mobile phone...

Here is the source properties:
---
Length: 5:50.760
Video: 1920x1080@25.00fps, Aspect=1.00, Decoding format=I420/YV12
Audio: 48000Hz 2ch 32bps

Using VLC decoder (v3.0.x)
Video: 1920x1080, h264, 25.00fps
Audio: 48000hz, 32bps, 2ch, a52

Loaded from: /Applications/VLC.app
---

I have tried to render with both 25fps, and 30 fps. It looks the same.

I am a total noob when it comes to video editing, fyi.

Thanks!
__________________
Macbookpro 2011.
MagicRat is offline   Reply With Quote
Old 01-31-2020, 03:04 AM   #4
FixItInPost
Human being with feelings
 
Join Date: Jun 2018
Location: South Africa
Posts: 21
Default

Hello again MagicRat,

Ah! 25fps! A fellow resident of PAL land! Only integer frame rates for us! ;-p

The issue seems to be that the problem footage has been shot interlaced instead of progressive – cellphones normally always shoot progressive. Interlaced footage comprises of 2 fields that make up a single frame and, these days, is normally found in TV broadcast, particularly (but not limited to) live sporting events.

It’s strange that the “combing” effect is not evident within REAPER but this could be due to the fact that the video preview window is not showing you the footage at its native 1920x1080 resolution but is showing you a scaled down preview which might be dropping scan lines.

To see if the footage is indeed interlaced I would recommend downloading MediaInfo. Once installed, run the program and select either Text or HTML as the Output format. Open the video file within MediaInfo and look under the heading Scan Type. If it’s interlaced it will read “Interlaced” and under Scan order it will tell you which field is first.

I have no interlaced 1080 footage (a.k.a 1080i) on hand to test with, so, if the footage is indeed interlaced you could try adding the video processor effect just to the problem footage clips and select the preset “Basic helpers: De-interlace track/item”. Adjust the parameters and try a few test renders.

Just as a test you could also try adjusting the render size to 960x540 - which is half the vertical resolution of the problem footage (1920x1080) and will drop every second scan line, effectively removing one of the interlaced fields thus giving you a progressive scan picture.

Good luck!
FixItInPost is offline   Reply With Quote
Old 01-31-2020, 05:54 AM   #5
MagicRat
Human being with feelings
 
Join Date: Mar 2015
Location: In a hat
Posts: 32
Default

Thank you, now I hopefully can sort it out!

But I do not understand how the video can play back perfectly before taking it into reaper. Never been a problem and I have ma y hours of recordings from that session. Can you see why?

Rendering as I did before, MP4 but with the “Basic helpers: De-interlace track/item”, removes the problem.

I suspect that I trash the quality by doing this?

But since the goal with this is to upload to google photos and then delete the original files I think I should use a lossless format. Question is, which one?
__________________
Macbookpro 2011.

Last edited by MagicRat; 01-31-2020 at 07:05 AM.
MagicRat is offline   Reply With Quote
Old 01-31-2020, 07:06 AM   #6
FixItInPost
Human being with feelings
 
Join Date: Jun 2018
Location: South Africa
Posts: 21
Default

Some media players and even some graphics cards detect interlaced video footage and (depending on their settings) will automatically apply a de-interlacing filter so the image looks "clean" on computer monitors. That said, VLC player by default does not automatically de-interlace footage.

I would run the footage through the MediaInfo analyser and see if the footage is indeed interlaced. If it's not interlaced there could be something else at play... but I don't know what else it could be!
FixItInPost is offline   Reply With Quote
Old 01-31-2020, 07:57 AM   #7
MagicRat
Human being with feelings
 
Join Date: Mar 2015
Location: In a hat
Posts: 32
Default

Wow, had no clue about interlacing thats for sure. I just checked that the audio levels were ok and then I started recording, with a borrowed camera.

Its ok now, I got everything exported and up on google photos, so thanks a lot. Somehow it feels like copying cassette tapes, loss on loss. But for this purpose, it is ok. Most important is that I could edit the sound a bit.

Cheers!
__________________
Macbookpro 2011.
MagicRat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 12:21 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.