Old 02-16-2020, 10:29 AM   #1
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Cologne
Posts: 761
Default disable vertical zoom in

I wonder how to disable vertical zoom. At the moment strg+mousewheel zooms in/out. Removing the shortcut from the action list (command Id 991) does work for the arrangement view. But hovering over the tracks in the TCP and using strg+mousewheel still triggers the zoom. Any idea?
__________________
https://gassnklang.de
Gass n Klang is online now   Reply With Quote
Old 02-17-2020, 05:12 PM   #2
georgemickel
Human being with feelings
 
georgemickel's Avatar
 
Join Date: Jun 2018
Location: Pewaukee,WI
Posts: 203
Default

I recently rewatched one of "The Reaper Blog" youtube vids regarding mouse modifiers, maybe it has something to do with that.

I'm not home in front of my studio pc but I hope someone else will be of help.

Good luck!

G
georgemickel is online now   Reply With Quote
Old 02-18-2020, 04:22 AM   #3
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Cologne
Posts: 761
Default

thanks, but I can't find it in the mouse modifiers. But I don't think there are any settings for mousewheel actions in there.
__________________
https://gassnklang.de
Gass n Klang is online now   Reply With Quote
Old 02-18-2020, 06:06 AM   #4
georgemickel
Human being with feelings
 
georgemickel's Avatar
 
Join Date: Jun 2018
Location: Pewaukee,WI
Posts: 203
Default

I'm surprised that nobody chimed in..

Bump for ya
georgemickel is online now   Reply With Quote
Old 02-21-2020, 07:41 AM   #5
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Cologne
Posts: 761
Default

any idea?
__________________
https://gassnklang.de
Gass n Klang is online now   Reply With Quote
Old 02-21-2020, 08:23 AM   #6
georgemickel
Human being with feelings
 
georgemickel's Avatar
 
Join Date: Jun 2018
Location: Pewaukee,WI
Posts: 203
Default

Quote:
Originally Posted by Gass n Klang View Post
any idea?
I did a quick search on YouTube and saw options to choose from but didn't see how to disable vertical zoom.
Try a interweb search of Kenny's and The Reaper Blog's videos (link below). Hopefully you'll get a response.

https://youtu.be/1_ElH-fMjhc
georgemickel is online now   Reply With Quote
Old 03-04-2020, 07:21 AM   #7
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Cologne
Posts: 761
Default

bump.
__________________
https://gassnklang.de
Gass n Klang is online now   Reply With Quote
Old 04-24-2020, 03:54 PM   #8
linkoboy
Human being with feelings
 
linkoboy's Avatar
 
Join Date: Feb 2019
Posts: 25
Default

I've the same issue, I wanted to disable Ctrl+mousewheel zoom vertical in tcp because it breaks my tracks heights everytime ;-(

I've searched in the web and the forums and find anything about that, I think this action is "hard coded" in Reaper.

Could you please add an action to possibly disable Ctrl+mousewheel or change the shortcut ? it will be super great :-)
linkoboy is offline   Reply With Quote
Old 04-29-2020, 02:01 AM   #9
Ideosound
Human being with feelings
 
Ideosound's Avatar
 
Join Date: Oct 2017
Location: U.K
Posts: 369
Default

Would also like to know if this is possible. If I make a time selection by dragging, if the mouse goes slightly up or down whilst dragging left or right, then you get this vertical zooming which is annoying.
Ideosound is offline   Reply With Quote
Old 04-29-2020, 02:25 AM   #10
Gass n Klang
Human being with feelings
 
Gass n Klang's Avatar
 
Join Date: Nov 2015
Location: Cologne
Posts: 761
Default

Quote:
Originally Posted by Ideosound View Post
Would also like to know if this is possible. If I make a time selection by dragging, if the mouse goes slightly up or down whilst dragging left or right, then you get this vertical zooming which is annoying.
exactly!
__________________
https://gassnklang.de
Gass n Klang is online now   Reply With Quote
Old 11-30-2020, 08:42 PM   #11
Nüwa
Human being with feelings
 
Join Date: Nov 2020
Posts: 2
Default

Omg finally a post which talks about this issue. This is so frustrating when working with reaper. I use cmd+mouse wheel to zoom horizontally and alt+mouse wheel to zoom vertically. When I hover over the TCP cmd+mouse wheel and alt+mouse wheel both zoom vertically and nothing zooms horizontally. It seems like alt+mouse wheel over the TCP is hard coded to zoom the tracks? My zoom behaviour is set up so it zooms around my mouse cursor position, so when i want to zoom to the left i usually flick my mouse to the left to zoom, but the way reaper works right now, as soon as my mouse cursor goes over the tcp it stops zooming the way I want and it starts zooming vertically which throws me off. I wish my zooming controls could be consistent wether my cursor is hovering over the arrange area or the TCP. When using a trackpad with gestures, the zoom stays the same wether my cursor is above the arrange area or the TCP so it probably shouldn't be too hard to add it as an option. Hopefully this gets fixed soon, it's one of the things that prevent me from switching completely to reaper tbh :/
Nüwa is offline   Reply With Quote
Old 11-30-2020, 10:23 PM   #12
Fergler
Human being with feelings
 
Fergler's Avatar
 
Join Date: Jan 2014
Posts: 4,427
Default

I can't reproduce this, action 991 unbound does nothing over the TCP.
__________________
Check out my hip-hop, funk-rock band Theatre Crisp
Fergler is offline   Reply With Quote
Old 12-01-2020, 01:38 AM   #13
Ideosound
Human being with feelings
 
Ideosound's Avatar
 
Join Date: Oct 2017
Location: U.K
Posts: 369
Default

I think I fixed this, I'm sure it's an action that isn't turned on by default and I think I'd tried it out, then after a while decided it doesn't work for my workflow. Try searching in your actions for vertical zoom or something and see if there is an action that is already on.
Ideosound is offline   Reply With Quote
Old 12-03-2020, 08:11 AM   #14
bodfum
Human being with feelings
 
bodfum's Avatar
 
Join Date: Oct 2017
Location: UK
Posts: 25
Default

If you have the SWS extension check the settings for the Zoom preferences. There is an option in there to override Reaper preferences
bodfum is offline   Reply With Quote
Old 12-13-2020, 02:03 AM   #15
Loulou92
Human being with feelings
 
Loulou92's Avatar
 
Join Date: Sep 2015
Location: Paris
Posts: 237
Default

I can't disable it, it's so annoying... The SWS bit (comment above) doesn't seem to help much .

I disabled all shortcuts in the action list related to scroll or zoom, and I *still* get this vertical zoom in the TCP. I messes up the TCP, the env track height being the most annoying side effect, here.

Last edited by Loulou92; 12-13-2020 at 04:07 AM.
Loulou92 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:20 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.