Old 06-24-2019, 07:11 PM   #1
earhax
Human being with feelings
 
Join Date: Nov 2015
Posts: 171
Default Services menu EMPTY on Mac OS X REAPER

The OS X "Services" menu (REAPER > Services) shows the arrow, but no longer expands the pane that normally lists all the services I have enabled for use in REAPER (and any that are enabled for use in any app).

I don't know when this started occurring. But I used to be able to see a number of services listed in this menu, followed by "Services Preferences..." (which is always shown, even when no services are available for the active app).

I'm not sure if this is something to do with REAPER, or the OS. But every other app I'm running has no trouble displaying the Services menu and the list of services I have enabled - only REAPER.

Any help in resolving this would be appreciated.

Additional info:
- When REAPER is first launched and the "REAPER Choose Project(s)" window is showing, the Services menu works normally. But after loading a project, it stops working.
- A few times, when "Actions" was the frontmost window, the Services menu would expand the submenu, but it was completely blank/empty.

Troubleshooting I've tried:
- deleting the com.cockos preference files in ~/Library/Preferences
- deleting the ~/Library/Application Support/REAPER folder and all files within it
- installing/running the latest versions of both the 32 and 64 bit REAPER app
- booting in safe mode, using a different/new user profile

Info on my system:

Hardware Configuration:
MacBook Pro Retina, 15-inch, Early 2013 (MacBookPro10,1)
Processor: 2.7 GHz Intel Core i7 (4 cores)
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 650M 1024 MB
Boot ROM: MBP101.00EE.B03
SMC: 2.3f36

Software:
System Version: OS X Mavericks 10.9.5 (13F34)
Kernel Version: Darwin 13.4.0
Boot Volume: OSX
Boot Mode: Normal

REAPER v5.974/64 rev cb4407 (April 6 2019)
SWS Extensions 2.10.0 #1 built on Feb 6 2019
ReaPack v1.2.2 built on Feb 24 2019

Last edited by earhax; 07-07-2019 at 06:26 AM. Reason: Added more info
earhax is offline   Reply With Quote
Old 07-07-2019, 03:59 PM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 12,197
Default

Fix for this is coming in the next pre-release build!
Justin is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:01 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.