Old 01-16-2012, 02:23 PM   #1
mikeroephonics
Human being with feelings
 
mikeroephonics's Avatar
 
Join Date: Nov 2006
Posts: 2,480
Default M-Audio Trigger Finger won't work (always)

UPDATE: ISSUE RESOLVED. Scroll to Post #4 or click here:
http://forum.cockos.com/showpost.php...24&postcount=4


Hi. I have an M-Audio Trigger Finger. I've used it for many years with no problems. However, it will not work on my new machine. It runs fine on my old machine. I just tested it.

On the new machine, it lights up but Windows says there was a problem with the device.

I tried the following:
1.) Unplugged the TF.
2.) Installed the Trigger Finger USB MIDI device driver from M-Audio's site.
3.) Rebooted.
4.) Plugged the TF back in.
5.) The device is not working...

The working system is
Win 7 x64
Intel DP35DP

The non-working system is
Win 7 x64
Asus P8P67 Pro Rev 3.1

They're both Win 7x64 machines. What gives? :/
Are some mainboards more friendly with USB devices?
My M-Audio Keystation Pro 88 works perfectly in the same USB port on the Asus system.

I've Googled this issue to no avail. Lots of people are having this problem.

Thanks!
__________________
Please check out these MIDI requests: http://forum.cockos.com/showthread.php?t=103192
Thanks.

Last edited by mikeroephonics; 01-17-2012 at 06:45 AM.
mikeroephonics is online now   Reply With Quote
Old 01-16-2012, 07:12 PM   #2
setvice
Human being with feelings
 
setvice's Avatar
 
Join Date: Jun 2009
Location: Perth WA
Posts: 417
Default

I have one and its a pain. It only works on my windows 7 laptop (not my main machine) and thats when i plug it in to a USB hub first. Perhaps try that.
setvice is offline   Reply With Quote
Old 01-17-2012, 02:18 AM   #3
joees
Human being with feelings
 
Join Date: Jan 2012
Posts: 10
Default

might want to try some other ports Mike, all the new chipsets after 775 and up are affected with bad usb ports since they got usb3 on their motherboards.

You might have noticed that there are some power issues with the usb ports on your motherboard in other instances. The first revision of the Asus P67 motherboards all got drawn back, not sure if you got the B3 revision, but they say they were fixed but its not 100%. I have issues with the motherboard as well, i got the P8P67 Deluxe. For example my usb hub on my keyboard doesnt work, usb in tray pops up with unrecognized, i know its power issues. I got a backlit keyboard and i have to have it in specific ports for it not to shut down and get disconnected after longer periods of uptime, and its not 100% even if its a B3 revision. All lga1155, 1156 and 1366 are affected, thety all have issues on their usb ports, not sure if Asus is worse, and not sure about lga2011, but i think its there too, like usb3 is a bad hack and the chipset doesnt route enough power too it. If none of your usb ports work properly with it then u might look at updating the bios on it and see if thats working, its lousy, and most of the new tech are just hacks in some ways, cant wait for any of this new tech to work like it used to like it did with the old standard that its built upon.
joees is offline   Reply With Quote
Old 01-17-2012, 06:30 AM   #4
mikeroephonics
Human being with feelings
 
mikeroephonics's Avatar
 
Join Date: Nov 2006
Posts: 2,480
Default

Got it working! Thanks, everyone!

I installed an old Belkin PCI-to-USB 2.0 adapter into my Asus P8P67 Pro (rev 3.1) mainboard.

REAPER sees the Trigger Finger now. Working as expected!

Important note:
I installed the Driver for the Trigger Finger, which is here:

M-Audio USB MIDI Series 5.0.1.exe
http://www.m-audio.com/index.php?do=...drivers&f=1088
Direct Download Link: http://www.m-audio.com/index.php?do=...&f=1088&dl=yes

I installed the TF driver BEFORE I installed the Belkin PCI-to-USB card. I don't know if the TF driver is necessary, but I included the TF driver info in case it is required to get things working correctly.

Today's Top Tip: Don't throw out that old "useless hardware" (PCI-to-USB adapter.) They may come in handy some day!

Mike
__________________
Please check out these MIDI requests: http://forum.cockos.com/showthread.php?t=103192
Thanks.

Last edited by mikeroephonics; 01-17-2012 at 06:46 AM.
mikeroephonics is online now   Reply With Quote
Old 01-17-2012, 06:49 PM   #5
setvice
Human being with feelings
 
setvice's Avatar
 
Join Date: Jun 2009
Location: Perth WA
Posts: 417
Default

Thats great! I might have to try that myself.
setvice is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:03 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.