Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER for Linux

Reply
 
Thread Tools Display Modes
Old Today, 03:36 AM   #1
hfsrj
Human being with feelings
 
Join Date: Jan 2016
Posts: 5
Default (probably stupid) Linux Studio Plugins LSP not shown in plugins

I'm using reaper with Ubuntu 18.04 (64bits).
I downloaded the LSP plugins via sourceforge (lsp-plugins-lxvst-1.1.15-Linux-x86_64.tar.gz).

I then extracted the .so files to my /home/user/.vst folder (which is chosen in reaper settings).

I don't find the LSP plugins in the FX menu. Neither if I brutally put the .so files in /opt/REAPER/plugins.

Any idea what could be wrong ? Thanks !
hfsrj is online now   Reply With Quote
Old Today, 05:57 AM   #2
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jšmtland, Sweden
Posts: 423
Lightbulb

Have you done "Clear cache/re-scan" under Preferences/Plug-ins/VST? I have mine under /.vst and they are showing up.
__________________
OS: Ubuntu Studio, Reaper For Linux (64Bit) and native linux-vst plugins (16GB RAM) LSP-Suite, Drumgizmo, TpL-Plugins, LinuxSampler/Fantasia, Behringer U-PHORIA UMC22.
Tobbe is offline   Reply With Quote
Old Today, 06:11 AM   #3
hfsrj
Human being with feelings
 
Join Date: Jan 2016
Posts: 5
Default

Yes I did And didn't help.

Is there any package I should have installed for the vst to work ?

I tried with SickNDestroy VST and it works...
Maybe I'll try compiling from source, although that won't tell me what's wrong.
Is there any reaper log ?

Last edited by hfsrj; Today at 06:16 AM.
hfsrj is online now   Reply With Quote
Old Today, 06:50 AM   #4
hfsrj
Human being with feelings
 
Join Date: Jan 2016
Posts: 5
Default

So after compiling them, it works. I guess there was an issue with dependencies...

I would be very curious to find out which one, as this may also happen to others, and compiling is not always a friendly option.

Any idea on where to find reaper logs, or so, that would help ?
hfsrj is online now   Reply With Quote
Old Today, 06:52 AM   #5
Tobbe
Human being with feelings
 
Tobbe's Avatar
 
Join Date: Sep 2009
Location: Backe, Jšmtland, Sweden
Posts: 423
Default

I just downloaded "lsp-plugins-lxvst-1.1.15-Linux-x86_64", unpacked it and put all *.so files under /home/tobbe/.vst. Did a rescan in Reaper and the show up under All Plugins "New" in the FX list.
__________________
OS: Ubuntu Studio, Reaper For Linux (64Bit) and native linux-vst plugins (16GB RAM) LSP-Suite, Drumgizmo, TpL-Plugins, LinuxSampler/Fantasia, Behringer U-PHORIA UMC22.
Tobbe is offline   Reply With Quote
Old Today, 07:04 AM   #6
hfsrj
Human being with feelings
 
Join Date: Jan 2016
Posts: 5
Default

Must be something with misplaced libraries I guess ?

Edit : thanks for the help
hfsrj is online now   Reply With Quote
Old Today, 07:27 AM   #7
hfsrj
Human being with feelings
 
Join Date: Jan 2016
Posts: 5
Default

So, it turns out I had downloaded the Linux-X86-64 plugins... in lv2 format.
It turns out the VST format plugins I downloaded were the FreeBSD ones...
No surprise they didn't work.

Thanks a lot for the help, sorry for the wasted time. Stupid indeed
hfsrj is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:34 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.