Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 01-22-2024, 06:56 AM   #1
Buy One
Human being with feelings
 
Buy One's Avatar
 
Join Date: Sep 2019
Posts: 1,151
Default AI pool cannot be restored after deletion of another AI

In the animation

First i send 1st AI (pool ID 4) to pool ID 2 and immediately restore its original pool ID 4. Nothing visibly changes, as expected.

Then i do the same thing but interject the storage and restoration phases with deletion of another AI (selected) with different pool ID using action. After the deletion original pool ID of the 1st ID cannot be restored even though its data are still present in the track chunk.

All this essentially would be redundant if this feature request ReaScript API FR: Delete Automation Item were granted.

Also unique AI ID would be helpful because it's difficult to reliably keep track of certain AIs without immutable properties.



Last edited by Buy One; 01-22-2024 at 08:09 AM.
Buy One is offline   Reply With Quote
Old 04-13-2024, 11:25 AM   #2
Buy One
Human being with feelings
 
Buy One's Avatar
 
Join Date: Sep 2019
Posts: 1,151
Default

Refresh
Buy One is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:31 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.