Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Pre-Release Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 05-11-2022, 03:39 PM   #1
msmucr
Human being with feelings
 
Join Date: Jun 2009
Location: Praha, Czech republic
Posts: 595
Default WMF support in Reaper 6.57+ / glitches

Hello to all,

it's a quite some time when I last visited the forum.. I'm pleased with new features added to Reaper including support for Windows Media Foundation in the recent release.

For example decoding and playback of common long-GOP AVC in MP4 container is definitely much more responsive and fluent than any other method available on Windows (ffmpeg, VLC, DS) according to my tests. Big thumbs up for such improvement.

However I few things in both 6.57 release and current 6.57+dev0511, which would be nice to address.

The first is related directly to AVC (H.264) decoding. There is some vertical shift in decoded color planes. Related artifacts are visible at attached screenshot.

I've tried that at different computers with the same results, plus test file decodes correctly using WMF in Windows built-in "Movies & TV" app.

The generated 1 sec. test file was done with ffmpeg and following command:

ffmpeg -f lavfi -i smptehdbars=size=hd1080:duration=1 -pix_fmt yuv420p -c:v libx264 .\test_smpte_420_avc.mp4

To cross check that I've also tried to generate similar files for other WMF supported formats - VP9 in WEBM container and WMV, which were both decoded fine.

Next thing is, WMF decoder in Reaper isn't used for HEVC (H.265) files in MP4 container. HEVC won't work out of box in Windows 10, but it's $1 MS official extension from Windows Store https://www.microsoft.com/store/productId/9NMZLZ57R3T7

Other additional formats for WMF from the Store like VP9 or AV1 works well in Reaper. So HEVC would be potentially also nice (assuming, there might be similar performance gain like with AVC).


Finally I tested WMF render and found some glitches.

MP4 file with both video and audio (H.264, AAC respectively) has incorrect suffix. It should be mp4 instead of m4v. Exported file is correct and contains both, just output filename is wrong.

WMV render has incorrect codec choices. There should be WMV and WMA instead of H.264 and AAC. Such render produces zero length file.


Thank you very much for great ongoing support,

Michal
Attached Images
File Type: png wmf export to windows media video.PNG (33.3 KB, 174 views)
File Type: png wmf export to mpeg4.PNG (33.8 KB, 176 views)
File Type: png reaper_657_wmf_decoded_frame.png (18.2 KB, 174 views)
__________________
FRs: Better FX bypass
msmucr is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:17 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.