Prev Previous Post   Next Post Next
Old 10-07-2019, 08:16 AM   #1
azslow3
Human being with feelings
 
Join Date: Nov 2017
Location: Heidelberg, Germany
Posts: 747
Default VSTGUI bug on Linux

VSTGUI 4 has long standing bug on Linux.

Symptom:
as soon as you try to open VSTGUI 4 based plug-in, REAPER crash (in that plug-in).

Why:
Run "fc-match Arial"
In case you see translation into your language instead of "Regular", the plug-in will crash.

Solutions:
(1) it should be fixed in the VSTGUI source (I have commented https://github.com/steinbergmedia/vstgui/issues/88 )
(2) some plug-in developers try to use different fonts (without style name translation, f.e. Surge went this way)
(3) for end users, run REAPER as "FC_LANG=en ./reaper"

PS. OMG Steinberg... They are in Hamburg, they also should have style "Standard" instead or "Regular"
azslow3 is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 11:44 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.