COCKOS
CONFEDERATED FORUMS
Cockos : REAPER : NINJAM : Forums
Forum Home : Register : FAQ : Members List : Search :
Old 08-19-2019, 12:21 AM   #1
TonyGlover
Human being with feelings
 
TonyGlover's Avatar
 
Join Date: Mar 2016
Posts: 34
Default Audio Unit crash on Logic pro 10.4

I compile a plugin on Audio Unit but crash when try to load on Logic pro 10.4. This is the message from validator:

Code:
AU Validation Tool
    Version: 1.6.1a1 
    Copyright 2003-2013, Apple Inc. All Rights Reserved.
    Specify -h (-help) for command options

--------------------------------------------------
VALIDATING AUDIO UNIT: \'aufx\' - \'rt5w\' - \'TyGl\'
--------------------------------------------------
Manufacturer String: Tony
AudioUnit Name: TestPlug
Component Version: 1.0.0 (0x10000)

* * PASS
--------------------------------------------------
TESTING OPEN TIMES:
COLD:
Time to open AudioUnit: 21.996 ms


validation result: crashed validation
Crashing so fast! What can it be?

It wonders me because on an older version of logic it works... I used WDL Tale version
TonyGlover is offline   Reply With Quote
Old 08-20-2019, 02:58 AM   #2
TonyGlover
Human being with feelings
 
TonyGlover's Avatar
 
Join Date: Mar 2016
Posts: 34
Default

No solution ?

WDL it's not compatible with Logic pro 10 ?
TonyGlover is offline   Reply With Quote
Old 08-20-2019, 11:14 AM   #3
bozmillar
Human being with feelings
 
bozmillar's Avatar
 
Join Date: Sep 2009
Posts: 604
Default

It works in Logic Pro 10. There must be something when your plugin is initializing. It's pretty hard to tell from the error other than the fact that it's not able to open.
__________________
http://www.bozdigitallabs.com
bozmillar is offline   Reply With Quote
Old 08-20-2019, 11:35 AM   #4
TonyGlover
Human being with feelings
 
TonyGlover's Avatar
 
Join Date: Mar 2016
Posts: 34
Default

Yes, that's how I thought about the initialization, not even OnParamChange is called. I do not understand, it is too simple and I see no error
TonyGlover is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:16 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.