Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-21-2022, 04:25 AM   #1
soulaccess
Human being with feelings
 
Join Date: Jul 2012
Posts: 23
Default API: TrackFX_AddByName() ignores default settings (not quite yet FIXED)

EDIT: Fixed in Reaper V6.70
----------------------------

AFAICT when inserting a JS Effect with TrackFX_AddByName() the "Default settings for new instances" are ignored. Oversampling is set to "no oversampling" and embedded UI to "no"
This only happens with JS Plugins, it works as expected with VST Plugins.

Steps to recreate:
- in the FX Browser right-click the Plugin "JS: Distortion" and set "Default settings for new instances" > "FX instance oversampling" to "Oversample up to [...]"
- select a track and execute LUA code (below)
- check the track with the instantiated Plugin, oversampling will be set to "no oversampling"

Code:
track = reaper.GetSelectedTrack2(0, 0, true)
reaper.TrackFX_AddByName(track,"JS:Distortion",false,-1)

Last edited by soulaccess; 11-23-2022 at 06:30 AM. Reason: Bug fixed in Reaper V6.70
soulaccess is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 08:00 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.