Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Q&A, Tips, Tricks and Howto

Reply
 
Thread Tools Display Modes
Old 10-26-2018, 03:11 PM   #1
mister happy
Human being with feelings
 
mister happy's Avatar
 
Join Date: Mar 2017
Location: at the moment
Posts: 58
Default MIDI editor Menu>View>Mode & Menu>View>Piano Roll Notes changes the other tracks too

Hi,
I have just recently begun using the MIDI editor features that display note names and drum mode diamond shapes.

When I change my drum track to these settings it seems as if the next MIDI track I open in the MIDI editor is stuck in this mode even though it was set to piano notes. I then have to set it back to the piano style view.

Is there some way to set up a drum track without disrupting normal music tracks that use piano style displays?

Thank you.
__________________
REAPER 5.96.1, Win 7 x64

Last edited by mister happy; 10-29-2018 at 06:54 PM.
mister happy is offline   Reply With Quote
Old 10-27-2018, 07:00 AM   #2
mister happy
Human being with feelings
 
mister happy's Avatar
 
Join Date: Mar 2017
Location: at the moment
Posts: 58
Default

I have continued to try to find out if I am doing something wrong or if there is some pattern to what I am experiencing.

I went ahead and made some track templates of the drum tracks set up with the view modes I like.

It seems like the templates don't save the "view" choices.

It seems like the view choices are stored in the project, so I have to reset them when I open different MIDI items with differing view options.

I wish I new how to describe it better.
__________________
REAPER 5.96.1, Win 7 x64
mister happy is offline   Reply With Quote
Old 11-08-2018, 09:13 AM   #3
mister happy
Human being with feelings
 
mister happy's Avatar
 
Join Date: Mar 2017
Location: at the moment
Posts: 58
Default

Hi,
I am still having trouble with this and wonder if there is a solution I am missing.

Here's another example; I have made a project template that has a MIDI drum track, and a MIDI synth track. Both are virtual instruments. Both tracks have empty MIDI items in them. I had the drum track set up with diamonds and note names, and the synth track set up with piano notes.

When I start a new project based on the template and I open the drum item in the MIDI Editor I see piano notes and drum note names over lain. I have to reset the view options.

I would have thought the view options stick to the project but somehow they seem to be remembered as last used by REAPER.

Is there a way to lock the view options for a track and have the display show as expected when you open the MIDI items in the MIDI editor?

Thank you.
__________________
REAPER 5.96.1, Win 7 x64
mister happy is offline   Reply With Quote
Old 11-08-2018, 09:44 AM   #4
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,509
Default

I cannot repeat that here. I can get:



If I save and re-open that project I still have the different views (they are stored in the MIDI items in the project file). If I create a new MIDI clip its view is the last one selected (that is stored in Reaper's configuration settings).

Perhaps you could compress a simple problem project file (no audio samples needed) into a ZIP file and post it here as an attachment so that we can have a look at it and see what's (not) happening?

How to post attachments (in Post #1)
__________________
DarkStar ... interesting, if true. Inspired by ...
DarkStar is offline   Reply With Quote
Old 11-08-2018, 04:03 PM   #5
mister happy
Human being with feelings
 
mister happy's Avatar
 
Join Date: Mar 2017
Location: at the moment
Posts: 58
Default

Quote:
Originally Posted by DarkStar View Post
...If I create a new MIDI clip its view is the last one selected (that is stored in Reaper's configuration settings)...
This helps explain some of the things I am encountering. I will try to keep this in mind so that I can understand that this is normal behavior when I encounter it.

Quote:
...If I save and re-open that project I still have the different views (they are stored in the MIDI items in the project file)...
I think I am figuring out that my confusion occurs when I have two empty MIDI items and expect each to have the relative View>Piano Roll Notes type, but they are using the last one selected. I have added some place holder notes in each track and now the settings seem to stick.

Thank you.
__________________
REAPER 5.96.1, Win 7 x64
mister happy is offline   Reply With Quote
Old 11-09-2018, 06:23 AM   #6
TheWhistler
Human being with feelings
 
TheWhistler's Avatar
 
Join Date: Nov 2010
Location: Deep in the pocket...
Posts: 1,030
Default

Quote:
Originally Posted by DarkStar View Post
I cannot repeat that here. I can get:



How to post attachments (in Post #1)
Sorry for hijacking the thread
How did you get two rows of tools in your toolbar? And perfectly aligned....
TheWhistler is offline   Reply With Quote
Old 11-09-2018, 06:35 AM   #7
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 17,509
Default

Separators for the half-width spaces and No-op actions for the full-width spaces.

And a lot of trial and error.
__________________
DarkStar ... interesting, if true. Inspired by ...
DarkStar is offline   Reply With Quote
Old 11-10-2018, 08:13 AM   #8
TheWhistler
Human being with feelings
 
TheWhistler's Avatar
 
Join Date: Nov 2010
Location: Deep in the pocket...
Posts: 1,030
Default

Quote:
Originally Posted by DarkStar View Post
Separators for the half-width spaces and No-op actions for the full-width spaces.

And a lot of trial and error.
Ah, ok so no special magic trick. Thank´s for answering.
TheWhistler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:41 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.