Old 10-18-2021, 06:19 AM   #121
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 3,067
Default

Quote:
Originally Posted by 1Man View Post
Thank you for the help so far. I just tried out the new file, and the "Track", "Edit Plugins", "Sends", and "Pan" buttons all seem to be non-functional.

I also just noticed when I press the "Macro" button, my display for my 8th track fader changes to read "FX" and it seems to be set to apply the last clicked FX parameter to my 8th fader. Which is kinda nice with my setup actually, unless I want to control multiple FX parameters at once.
Airon posted his CSI v1.1 FP16 files here:

https://stash.reaper.fm/43024/Faderport16_CSI_1.1.zip

I'd suggest trying those!
Funkybot is offline   Reply With Quote
Old 10-19-2021, 07:28 PM   #122
NsaintP
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Default

Quote:
Originally Posted by Funkybot View Post
Did you update your CSI? The syntax changed when CSI went version 1.1. That could be why things aren't working.

If not that, then I'd suggest:

1. Post a screen print of your Reaper -> Preferences -> MIDI Devices (the Faderport should be disabled)

2. Post a screen print of your CSI device settings for the Faderport

3. Post the contents of your csi.ini

4. Post the contents of your Faderport zone folder

...we need to be able to see what you're seeing.

Thanks Funkybot. I tried reinstalling with the latest CSI from Reaper Stash released in Aug 2021. Still no luck. The scribble strips on my FP8 just say 'waiting for host' no matter what I do. I have a feeling it might be the Midi in and out in preferences/Midi Devices. The Faderport 8 is disabled, as per instructions. Which begs the question: What Midi device should be enabled? Or none at all?
Attached Files
File Type: ini CSI.ini (152 Bytes, 39 views)
File Type: zip Reaper FP8 Question.zip (154.2 KB, 42 views)
NsaintP is offline   Reply With Quote
Old 10-19-2021, 09:19 PM   #123
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 3,067
Default

Quote:
Originally Posted by NsaintP View Post
Thanks Funkybot. I tried reinstalling with the latest CSI from Reaper Stash released in Aug 2021. Still no luck. The scribble strips on my FP8 just say 'waiting for host' no matter what I do. I have a feeling it might be the Midi in and out in preferences/Midi Devices. The Faderport 8 is disabled, as per instructions. Which begs the question: What Midi device should be enabled? Or none at all?
Get rid of the Faderport.zon file. That's a CSI v1.0 file. Download the files Airon put together here:

https://stash.reaper.fm/43024/Faderport16_CSI_1.1.zip

...then try those out.

Otherwise, your settings look good.
Funkybot is offline   Reply With Quote
Old 10-19-2021, 10:11 PM   #124
NsaintP
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Default

Quote:
Originally Posted by Funkybot View Post
Get rid of the Faderport.zon file. That's a CSI v1.0 file. Download the files Airon put together here:

https://stash.reaper.fm/43024/Faderport16_CSI_1.1.zip

...then try those out.

Otherwise, your settings look good.



Getting closer but not there yet. I've replaced the .mst and .zon files with the Reaper Stash versions from Aug 2021. But now for whatever reason Presonus FP8 is showing up as 'not present' under Midi Devices so I can't actually select it within Midi Surface as Midi In and Midi Out. I just get blank boxes there with nothing to select.
Attached Files
File Type: zip Midi Not Present.zip (154.6 KB, 36 views)
NsaintP is offline   Reply With Quote
Old 10-19-2021, 11:01 PM   #125
NsaintP
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Default

Quote:
Originally Posted by Funkybot View Post
Get rid of the Faderport.zon file. That's a CSI v1.0 file. Download the files Airon put together here:

https://stash.reaper.fm/43024/Faderport16_CSI_1.1.zip

...then try those out.

Otherwise, your settings look good.



OK Funkybot - restarting the system seemed to get Presonus FP8 showing up again in Midi Devices. But still no connection! I'm about to nut! Just to be clear, when I start the FP8 by itself (Reaper not running) the Scribble Strips say 'Studio One' mode and 'waiting for host'. Then I start Reaper and the scribble strips go blank. After that, nothing.
Attached Files
File Type: zip Midi Showing_FP8 Not Connecting.zip (102.2 KB, 30 views)
NsaintP is offline   Reply With Quote
Old 10-20-2021, 06:13 AM   #126
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 3,067
Default

Quote:
Originally Posted by NsaintP View Post
OK Funkybot - restarting the system seemed to get Presonus FP8 showing up again in Midi Devices. But still no connection! I'm about to nut! Just to be clear, when I start the FP8 by itself (Reaper not running) the Scribble Strips say 'Studio One' mode and 'waiting for host'. Then I start Reaper and the scribble strips go blank. After that, nothing.
Only thing that sticks out as odd to me is your Home page in CSI is called "Homepage_ReaperFollows." Try to rename it to just "Home" - everything else looks good to me assuming you're using Airon's file.

If you're still running into issues, please head over to the main CSI Device Setup thread and maybe someone else can figure out what's going on.

I'm assuming the Faderport works in other DAWs and the unit itself has been ruled out as the issue. A few people had some Behringer surfaces that needed replacing then suddenly everything worked on the replacement.
Funkybot is offline   Reply With Quote
Old 10-20-2021, 10:13 PM   #127
NsaintP
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Cool

Quote:
Originally Posted by Funkybot View Post
Only thing that sticks out as odd to me is your Home page in CSI is called "Homepage_ReaperFollows." Try to rename it to just "Home" - everything else looks good to me assuming you're using Airon's file.

If you're still running into issues, please head over to the main CSI Device Setup thread and maybe someone else can figure out what's going on.

I'm assuming the Faderport works in other DAWs and the unit itself has been ruled out as the issue. A few people had some Behringer surfaces that needed replacing then suddenly everything worked on the replacement.
I renamed the Home page 'Home' as suggested but to no avail. As for the unit itself being the source of the problem,I was using it daily a couple months ago so I think there is little chance something has gone wrong with the FP8. I tweaked the .zon file at some stage and when it stopped working I assumed I messed it up somehow. Thus I reinstalled everything and still no luck. I'll try the CSI Device setup thread and see how I go. Thanks anyway for your efforts Funkybot.
NsaintP is offline   Reply With Quote
Old 10-21-2021, 12:09 AM   #128
NsaintP
Human being with feelings
 
Join Date: Feb 2019
Posts: 36
Thumbs up

Quote:
Originally Posted by NsaintP View Post
I renamed the Home page 'Home' as suggested but to no avail. As for the unit itself being the source of the problem,I was using it daily a couple months ago so I think there is little chance something has gone wrong with the FP8. I tweaked the .zon file at some stage and when it stopped working I assumed I messed it up somehow. Thus I reinstalled everything and still no luck. I'll try the CSI Device setup thread and see how I go. Thanks anyway for your efforts Funkybot.

Update - I reinstalled CSI version 1.0 and it works. I'm glad! Not sure if the failure with 1.1 is on me or not. Will update again if I get 1.1 going.
NsaintP is offline   Reply With Quote
Old 10-30-2021, 06:14 AM   #129
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 11,357
Default

You could try my setup, perhaps compare it to yours. See my signature for the download link.
__________________
(Video)Using Latch Preview - Faderport16 for CSI v1.0 or CSI v1.1
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 11-02-2021, 02:39 AM   #130
Sirdouille
Human being with feelings
 
Join Date: Nov 2016
Posts: 3
Default My config

Hi,

Here is my version of mst and zone files for the FaderPort8 :

https://github.com/Sirdouille/CSI

I started from the Jan Feld files (https://github.com/JanFeld/reaper-csi-configs), and I tweaked them little by little.

Main characteristics :

- Use of the the small upper-left knob for track navigation
- Little use of Zones, emphasis on modifiers
- Pan button used as a modifier for panning control
- Receive function assigned to "Edit Plugins" button
- Implementation of several Zoom functionalities
- Prev and Next buttons mainly used for navigation within the TCP
- ...

See the FP8s1_Buttons file for all the details. I found the modifiers implementation quite straightforward, especially with the lighting of the buttons. It made me wish there were more than 4.

Issues :

I didn't get the Encoder functionality to work, so I went back to the Airon RotaryBigLeft-RotaryBifgLeftMid-RotaryBigLeftFast implementation.

I've had fader range or value-mapping problems right from the start when I tried to create zon files for FX plugin control (with the FabFilter ProC2), so I didn't dig much into that. If anyone knows how to get the faders to work properly for any range of plugin knobs, any help would be appreciated.

Cheers,


Sirdouille.
Sirdouille is offline   Reply With Quote
Old 11-02-2021, 05:23 AM   #131
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 6,811
Default

Quote:
Originally Posted by Sirdouille View Post
I found the modifiers implementation quite straightforward, especially with the lighting of the buttons. It made me wish there were more than 4.
Glad to see you are getting things set up your way !

Some more experienced with the FP series may jump in with tips

As for the modifiers, just in case you don't know, you can use combinations too, like:

Code:
Shift+Alt+SomeButton
Alt+Control+Shift+Option+SomeButton

Note that Shift+Alt is the same as Alt+Shift, etc.
__________________
Software -- https://stash.reaper.fm/v/42437/CSI%20v1_1.zip
Donate -- via PayPal to [waddingtongeoff@gmail.com]

Wiki -- https://github.com/GeoffAWaddington/...ntegrator/wiki
Geoff Waddington is offline   Reply With Quote
Old 11-03-2021, 02:39 PM   #132
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 11,357
Default

Quote:
Originally Posted by Sirdouille View Post
Hi,

Here is my version of mst and zone files for the FaderPort8 :

https://github.com/Sirdouille/CSI

I started from the Jan Feld files (https://github.com/JanFeld/reaper-csi-configs), and I tweaked them little by little.

Main characteristics :

- Use of the the small upper-left knob for track navigation
- Little use of Zones, emphasis on modifiers
- Pan button used as a modifier for panning control
- Receive function assigned to "Edit Plugins" button
- Implementation of several Zoom functionalities
- Prev and Next buttons mainly used for navigation within the TCP
- ...

See the FP8s1_Buttons file for all the details. I found the modifiers implementation quite straightforward, especially with the lighting of the buttons. It made me wish there were more than 4.
Neat setup.

Quote:
I've had fader range or value-mapping problems right from the start when I tried to create zon files for FX plugin control (with the FabFilter ProC2), so I didn't dig much into that. If anyone knows how to get the faders to work properly for any range of plugin knobs, any help would be appreciated.
Here's a setup I'm working on. I've kept it to eight faders. Using more modifiers might be neat. Save this to your zone folder.

Code:
Zone "VST3: Pro-C 2 (FabFilter)"
  FocusedFXNavigator
/ SelectedTrackNavigator

Fader1        FXParam 1
Select1       FXParam 1  [ 1.0 ] { 2 10 2  127 20  30 } // reset to 0 dB threshold
FPDisplayA1   FixedTextDisplay   "Threshold"
FPDisplayB1   FXParamValueDisplay "1"
FPDisplayC1   FixedTextDisplay "Thr"
Shift+Fader1        FXParam 3			  
Shift+Select1       FXParam 3  [ 0.25 ] { 165 0 255 165 0 255 } // reset knee to default 18dB
Shift+FPDisplayA1   FixedTextDisplay "Knee"
Shift+FPDisplayB1   FXParamValueDisplay "3"
Shift+FPDisplayC1   NoAction



Fader2        FXParam 2
Select2       FXParam 2  [ 0.39977777 ] { 2 10 2  127 20  30 } // reset Ratio to 2:1
FPDisplayA2   FixedTextDisplay   "Ratio"
FPDisplayB2   FXParamValueDisplay "2"
FPDisplayC2   FixedTextDisplay "Rat"
Shift+Select2       FXParam 0  [ 0.0 0.14285715 0.2857143 0.42857143 0.5714286 0.71428573 0.85714287 1.0 ] { 165 0 255 165 0 255 } // Styles
Shift+FPDisplayA2   FXParamValueDisplay "0"
Shift+FPDisplayB2   FXParamValueDisplay "0"
Shift+FPDisplayC2   FixedTextDisplay   "Style"


Fader3        FXParam 5
Select3       FXParam 5  [ 0.2 ] { 2 10 2  127 40  30 } // reset Attack to 2 ms
Shift+Select3 FXParam 999 { 0 0 0 0 0 0 } // keeps the button dark when shift is held
FPDisplayA3   FixedTextDisplay   "Attack"
FPDisplayB3   FXParamValueDisplay "5"
FPDisplayC3   FixedTextDisplay "Att"


			  
Fader4        FXParam 6
Select4       FXParam 6  [ 0.40213889 ] { 2 10 2  127 40  30 } // reset Release to 200ms
FPDisplayA4   FixedTextDisplay   "Release"
FPDisplayB4   FXParamValueDisplay "6"
FPDisplayC4   FixedTextDisplay "Rel"
Shift+Select4       FXParam 7 [ 0.0 1.0 ] { 41 0 64 165 0 255 } // toggle auto release
Shift+FPDisplayA4   FixedTextDisplay "Auto Release"
Shift+FPDisplayB4   FixedTextDisplay "Toggle"
Shift+FPDisplayC4   FXParamValueDisplay "7"

			  
Fader5        FXParam 10
Select5       FXParam 10 [ 0.5 ] { 2 10 2  127 40  30 } // reset wet gain to 0 dB
FPDisplayA5   FixedTextDisplay   "Wet"
FPDisplayB5   FXParamValueDisplay "10"
FPDisplayC5   FixedTextDisplay "Gain"
Shift+Select5       FXParam 14 [ 0.0 1.0 ] { 41 0 64 165 0 255 } // toggle auto gain
Shift+FPDisplayA5   FixedTextDisplay "Auto Gain"
Shift+FPDisplayB5   FixedTextDisplay "Toggle"
Shift+FPDisplayC5   FXParamValueDisplay "14"



Fader6        FXParam 12
Select6       FXParam 12 [ 0.0 ] { 2 10 2  127 40  30 } // reset dry gain to -inf dB
Shift+Select6 FXParam 999 { 0 0 0 0 0 0 }
FPDisplayA6   FixedTextDisplay   "Dry"
FPDisplayB6   FXParamValueDisplay "12"
FPDisplayC6   FixedTextDisplay "Gain"


Fader7        FXParam 21
Select7       FXParam 21 [ 0.15904045 ] { 2 10 2  127 40  30 } // reset Sidechain Low to 60Hz
FPDisplayA7   FixedTextDisplay   "SC-Low"
FPDisplayB7   FXParamValueDisplay "21"
FPDisplayC7   FixedTextDisplay "Freq"
Shift+Select7       FXParam 20 [ 0.0 1.0 ]    { 41 0 64 165 0 255 } // toggle Sidechain Low enable
Shift+FPDisplayA7   FixedTextDisplay   "SC-Low"
Shift+FPDisplayB7   FixedTextDisplay "Toggle"
Shift+FPDisplayC7   FXParamValueDisplay "20"

Fader8        FXParam 26
Select8       FXParam 26 [ 0.5 ] { 2 10 2  127 40  30 } // reset Sidechain Mid Gain to 0 dB
FPDisplayA8   FixedTextDisplay   "SC-Mid"
FPDisplayB8   FXParamValueDisplay "26"
FPDisplayC8   FixedTextDisplay "Gain"
Shift+Select8       FXParam 24 [ 0.0 1.0 ]    { 41 0 64 165 0 255 } // toggle Sidechain Mid enable
Shift+FPDisplayA8   FixedTextDisplay   "SC-Mid"
Shift+FPDisplayB8   FixedTextDisplay "Toggle"
Shift+FPDisplayC8   FXParamValueDisplay "24"

/ FXParam 0 "Style"
/ FXParam 1 "Threshold"
/ FXParam 2 "Ratio"
/ FXParam 3 "Knee"
/ FXParam 4 "Range"
/ FXParam 5 "Attack"
/ FXParam 6 "Release"
/ FXParam 7 "Auto Release"
/ FXParam 8 "Lookahead"
/ FXParam 9 "Hold"
/ FXParam 10 "Wet Gain"
/ FXParam 11 "Wet Pan"
/ FXParam 12 "Dry Gain"
/ FXParam 13 "Dry Pan"
/ FXParam 14 "Auto Gain"
/ FXParam 15 "Side Chain Expert Mode"
/ FXParam 16 "Side Chain Input"
/ FXParam 17 "Side Chain Level"
/ FXParam 18 "Stereo Link"
/ FXParam 19 "Stereo Link Mode"
/ FXParam 20 "Side Chain Low Enabled"
/ FXParam 21 "Side Chain Low Frequency"
/ FXParam 22 "Side Chain Low Slope"
/ FXParam 23 "Side Chain Mid Auto"
/ FXParam 24 "Side Chain Mid Enabled"
/ FXParam 25 "Side Chain Mid Frequency"
/ FXParam 26 "Side Chain Mid Gain"
/ FXParam 27 "Side Chain Mid Q"
/ FXParam 28 "Side Chain Mid Shape"
/ FXParam 29 "Side Chain High Enabled"
/ FXParam 30 "Side Chain High Frequency"
/ FXParam 31 "Side Chain High Slope"
/ FXParam 32 "Audition Side Chain"
/ FXParam 33 "Audition Triggering"
/ FXParam 34 "Mix"
/ FXParam 35 "Input Level"
/ FXParam 36 "Input Pan"
/ FXParam 37 "Output Level"
/ FXParam 38 "Output Pan"
/ FXParam 39 "Bypass"
/ FXParam 40 "Oversampling"
/ FXParam 41 "Lookahead Enabled"
/ FXParam 42 "Midi State"
/ FXParam 43 "Meter Scale"
/ FXParam 44 "Display Enabled"
/ FXParam 45 "Knee Display Enabled"
/ FXParam 46 "Host Bypass"
/ FXParam 47 "Internal"
/ FXParam 48 "Internal"
/ FXParam 49 "MIDI CC"
/ FXParam 50 "Pitch Bend"
/ FXParam 51 "Channel Pressure"

FPDisplayD1  NoAction
FPDisplayD2  NoAction
FPDisplayD3  NoAction
FPDisplayD4  NoAction
FPDisplayD5  NoAction
FPDisplayD6  NoAction
FPDisplayD7  NoAction
FPDisplayD8  NoAction
ZoneEnd
__________________
(Video)Using Latch Preview - Faderport16 for CSI v1.0 or CSI v1.1
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 11-03-2021, 03:20 PM   #133
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: Berlin
Posts: 11,357
Default

Geoff, the fourth display bit for the Faderport 8/16 still does nothing it seems. It does not display fixed text or anything else.

Who wrote the support for that ? Perhaps we can ask the author to get it fixed.
__________________
(Video)Using Latch Preview - Faderport16 for CSI v1.0 or CSI v1.1
Airon Audio Dia/FX Edit&Mix
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 11-24-2021, 07:53 AM   #134
benmiller
Human being with feelings
 
benmiller's Avatar
 
Join Date: Dec 2015
Posts: 56
Default select button colors

Hi, Just git started with a csi and a Faderport 16, got it working pretty quickly thanks to this thread. Thank you for this!!

I'm using Aarons fp16 files and decided to do some tweaking but quickly ran into an issue:

I would like the select button to reflect the color of the track.

So in the FP16s&_channel.zon file i moded to this:

Select| TrackUniqueSelect { "Track" }

This sort of works but the color values are not the same as displayed by reaper: green in reaper becomes yellow on FP, Purlple in reaper becomes pink on FP, red in reaper becomes light purple.... etc

any idea how i can fix this?

also, in the original rgb values in the file are are 6 values, 3 for when the track is unselected, and 3 for when the track is selected. Is it somehow possible to scale down the "track" value to have a lighter color when track is unselected? something like:
Select| TrackUniqueSelect { 0.3*"Track" "Track"}


thanks
benmiller is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.