Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 10-16-2018, 05:08 AM   #1
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: City
Posts: 10,139
Default MCU Control surface unresponsive, Reaper unkillable

5.96 x64 Windows 7x64

This may be a driver failure somewhere.

Reaper becomes an unkillable process. If I start another instance of Reaper, it hangs when scanning for control surfaces.

The clearest indicator is when the control surface via the MCU standard plugin becomes unresponsive. It's a Presonus FP16 in Logic mode. Perhaps this is the culprit.

Add to that, turning the surface on and off will not have Windows find the device, so something is definitely hanging.

Here's a dump of the Reaper process. Perhaps you can tell me what's making Reaper behave this way.

https://www.dropbox.com/s/0rbq759o16...llable.7z?dl=0 (160 MB 7Zip)

The only thing that fixes this is a HARD RESET.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 10-16-2018, 06:14 AM   #2
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 22,630
Default

The driver (control surface via MIDI) is hung and reaper is waiting for it to close the midi comm to close out and clean up. Since it is in kernel (OS code), if it never releases you likely have to reboot since that's the only way to clear up the hang down in the OS code.

00 00000000`0012e768 000007fe`fcae3e36 ntdll!ZwDeviceIoControlFile+0xa <=====
01 00000000`0012e770 00000000`76c45cdf KERNELBASE!DeviceIoControl+0x18e06
02 00000000`0012e7e0 000007fe`fa2369dc kernel32!DeviceIoControlImplementation+0x7f
03 00000000`0012e830 000007fe`fa236b97 wdmaud!SyncIoctl+0xc0
04 00000000`0012e8d0 000007fe`fa225f3f wdmaud!PinSetState+0x5f
05 00000000`0012e940 000007fe`fa223d9c wdmaud!CMIDIDeviceBase::CloseMidiPin+0x1f <=======
06 00000000`0012e970 000007fe`fa23a07b wdmaud!CMIDIOutDevice::`vector deleting destructor'+0x2c
07 00000000`0012e9b0 000007fe`fa2372ca wdmaud!_chkstk+0x20eb
08 00000000`0012e9f0 000007fe`fa237593 wdmaud!CRT_INIT+0x96
09 00000000`0012ea40 00000000`76d8778b wdmaud!CRT_INIT+0x35f
0a 00000000`0012eba0 00000000`76d8c1e0 ntdll!LdrShutdownProcess+0x1db
0b 00000000`0012ecc0 00000001`4037275f ntdll!RtlExitUserProcess+0x90 <==== reaper shutting down and this is the transition to kernel code
0c 00000000`0012ecf0 00000001`407c0c11 reaper+0x37275f
0d 00000000`0012fea0 00000000`76c459cd reaper+0x7c0c11
0e 00000000`0012ff60 00000000`76da385d kernel32!BaseThreadInitThunk+0xd

Here's a deeper explanation but most likely driver related..

https://blogs.technet.microsoft.com/...ble-processes/

Either way, that's the issue, outstading driver call not being serviced/answered so it can complete the process shutdown which is preventing reaper from exiting. I noticed wdmaudio, not sure if switching that is possible or will workaround the issue. That's also why it hangs when starting a 2nd reaper process, the hardware is already tied up. You could unplug/re-plugin the hardware when this occurs, it'll either do nothing, force it to release, or BSOD the box.

Last edited by karbomusic; 10-16-2018 at 06:55 AM.
karbomusic is offline   Reply With Quote
Old 10-16-2018, 08:31 AM   #3
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: City
Posts: 10,139
Default

This whole mess only happens after hours of use, and I have the sneaking suspicion it happens when I take a longer break.



I'm checking energy options. Could be that some bumbling fuck-wad of an update changed that..... and USB energy saving options were on. Not sure if that can be it, but it sure points towards USB stuff being screwed. Or some MIDI thing not working well.


I'll check Presonus forums as well. Kinda scared my mainboard is messed up. Or a chipset driver isn't ok and maybe got updated.


Or the USB hubs are messed up. Well, it's just a reset so far.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 10-16-2018, 08:38 AM   #4
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 22,630
Default

Quote:
Originally Posted by airon View Post
This whole mess only happens after hours of use, and I have the sneaking suspicion it happens when I take a longer break.



I'm checking energy options.
This sounds plausible. The stack is pretty clear, we are way down near/at the hardware at the OS level and not receiving an answer (where "we" is the OS). IOW, I don't see where reaper is doing anything wrong really (Justin would need to keep me honest on that part), it's simply exiting and part of that is the cleanup of the driver connection to the hardware which is handled by the OS. It likely isn't possible to know exactly why it isn't responding with just a reaper dump, it would require a full OS kernel dump and likely not worth the trouble since it's likely something like a buss power down or something.

https://docs.microsoft.com/en-us/win...eiocontrolfile

Last edited by karbomusic; 10-16-2018 at 08:46 AM.
karbomusic is offline   Reply With Quote
Old 10-18-2018, 04:10 AM   #5
airon
Human being with feelings
 
airon's Avatar
 
Join Date: Aug 2006
Location: City
Posts: 10,139
Default

I ran a session just a few minutes and it happened again.


It's likely this is a problem from another program, because this tends to happen when I've used other tools as well. I was running Vegas 15 Pro for a little while, and do so fairly often in the past weeks, but that thing must be buggy. Trial's almost over anyway, so I'll try v16 instead or bite the bullet and go for Resolve. Small-time duties on video for fun really.


I'll keep my eye open and report back here. I may not be the only one this could happen to.
__________________
Dialogue/FX Editor & Re-Recording Mixer
(Video)Using Latch Preview
"My ego comes pre-shrunk" - Randy Thom
airon is offline   Reply With Quote
Old 10-18-2018, 06:04 AM   #6
karbomusic
Human being with feelings
 
karbomusic's Avatar
 
Join Date: May 2009
Posts: 22,630
Default

I've been using Resolve 15 for about two months now, so far, so good.
karbomusic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 01:13 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.