Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Bug Reports

Reply
 
Thread Tools Display Modes
Old 02-05-2020, 10:37 AM   #1
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 1,234
Default [Solved] Changing the Equal Gain Crossfade shape eliminates Equal Gain behavior

Hi there,
[EDIT-- OK... I found a fix. There is a mouse modifier option in the preferences under "Media item fade intersection" that allows you to move change the fade shape horizontally only. Also, you can add a modifier to adjust vertically. If you use Horizontally only, you will keep your Equal Gain without messing it up.


When one chooses Equal Gain as a crossfade type, it should be possible to change the crossfade shape without losing the Equal Gain behavior. Regardless of the shape, the the sum of the differences should always result in an equal gain (no change in volume or VU).

This is not the case.

Repro Steps (best done with a sine wave):

1) create a crossfade
2) choose Equal Gain as the crossfade type
3) drag the fade curves vertically to adjust the crossfade shape
4) play back... there is now a volume bump... it behaves like an Equal Power... NOT and equal gain crossfade.
__________________
Cheers,
Andrew K
v6.03+dev0114 - January 14 2020 • Mac 10.12.+ • i7 Quad 2.9GHz • 24GB

Last edited by Thonex; 02-06-2020 at 12:03 PM.
Thonex is online now   Reply With Quote
Old 02-06-2020, 11:19 AM   #2
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 1,234
Default

Just adding a GIF to this... This is an insidious bug. People may not realize this without a GIF. Anyone who thought they were doing Equal Gain crossfades and then adjusted the curve vertically basically went to Equal Power (not Equal Gain) mode:



I think the solution is to restrict the mouse horizontally unless you add a modifier?
__________________
Cheers,
Andrew K
v6.03+dev0114 - January 14 2020 • Mac 10.12.+ • i7 Quad 2.9GHz • 24GB

Last edited by Thonex; 02-06-2020 at 11:49 AM.
Thonex is online now   Reply With Quote
Old 02-06-2020, 12:03 PM   #3
Thonex
Human being with feelings
 
Join Date: May 2018
Location: Los Angeles
Posts: 1,234
Default

OK... I found a fix. There is a mouse modifier option in the preferences under "Media item fade intersection" that allows you to move change the fade shape horizontally only. Also, you can add a modifier to adjust vertically. If you use Horizontally only, you will keep your Equal Gain without messing it up.
__________________
Cheers,
Andrew K
v6.03+dev0114 - January 14 2020 • Mac 10.12.+ • i7 Quad 2.9GHz • 24GB
Thonex is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:43 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.