Old 05-23-2020, 09:44 AM   #1
MartinJG
Human being with feelings
 
Join Date: Oct 2011
Location: UK
Posts: 105
Default How do I set up an East West Play template?

I seem to be suffering a mild attack of brainfade. I have seen several You Tube vids on how to set up and route a Kontakt template on Reaper but cannot find anything on Play. Can anybody recommend or point me in the right direction?

Many thanks

Martin
MartinJG is offline   Reply With Quote
Old 05-23-2020, 02:55 PM   #2
DarkStar
Human being with feelings
 
DarkStar's Avatar
 
Join Date: May 2006
Location: Surrey, UK
Posts: 18,376
Default

This is the simplest way to get started:
(a) right-click in the Track Control Panel (TCP) area below any existing tracks,
(b) select "Insert virtual instrument on new track",
(c) select the VSTi,
(d) click [Yes] on the "Build Routing confirmation" window; that will create tracks for all of the audio outputs from the VSTi,
(e) open the FX window for the VSTi track (click the [fx] button),
(f) select [Options] >> "Build 16 channel of MIDI routing to this track",
(g) disable RecArm on the VSTi track,
(h) if Input Monitoring is Off for the "MIDI" tracks, select them all and turn it on (and turn it on in Preferences >> Track / Send Defaults >> Record config, for future use).
Now you will have 16 tracks sending MIDI (on channels 01 ... 16 respectively) to the VSTi and several tracks for the audio outputs from the VSTi. If you do not need separate MIDI input tracks, omit steps (e) ... (h)

Within the VSTi, load your instruments and set the routing for each one - receiving MIDI on a particular MIDI channel AND sending its audio to a particular audio output pair; depending on the VSTi you may need to do some additional configuration work within the VSTi itself (e.g. to create / enable the output channels).

Back in Reaper, name your MIDI tracks for their destination instruments and add the MIDI. Name the audio tracks too. Colour the tracks as you wish. SAVE them all as a Track Template.
__________________
DarkStar ... interesting, if true. . . . Inspired by ...
DarkStar is offline   Reply With Quote
Old 05-23-2020, 03:55 PM   #3
MartinJG
Human being with feelings
 
Join Date: Oct 2011
Location: UK
Posts: 105
Default

Thanks for getting back. I have double checked everything against your check list and that seems to agree. I can write to the midi tracks so there is a signal there but I am not getting any sound. I have checked the send/receive routing and that seems to be fine, ie 16 receive/sends to plugin master track. No sound on the plugin virtual keyboard either which is odd. I have checked the individual plugin track for one instrument and that works OK. Problem seems to be in the routing to audio.


PS - Cracked it. I had mistakenly turned the VSTi into a parent folder. Force of habit. Consequently, it was no longer functioning as a VST!

Thanks for your help.

Last edited by MartinJG; 05-23-2020 at 06:01 PM.
MartinJG is offline   Reply With Quote
Old 05-25-2020, 01:30 PM   #4
kirk1701
Human being with feelings
 
kirk1701's Avatar
 
Join Date: May 2015
Location: Ontario
Posts: 1,196
Default

Quote:
Originally Posted by DarkStar View Post

Within the VSTi, load your instruments and set the routing for each one - receiving MIDI on a particular MIDI channel AND sending its audio to a particular audio output pair; depending on the VSTi you may need to do some additional configuration work within the VSTi itself (e.g. to create / enable the output channels).
I'm having a similar issue.

The create/enable output channels always stumps me. I can do it in Kontakt, but presently I'm working with Spitfire's BBCSO Discover plugin and I can't seem to find the outputs.
__________________
"I've never trusted Klingons and I never will. I can never forgive them for the death of my boy."
kirk1701 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:18 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.