Old 05-18-2014, 01:24 PM   #1
user2883
Human being with feelings
 
Join Date: Dec 2009
Posts: 18
Default Klinke MCU questions

Hi all,

Since discovering this highly interesting program for use with my BCF2000 I browsed around a bit trying to find answers to my questions. I found some of them but they were scattered around the forums so I created this thread to pose my questions of today and for the future. A big thanks to Klinke for putting the time and effort into this plugin!

1. I'm using the Reaper 4.62 x64. I found that the faders are not at unity positioned at the zero mark on the BCF2000. Any fix to this? By looking at the MCU it looks like they have the same 100mm faders and have their zero mark similar to the BCF2000. See picture below (modified my IKEA Jerker desk and BCF2000 sides with oak..)



2. When in "insert mode" and controlling for example an Eq everything is controlled by the faders. It seems it's not possible to flip in this mode. Are there any other fix to this?

3. The BCF2000 mcu emulation mode doesn't have a name/value button assigned so how do you access the Global actions dialog?

4. The BCF2000 mcu emulation mode have assigned buttons which doesn't seem to match fully with Klinke's mcu plugin. Are there any general Klinke/BCF2000 map out there?

5. How do the upper shift/lower shift/alt/alg gr correspond to the modifier buttons on the MCU? Are the shift and control on the keyboard additional keys or do they correspond to the shift and controll on the MCU?

6. What's the latest version of Klinke's plugin? I'm using 0.8.2.3 (dev2,3)

7. What's the status on the plugin development? Is it alive?

This was the batch of questions for today. Will look in to automation next. Thanks for reading!

Best regards
Attached Images
File Type: jpg faders.jpg (44.5 KB, 2715 views)
user2883 is offline   Reply With Quote
Old 05-18-2014, 02:40 PM   #2
KevinW
Human being with feelings
 
KevinW's Avatar
 
Join Date: Sep 2009
Location: Dayton, Ohio USA
Posts: 1,713
Default

Quote:
Originally Posted by user2883 View Post

4. The BCF2000 mcu emulation mode have assigned buttons which doesn't seem to match fully with Klinke's mcu plugin. Are there any general Klinke/BCF2000 map out there?s
Cool mod. I'd did something similar myself, maybe I'll post a pic one of these days.

I can't answer all your questions, but here's an overlay with the mappings. I personally prefer Cubase emulation mode.
https://www.dropbox.com/s/9i3pc8dqgt...%20overlay.xls

Quote:

5. How do the upper shift/lower shift/alt/alg gr correspond to the modifier buttons on the MCU? Are the shift and control on the keyboard additional keys or do they correspond to the shift and controll on the MCU?
If you enable the option in Klinke's plugin configuration, you can use the right shift (or is it Ctrl?) and right alt keys on your keyboard to replace the buttons on the mcu. The upper/lower shift buttons on the BCF just get you access to certain functions on the BCF - see the overlay above.
KevinW is offline   Reply With Quote
Old 05-18-2014, 04:34 PM   #3
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

Quote:
Originally Posted by user2883 View Post
1. I'm using the Reaper 4.62 x64. I found that the faders are not at unity positioned at the zero mark on the BCF2000. Any fix to this? By looking at the MCU it looks like they have the same 100mm faders and have their zero mark similar to the BCF2000.
This depends on some Reaper settings. The Volume/Pan faders settings in the Track Control Panels are also used for the control surfaces.

Quote:
Originally Posted by user2883 View Post
2. When in "insert mode" and controlling for example an Eq everything is controlled by the faders. It seems it's not possible to flip in this mode. Are there any other fix to this?
Only if there exist no parameter map for an plugin the VPots are unused and all parameters are mapped to faders. The idea is to use VPots for discrete parameters like Filter mode, On/Off switches etc., so flipping doesn't make sense. And the Flip buttons is used to bypass the effect btw.. Please check the manual for more details.

Quote:
Originally Posted by user2883 View Post
3. The BCF2000 mcu emulation mode doesn't have a name/value button assigned so how do you access the Global actions dialog?
You can find in the Action list of Reaper for all buttons a corresponding action. So you can learn the name/value button e.g. to a key of the computer keyboard. Or to a button of an additional controller.

Quote:
Originally Posted by user2883 View Post
6. What's the latest version of Klinke's plugin? I'm using 0.8.2.3 (dev2,3)

7. What's the status on the plugin development? Is it alive?
Yep, 0.8.2.3. And the development is alive but in a deep sleep. But it will weak up soon, sommer is comming ;-)
Klinke is offline   Reply With Quote
Old 05-20-2014, 10:42 AM   #4
user2883
Human being with feelings
 
Join Date: Dec 2009
Posts: 18
Default

Sweet!
Thank you all for your replies!

Next batch of questions:

8. In action mode, what are you using the programmable vpots and button for?

9. If in plugin mode, and I want to use the encoders for example gain (non-discrete value) in an Eq, how do you specify that in the plug maps? I guess someone with a BCR2000 perhaps can fill me in on that one? :-)

10. Is it possible to change the defaul path of My documents/Reaper/MCU?

Regards
user2883 is offline   Reply With Quote
Old 05-21-2014, 12:43 PM   #5
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 6,913
Default

Hi,

just saw your PM with the question about controlling plugin parameters and generating maps.

I once did a video about using ReaEq here.

http://forum.cockos.com/showpost.php...4&postcount=13

ReaEq already has a pre-made map by Klinke though.

In the last part of the video you can see I bring up Klinke's mapping editor. (Alt + "Plugin" button on the BCR)



Enable the "Learn" tickbox, Channel 1-8 at the bottom are the 8 rotaries which you can map to the different plugin parameters.

I think this is better written in the manual than I can explain it.

Does this help already ?
If not, post back where the specific problems are.
nofish is offline   Reply With Quote
Old 05-21-2014, 03:05 PM   #6
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

Quote:
Originally Posted by user2883 View Post
10. Is it possible to change the defaul path of My documents/Reaper/MCU?
No. Maybe a AppData subfolder would be a better place, but I don't plan to change this. Why do you want to change the path?
Klinke is offline   Reply With Quote
Old 05-21-2014, 03:59 PM   #7
user2883
Human being with feelings
 
Join Date: Dec 2009
Posts: 18
Default

Thanks for your contributions so far! Much appreciated!

I got the hang on learning the parameters for the vpots and creating the plugmaps. I understand why continuous values is better suited for the faders. Are the resolution for both faders and encoders 1024 steps?

11. I read in the manual that it's possible to modify the speed of the encoders; in most cases the vpots are a bit too sensitive for changing discrete values. I would if possible prefer to move the pot a bit more before catching a new value. Possible to somewhere change that in plug mode?

Regarding changing path I have all data related items like this stored on a different disk than my system disk. I routinely take backup with Norton Ghost and if placed on my system disk I might miss recent added files and changes.

Regards
user2883 is offline   Reply With Quote
Old 05-24-2014, 12:32 PM   #8
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

I have the impression, that you should move the complete documents folder to your data disc. That can be done easily, see e.g.:

http://windows.microsoft.com/en-us/w...#1TC=windows-7

The faders have a resolution of 10bits = 1024 steps, the encoder just send relativ signals (I can't remember, maybe only +1 and -1). In the action mode a single step can trigger an action multiple times, that's the speed parameter for the action mode. But it's not possible to ignore some signals, but this is what you would need.
Klinke is offline   Reply With Quote
Old 05-26-2014, 03:06 PM   #9
user2883
Human being with feelings
 
Join Date: Dec 2009
Posts: 18
Default

Ok, so I have pretty much everything cleared out by now and am about to start mixing for real. Feels good! And what an amazing piece of software Klinke! I'll donate and show my gratitude for sure!

So, are there anywhere you guys share plugmaps? I have done some of the ones I havent found (mostly newer UAD plugs like API 550, 560, Waves RS56 etc.) and would like to contribute.

A few more questions:

12. If sent a MIDI command which is interpreted by the Klinke MCU plugin but I would like to use a custom command for that MIDI command, which one has the priority and snag the command?

13. Are there any way to close the MCU Editor dialog windows with a command from the controller?

Regards
user2883 is offline   Reply With Quote
Old 05-28-2014, 01:45 PM   #10
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

Quote:
Originally Posted by user2883 View Post
So, are there anywhere you guys share plugmaps? I have done some of the ones I havent found (mostly newer UAD plugs like API 550, 560, Waves RS56 etc.) and would like to contribute.
You can send it to me, and I will add them to the next release, if this is fine for you.

Quote:
Originally Posted by user2883 View Post
A few more questions:

12. If sent a MIDI command which is interpreted by the Klinke MCU plugin but I would like to use a custom command for that MIDI command, which one has the priority and snag the command?
The only way to use a custom command for elements of the controller, that don't send midi events itself to reaper, is to use the MIDI port where the controller is connected also as an controller input in the Reaper MIDI settings (btw. the midi events your are seeing when you assign actions to the Global Section buttons or the VPots in Action Mode are not the midi events from the controller, but generated by the software itself). In this case, always both Reaper and the MCU extension will handle the MIDI event from the controller, so don't do this.

Quote:
Originally Posted by user2883 View Post
13. Are there any way to close the MCU Editor dialog windows with a command from the controller?
I think the same key combination that open the editor will also close it, if it's already open. But I'm not sure and can not test it at the moment. If this does not work, you need to use the mouse or computer keyboard.
Klinke is offline   Reply With Quote
Old 07-03-2014, 07:21 AM   #11
garfieldmayor
Human being with feelings
 
Join Date: Oct 2013
Posts: 13
Default Klinke MCU sluggish performance

Hey folks,

I'd like to join in with those celebrating Klinke's marvelous piece of work in regards to his MCU plugin... Top work Klinke!

Unfortunately, far all it's fantastic functionality, there's one issue that causing me to use my control surface (M-Audio ProjectMix) less and less, and may mean that I have to look for an alternative solution and that's the speed in general.

It's most apparent when trying to change banks (so much so that I've kinda given up using those buttons and rather quick jump) but I get the feeling it's sluggish in most of it's operations.

Has anyone else experienced this problem when using Klinke's solution? Are there any fixes?

I must admit that my current project is a little 'bloated' with hidden tracks etc, and I'm hoping that when I rationalize these I get an improvement, however it's not a problem I'm used to dealing with - the ProjectMix with Cubase was flawless and worked like lightning.

If anyone has any thoughts I'd welcome them!

ps If the you feel this needs to be posted in a separate thread just say - wasn't sure the best place for it!
garfieldmayor is offline   Reply With Quote
Old 07-03-2014, 09:33 AM   #12
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

Quote:
Originally Posted by garfieldmayor View Post
It's most apparent when trying to change banks (so much so that I've kinda given up using those buttons and rather quick jump) but I get the feeling it's sluggish in most of it's operations.
Is this also true, when you change banks in a project that have just 16 empty tracks? Or must it be a "real life" project. If the later is the case, can you please send me (klinkenstecker@gmx.de) one of those projects (just the RPP files)?

I know that the Undo-Handling of the extension can be improved (and I also plan to do this), and can cause some little performance problems, but in my project, this was only perceptible, when I used the debug version of the extension, which need a lot of more cpu cycles then the release version. And also switching banks should not create Undo-Points.
Klinke is offline   Reply With Quote
Old 07-10-2014, 03:52 AM   #13
garfieldmayor
Human being with feelings
 
Join Date: Oct 2013
Posts: 13
Default

Hey Klinke thanks so much for looking into this for me! I've taken the liberty of dropping you a little tip in at Paypal - least I could do really. If you can resolve this matter i'll be happy to chip in a little more since the speed issue is the only thing getting in the way of it being ideal.

I've sent via email my template project which demonstrates the problem. Bank changing without adding any media is slow. If you delete 100 or so of the tracks so you're down to 16, bank changing is back up to speed. Clearly it's an issue with the number of tracks therefore, but as I said, it's not a problem I've experienced with other software.

If you can shed any light on this it would be great! Cheers Garfield
garfieldmayor is offline   Reply With Quote
Old 07-14-2014, 03:26 PM   #14
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

I have found some time to check this issue, and I think I can see your problem, but it's on my computer not as bad as I expected from your description. I think changing the bank takes about 200 ms, on my computer I see only a real problem when you need more then one bank changes at once to get to the correct channels.

Are you aware of the folder mode and quick jump feature of the extension? This should help to decrease the number of necessary bank changes.

But neverless I will check sometime if I can improve the performance, I found the behaviour when I add a lot of new tracks a bit strange and disappointing. You can see that the time between the fader movements for the new created track will get longer and longer.
Klinke is offline   Reply With Quote
Old 07-15-2014, 11:25 AM   #15
garfieldmayor
Human being with feelings
 
Join Date: Oct 2013
Posts: 13
Default

Yeah the quick jump thing is the only thing that's keeping me onboard right now... Haven't looked into folders much though I must admit... Maybe I'll give it a go. Do let me know if you come up with any improvements though thanks!
garfieldmayor is offline   Reply With Quote
Old 10-24-2014, 02:53 PM   #16
BrufordRules
Human being with feelings
 
BrufordRules's Avatar
 
Join Date: Jan 2008
Posts: 40
Question MCU Klinke latest version?

Hi all,

Where can I find MCU Klinke latest version?

Mine is 0.8.0.3 but some users have installed 0.8.2.3 version.

Is there an official page for that?

Thanks in advance.

Alex
__________________
Bill Bruford on King Crimson: This is a band where you get to play in weird time signatures and still stay in nice hotels.
BrufordRules is offline   Reply With Quote
Old 10-24-2014, 04:45 PM   #17
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

https://bitbucket.org/Klinkenstecker..._mcu/downloads
Klinke is offline   Reply With Quote
Old 11-10-2014, 05:13 AM   #18
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Stupid Question:

how do i get to the "Main Options of the Pan-Mode" dialogue in BCF2000-MCU Mode ?

The shift key does not work, and the other key (pan/surround) is missing

Last edited by Mink99; 02-26-2015 at 02:19 PM.
Mink99 is offline   Reply With Quote
Old 11-13-2014, 06:13 AM   #19
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Sorry to bump ....
Mink99 is offline   Reply With Quote
Old 11-16-2014, 12:12 PM   #20
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Did further analysis : The shift keys only work when sent from keyboard , not from the mixer . So moving back to standard mcu mode. The only feature I needed cannot be set due to a "missing" button.


Btw is it possible to hide channels / tracks from the remote mixer which are not visible in either tcp or mcp ? Without klinke ....
Mink99 is offline   Reply With Quote
Old 02-07-2015, 06:02 PM   #21
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Still sorry to bump
Mink99 is offline   Reply With Quote
Old 02-26-2015, 02:07 PM   #22
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Angry

Bump or die .....
Mink99 is offline   Reply With Quote
Old 02-26-2015, 06:18 PM   #23
KevinW
Human being with feelings
 
KevinW's Avatar
 
Join Date: Sep 2009
Location: Dayton, Ohio USA
Posts: 1,713
Default

Quote:
Originally Posted by Mink99 View Post
Bump or die .....
I refer you to page 3 of the Klinke manual, where it instructs you to check the box in Reaper's csurf setup that says "use keyboard modifier".

Once you do that, then the Right-Alt key on your keyboard will behave as the MCU Option button.

Pressing Right-Alt then gets you the main pan options, and pressing shift-right Alt gets you additional options.
KevinW is offline   Reply With Quote
Old 03-02-2015, 12:18 PM   #24
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

thank you, but no, right alt is not recognized.
or maybe it is that the pan-mode button that should be pressed, is still missing on the bcf ?
or even more easy : two buttons should be pressed : one on the keyboard: this is alt-gr ... one on the bcf : this is what ?

Last edited by Mink99; 03-02-2015 at 12:28 PM.
Mink99 is offline   Reply With Quote
Old 03-05-2015, 06:55 AM   #25
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

No, you don't have to press any other key, when you press Alt-Gr (and the "use keyboard modifier" option is turned on), then the display of the MCU shows the options, that corresponds to the actual mode. Which leads to the question: Do you have BCFview (or somethings else, that emulates the display of the MCU) running?
Klinke is offline   Reply With Quote
Old 03-05-2015, 07:32 AM   #26
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Sorry, but then i am lost even more. I want to change the settings that now I can see.

I expected from the manual that there would be a dialogue called "main options of the pan mode" that would be triggered somehow where I could change the setting "show only those items that are in the mcp". Sorry I do not get it...
Mink99 is offline   Reply With Quote
Old 03-05-2015, 08:13 AM   #27
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 6,913
Default

Quote:
Originally Posted by Mink99 View Post
Sorry, but then i am lost even more. I want to change the settings that now I can see.

I expected from the manual that there would be a dialogue called "main options of the pan mode" that would be triggered somehow where I could change the setting "show only those items that are in the mcp". Sorry I do not get it...
Here's a screencapture how it works



It's starts with 'normal' (Pan) mode, than I press 'Alt Gr' and the main Pan mode options show up.
I than change these settings by turning the VPots - while still holding 'Alt Gr' ! (or maybe moving the faders, don't know how it works on the BCF, I'm using the BCR).

Does this help ?

(edit: Ignore the shown mouse button press at the beginning, that's not needed, just happened by accident)

Last edited by nofish; 03-05-2015 at 08:33 AM.
nofish is offline   Reply With Quote
Old 03-05-2015, 10:28 AM   #28
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Thanks working perfectly
Mink99 is offline   Reply With Quote
Old 03-15-2015, 10:28 AM   #29
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

have to correct last statement: third time

Problemsignatur:
Problemereignisname: APPCRASH
Anwendungsname: reaper.exe
Anwendungsversion: 4.7.7.0
Anwendungszeitstempel: 54d69429
Fehlermodulname: reaper_csurf_mcu_klinke_x64.dll
Fehlermodulversion: 0.0.0.0
Fehlermodulzeitstempel: 51aa5a67
Ausnahmecode: c0000005
Ausnahmeoffset: 00000000000421dd
Betriebsystemversion: 6.1.7601.2.1.0.256.48
Gebietsschema-ID: 1031
Zusatzinformation 1: e434
Zusatzinformation 2: e434574466a6e758a9bfcc63f6a7f883
Zusatzinformation 3: 1d34
Zusatzinformation 4: 1d3469b3799498540123b80724811232
Mink99 is offline   Reply With Quote
Old 03-15-2015, 01:25 PM   #30
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

Tied the crashes occur while you undone some previous action?
Klinke is offline   Reply With Quote
Old 03-17-2015, 12:59 AM   #31
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

They occurred when copying patterns. It might have been that I was not perfectly in the horizontal axis so that reaper created a new track and immediately removed it.
Mink99 is offline   Reply With Quote
Old 03-22-2015, 07:42 AM   #32
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

I think that could project-save/load function of the extension, which is also used when you undo something. The problem is, that this crash only appear sometimes and only one some computers (and maybe only in the 64bit version, because I got only reports from people using the 64bit version). I could reproduce them in the past, but not currently, which makes debugging difficult.

I have build a version, where the project-saving/loadings stuff is completly disabled. This the big disadvantage, that all the configuration you have done for the MCU (like anchors, quick-jumps etc.) are not stored with the Reaper project, so this can not be a final solution, but in the case that this version is working for you, I have a small hint, that I'm searching at the right place.

So please download this version (in has the version number v0.8.2.4), from here: https://dl.dropboxusercontent.com/u/...klinke_x64.dll and send me a note about the results.
Klinke is offline   Reply With Quote
Old 03-23-2015, 03:23 AM   #33
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

Have downloaded, will have it running for the next days and report back, Thank you.
Mink99 is offline   Reply With Quote
Old 03-26-2015, 07:37 PM   #34
Mink99
Human being with feelings
 
Mink99's Avatar
 
Join Date: Jan 2011
Location: Zürich
Posts: 1,001
Default

sorry copied 1 Item, navigated to start of track...

Problemsignatur:
Problemereignisname: APPCRASH
Anwendungsname: reaper.exe
Anwendungsversion: 4.7.7.0
Anwendungszeitstempel: 54d69429
Fehlermodulname: reaper_csurf_mcu_klinke_x64.dll
Fehlermodulversion: 0.0.0.0
Fehlermodulzeitstempel: 550ecd3e
Ausnahmecode: c0000005
Ausnahmeoffset: 00000000000418dd
Betriebsystemversion: 6.1.7601.2.1.0.256.48
Gebietsschema-ID: 1031
Zusatzinformation 1: e434
Zusatzinformation 2: e434574466a6e758a9bfcc63f6a7f883
Zusatzinformation 3: 2076
Zusatzinformation 4: 20767215033401a8a123e86a2e101d17

Lesen Sie unsere Datenschutzbestimmungen online:
http://go.microsoft.com/fwlink/?link...8&clcid=0x0407

Wenn die Onlinedatenschutzbestimmungen nicht verfügbar sind, lesen Sie unsere Datenschutzbestimmungen offline:
C:\Windows\system32\de-DE\erofflps.txt


licecap in zip...

Last edited by Mink99; 08-19-2015 at 08:42 AM.
Mink99 is offline   Reply With Quote
Old 03-31-2015, 03:02 AM   #35
Noizeskill
Human being with feelings
 
Join Date: Apr 2013
Posts: 38
Smile

Quote:
Originally Posted by Klinke View Post
I think that could project-save/load function of the extension, which is also used when you undo something. The problem is, that this crash only appear sometimes and only one some computers (and maybe only in the 64bit version, because I got only reports from people using the 64bit version). I could reproduce them in the past, but not currently, which makes debugging difficult.

I have build a version, where the project-saving/loadings stuff is completly disabled. This the big disadvantage, that all the configuration you have done for the MCU (like anchors, quick-jumps etc.) are not stored with the Reaper project, so this can not be a final solution, but in the case that this version is working for you, I have a small hint, that I'm searching at the right place.

So please download this version (in has the version number v0.8.2.4), from here: https://dl.dropboxusercontent.com/u/...klinke_x64.dll and send me a note about the results.
Hi! first of all ! thanks for your Amazing work!i love it!
i'm using the icon qcon lite in logic mode whit your extension ! sometimes i can modify the sends whit the fader and the display show me the amount of the send in "db" ...and sometimes i can modify this just whit the vpot whitout see the amount on the display ?? im going nuts triyng "flip" and every combination of buttons ...
so my question is ,.... what am i doing in wrong way ???
thank in advance !!
Noizeskill is offline   Reply With Quote
Old 04-02-2015, 07:55 AM   #36
Klinke
Human being with feelings
 
Klinke's Avatar
 
Join Date: Jul 2008
Location: Berlin / Germany
Posts: 728
Default

Quote:
Originally Posted by Noizeskill View Post
Hi! first of all ! thanks for your Amazing work!i love it!
i'm using the icon qcon lite in logic mode whit your extension ! sometimes i can modify the sends whit the fader and the display show me the amount of the send in "db" ...and sometimes i can modify this just whit the vpot whitout see the amount on the display ?? im going nuts triyng "flip" and every combination of buttons ...
so my question is ,.... what am i doing in wrong way ???
thank in advance !!
The MCU has a button called "Flip", pressing this button flips the fader and VPOTs in many of the extension modes, maybe also in the Send-Mode. From the description I got the impression, that you sometimes activate somehow this Flip-button.
Klinke is offline   Reply With Quote
Old 08-15-2015, 06:55 PM   #37
fdisaia
Human being with feelings
 
Join Date: Aug 2015
Posts: 1
Default Tracks being controlled visually shown on Mixer

Hi all, this is my first writing on the forum, first of all the klinke MCU plugin is great!!,

I have only one question, does anyone know if theres is any posibility of make de Mixer of Reaper show the tracks that are on my controllers active bank?, I have the iCON IControls Pro that has no display on it, and the only thing that frustrates me is that i have to select one track to know in wich part of the mixer i am, with a few tracks it's ok, but when the project has a lot of tracks it's very hard to know.
I know that other DAW's as Nuendo has the capability of doing this, but i couldn't find it on Reaper.

Thanks
fdisaia is offline   Reply With Quote
Old 08-16-2015, 09:24 AM   #38
LugNut
Human being with feelings
 
Join Date: Jun 2013
Location: So Florida
Posts: 580
Default

Quote:
Originally Posted by fdisaia View Post
Hi all, this is my first writing on the forum, first of all the klinke MCU plugin is great!!,

I have only one question, does anyone know if theres is anyhttp://mountainutilities.eu/miditoolsibility of make de Mixer of Reaper show the tracks that are on my controllers active bank?, I have the iCON IControls Pro that has no display on it, and the only thing that frustrates me is that i have to select one track to know in wich part of the mixer i am, with a few tracks it's ok, but when the project has a lot of tracks it's very hard to know.
I know that other DAW's as Nuendo has the capability of doing this, but i couldn't find it on Reaper.

Thanks
Hi,

Not at comp now but....

There is a function in knlinkes cs that allows you to do just that..unfortunately w no cs display you can't see them. Its in the klinke manual.

You can however use a virtual cs display. This will run on the bottom of your comp screen and emulates an MCU display. On PC I use mountain utilities. You hook it up between the comp and the icon using virtual midi cables. Once setup it works well.

I can't copy pate links on tablet now..stupid browser.....but its called midi tools by mountain utilities.
Good luck,
Guido

Edit...I had a similar situation with my d8b board...no MCU display.
It just so happened that a 10inch tablet on its side resting on my meter bridge lines up perfectly with the 8 faders I have per bank. I use the tablet as a second computer monitor and put the MCU display on the bottom of that.

I did a horrible video about it...maybe I can find....

http://forum.cockos.com/showthread.php?t=134026

Last edited by LugNut; 08-16-2015 at 09:39 AM.
LugNut is offline   Reply With Quote
Old 10-23-2016, 02:04 PM   #39
sfb
Human being with feelings
 
Join Date: Jul 2007
Posts: 47
Default Causes lag with a large number of tracks / big projects

Quote:
Originally Posted by Klinke View Post
But neverless I will check sometime if I can improve the performance, I found the behaviour when I add a lot of new tracks a bit strange and disappointing. You can see that the time between the fader movements for the new created track will get longer and longer.
Was this ever addressed? I had been searching for the source of sluggishness when dealing with a large number of tracks (my projects often require more than 500), assuming it was my older system. I recently upgraded to a new, much more powerful PC and found similar issues. For example, when I select a new track, there's a lag in the UI and REAPER temporarily freezes for several seconds. This occurs even when I start a new project and simply create a large number of empty tracks. I finally deduced it was this plugin (v8.3.4) which I'm using with a Nanokontrol 2. When I try the regular MCU plugin (which doesn't quite map correctly to the buttons), it does not exhibit the same lag.

Any help or advice? Thank you!

-sfb
sfb is offline   Reply With Quote
Old 07-15-2017, 10:25 AM   #40
Munchmastr
Human being with feelings
 
Join Date: Jul 2017
Posts: 2
Default

Quote:
Originally Posted by nofish View Post
Here's a screencapture how it works



It's starts with 'normal' (Pan) mode, than I press 'Alt Gr' and the main Pan mode options show up.
I than change these settings by turning the VPots - while still holding 'Alt Gr' ! (or maybe moving the faders, don't know how it works on the BCF, I'm using the BCR).

Does this help ?

(edit: Ignore the shown mouse button press at the beginning, that's not needed, just happened by accident)
Is there any way to get around using the VPots to change the main options settings? I am using a Faderport 8 and it doesn't have the VPot buttons or equivalent, so I can't change. Tried all the buttons. I tried changing the MultiTrackOptions1 XML file, but it seems to auto update and override my change. haha I have no clue what I'm doing, just trying to figure this out.
Munchmastr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 03:51 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2017, vBulletin Solutions Inc.