Old 02-13-2020, 06:37 PM   #6561
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Cragster View Post
Qcon Prox .it used to work i dont know.something in the new build ? i mean the send controls still work its just the display still keeps the track info on it.i guess its not a big issue.i can get used to it
Hang in there, Geoff just hasn't incorporated the code that blanks things and makes it look tidy yet.

Quote:
is it ok to get rid of the .ini on my desktop ?
Sure, if you've rebuilt the prefs and it's all working (blanking notwithstanding)
MixMonkey is offline   Reply With Quote
Old 02-13-2020, 06:44 PM   #6562
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 410
Default

Quote:
Originally Posted by MixMonkey View Post
Hang in there, Geoff just hasn't incorporated the code that blanks things and makes it look tidy yet.



Sure, if you've rebuilt the prefs and it's all working (blanking notwithstanding)
ok im hanging .thanks for your help man !!
Cragster is offline   Reply With Quote
Old 02-13-2020, 07:00 PM   #6563
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Cragster View Post
thanks for your help man !!
You're welcome. Who knows?, one day it might actually help you
MixMonkey is offline   Reply With Quote
Old 02-13-2020, 07:00 PM   #6564
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 410
Default

Code:
Read TrackAutoMode "1"
Shift+Read GlobalAutoMode "1"
Write TrackAutoMode "3"
Shift+Write GlobalAutoMode "3"
Trim TrackAutoMode "0"
Shift+Trim GlobalAutoMode "0"
Touch TrackAutoMode "2"
Shift+Touch GlobalAutoMode "2"
Latch TrackAutoMode "4"
Shift+Latch GlobalAutoMode "4"
These GlobalAutoMode csi commands are in my zone file (from the previous owner) with modifiers for the automation controls.ive been using my automation old style not through my surface with csi.can anyone give me a rundown on what these are and maybe what they do ? Thanks again.i know i ask alot of questions
Cragster is offline   Reply With Quote
Old 02-13-2020, 07:06 PM   #6565
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,035
Default

New build is up.

Trailing comments now supported, just use "//" followed by the comment:

Code:
Zone aZoneName
    Widget1 anAction // a trailing comment
ZoneEnd
__________________
CSI - You can donate here: geoffwaddington.ca
Beta software: https://stash.reaper.fm/v/38349/CSI%20beta.zip
installation and documentation here: https://github.com/malcolmgroves/reaper_csi/wiki
Geoff Waddington is offline   Reply With Quote
Old 02-13-2020, 07:57 PM   #6566
knadles
Human being with feelings
 
knadles's Avatar
 
Join Date: May 2012
Location: Chicago, IL, USA
Posts: 21
Default

Haven't been on in a few days and my last condition was that the MCU Pro display started working, but the fader bank controls didn't work. I just downloaded the current build and installed. Now the display is gone again and the MCU Pro doesn't respond at all. It has been suggested I post the zon file, which I assume is in the Zone folder. I don't know if this helps because I didn't edit it (I don't know enough about it to start changing things), but this is what it looks like. Again, the Mackie might as well be disconnected from the computer (which it isn't), because there's literally no reaction when I open Reaper. That wasn't true 10 minutes ago, prior to the install.

Code:
Zone Home
	OnTrackSelection MapSelectedTrackSendsToWidgets
	IncludedZones
		"Buttons|"
		"Channel|1-8"
		"MasterChannel|"
	IncludedZonesEnd
ZoneEnd

Zone "Buttons|"
	Send 		ToggleMapSelectedTrackSends
	Track 		ToggleMapSelectedTrackFXMenu
	Pan 		ToggleMapSelectedTrackFX
        ChannelLeft 	TrackBank "-1"
	ChannelRight 	TrackBank "1"
	BankLeft 	TrackBank "-8"
	BankRight 	TrackBank "8"
	Rewind 		Rewind
	FastForward	FastForward
	Stop 		Stop
	Play 		Play
	Record 		Record
	F1 		NextPage

	smpteBeats CycleTimeDisplayModes
	TimeDisplay TimeDisplay

	Read 	TrackAutoMode 	"1"
	Write 	TrackAutoMode 	"3"
	Trim 	TrackAutoMode 	"0"
	Touch 	TrackAutoMode 	"2"
	Latch 	TrackAutoMode 	"4"
	Group	Reaper 		"42023"

	Shift+Read 	GlobalAutoMode 	"1"
	Shift+Write 	GlobalAutoMode 	"3"
	Shift+Trim 	GlobalAutoMode 	"0"
	Shift+Touch 	GlobalAutoMode 	"2"
	Shift+Latch 	GlobalAutoMode 	"4"
	Shift+Group	Reaper 		"42024"

	Save 		Reaper 		"40026"
	Shift+Save 	Reaper 		"40022"

	Undo 		Reaper 		"40029"
	Shift+Undo 	Reaper 		"40030"

	Shift 		Shift
	Option 		Option
	Control 	Control
	Alt 		Alt

	Marker 		Reaper 		"40172"
	Shift+Marker 	Reaper 		"40157"
	Option+Marker 	Reaper 		"40174"

	Nudge 		Reaper 		"40173"
	Cycle 		CycleTimeline
	Click 		Reaper 		"40364"
ZoneEnd


Zone "Channel|"
	TrackNavigator
	DisplayUpper|  			TrackNameDisplay
	DisplayLower| 			TrackPanDisplay
	TrackTouch+DisplayLower| 	TrackVolumeDisplay
	RotaryPush| 			GoZone PanWidth|
	Rotary| 			TrackPan "0"
	RecordArm|  			TrackRecordArm
	Solo|  				TrackSolo
	Mute| 				TrackMute
	Select|  			TrackUniqueSelect
	Shift+Select|  			TrackRangeSelect
	Control+Select|  		TrackSelect
	Shift+Control+Select| 		TogglePin
	Option+Select| 			TrackFolderDive
	Fader|  			TrackVolume
	FaderTouch|  			TrackTouch
ZoneEnd

Zone "MasterChannel|"
	MasterTrackNavigator
	MasterFader 	TrackVolume
zoneEnd

Zone "Pan|1-8"
	TrackNavigator
	Rotary| 	TrackPan "0"
	RotaryPush| 	GoZone PanWidth|
ZoneEnd

Zone "PanWidth|1-8"
	TrackNavigator
	Rotary| 	TrackPanWidth "1"
	RotaryPush| 	GoZone Pan|
ZoneEnd

Zone "Send|1-8"
	SelectedTrackNavigator
	DisplayUpper|  			TrackSendNameDisplay
	TrackTouch+DisplayUpper|	TrackSendVolumeDisplay
	Mute| 				TrackSendMute
	Fader|  			TrackSendVolume
	TrackTouch+Fader|  		TrackSendVolume
	FaderTouch|  			TrackTouch
ZoneEnd

Zone "FXMenu|1-4"
	SelectedTrackNavigator
	DisplayUpper|  	FXNameDisplay |
	RotaryPush| 	GoFXSlot |
ZoneEnd
Thanks,
Pete
knadles is offline   Reply With Quote
Old 02-13-2020, 08:13 PM   #6567
Dberman
Human being with feelings
 
Join Date: Jan 2020
Posts: 28
Default

Quote:
Originally Posted by Funkybot View Post
I just bought an X-Touch one and have been setting it up. Pretty much everything works now (with the build Geoff just posted).

1. Backup your .mst and .zon files (make a copy of each and rename them X-TouchOne.bak for example).
2. Set the X-Touch One to MCU S1 mode (for now, just to test)
3. Replace your .zon with the attached one
4. Replace your .mst with the attached one
5. Report back
@Funkybot, yes! just about everything works, including channel faders. Questions for you:
- Did you choose MCU S1 mode for any particular reason? I see some of the MIDI addresses are different than MCU Std or User.
- The faders work perfectly! is that because you defined 8 of them in your mst? Is the same true for track arm, solo, mute?

Thanks again for all the help. The light is slowly coming on and I almost understand what I'm doing.
Dberman is offline   Reply With Quote
Old 02-13-2020, 08:14 PM   #6568
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by knadles View Post
Haven't been on in a few days and my last condition was that the MCU Pro display started working, but the fader bank controls didn't work. I just downloaded the current build and installed. Now the display is gone again and the MCU Pro doesn't respond at all. It has been suggested I post the zon file, which I assume is in the Zone folder. I don't know if this helps because I didn't edit it (I don't know enough about it to start changing things), but this is what it looks like. Again, the Mackie might as well be disconnected from the computer (which it isn't), because there's literally no reaction when I open Reaper. That wasn't true 10 minutes ago, prior to the install.

Did you happen to overwrite the csi.ini when you updated? That's my guess. Go into Reaper's Preferences -> Control Surfaces -> CSI, then check out the CSI devices on the Home Screen...you may be looking at a bunch of unfamiliar devices because that's Geoff's setup. If so, just delete them and setup your MCU again.
Funkybot is online now   Reply With Quote
Old 02-13-2020, 08:20 PM   #6569
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by Dberman View Post
@Funkybot, yes! just about everything works, including channel faders. Questions for you:
- Did you choose MCU S1 mode for any particular reason? I see some of the MIDI addresses are different than MCU Std or User.
- The faders work perfectly! is that because you defined 8 of them in your mst? Is the same true for track arm, solo, mute?

Thanks again for all the help. The light is slowly coming on and I almost understand what I'm doing.
Happy to hear it works now!

Ok so, without getting too deep into it...S1, Logic, and Cubase modes should all work VERY well. I didn't use Reaper mode because for some reason Behringer didn't map a button. MCU Std and MCU User modes are out because they only use 1 fader and 1 master, whereas the other DAW modes use 8 [virtual] faders and 1 master. The Waveform MCU mode is very bizarre in terms of what buttons they mapped and to which widgets - stay away from that one. So feel free to experiment with the other MCU DAW modes and pick a favorite as a starting point. They should all work pretty well. It's really about what default widgets you want to see and which overlay you want to use.

The reason the faders work now, is because of that 8 fader + 1 master thing I mentioned. I guess this is the MCU standard, and the MCU DAW modes are all configured this way.

MCU Std and MCU User modes for some reason are assigned to fader 5, and the channel select buttons don't work to change that. That's why it wasn't working for you. We were expecting it would be fader 1 that those modes used, but it wasn't.

Hope that kind of makes sense. It's hard to figure out without going in and experimenting with all the different modes to see what the unit does. I'll continue to refine the .mst and .zon files a bit further in the coming days so if you pop back in a few, I may have further refined it, but for now, I'm glad you're up and running!

If you note what isn't working and what you'd like a particular button to do, let me know what mode/overlay your using, and what isn't mapped and I can add it or show you how.
Funkybot is online now   Reply With Quote
Old 02-13-2020, 08:55 PM   #6570
knadles
Human being with feelings
 
knadles's Avatar
 
Join Date: May 2012
Location: Chicago, IL, USA
Posts: 21
Default

Quote:
Originally Posted by Funkybot View Post
Did you happen to overwrite the csi.ini when you updated? That's my guess. Go into Reaper's Preferences -> Control Surfaces -> CSI, then check out the CSI devices on the Home Screen...you may be looking at a bunch of unfamiliar devices because that's Geoff's setup. If so, just delete them and setup your MCU again.
I've been installing everything fresh every time. The first thing I do after install is delete the Home page with all the funky bits. Then I add a "Pete" home page, and on the surfaces side, I click "Add Midi." In the dialog window, I give it the name "Mackie." Midi in and out show RME Fireface 802 Port 1. The surface is set to MCU.mst. And the Zone folder shows MCU. None of the boxes are checked.

Is that correct, or should I be doing something else?

Thanks,
Pete
knadles is offline   Reply With Quote
Old 02-13-2020, 09:18 PM   #6571
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Pete, so far sounds like you're doing everything right.

Question: I guess you're using one of the older Mackie surfaces hooked up to your Fireface 802 MIDI input via a MIDI 5-pin DIN cable? If so, that part sounds good. If not, what specific surface are you using and how is it connected to Reaper?

Another question: assuming the Mackie connects to the 802, is the Fireface 802 MIDI Port disabled in Reaper's Preferences -> MIDI Devices? For CSI to work, any Control Surfaces need to have their ports disabled in Reaper.
Funkybot is online now   Reply With Quote
Old 02-13-2020, 10:15 PM   #6572
knadles
Human being with feelings
 
knadles's Avatar
 
Join Date: May 2012
Location: Chicago, IL, USA
Posts: 21
Default

Itís the silver MCU Pro. I donít know if there are different model numbers. I think it has the Alps faders, which I believe is the newer version, but Iím not sure. I bought it used about 4-5 years ago.

I have it connected through the USB. Itís not linked to the RME at all. Are you saying I need to disable the MIDI ports on the Mackie? I donít use them anyway. I think theyíre mostly for connecting an XT, which I donít have.

Thanks,
Pete
knadles is offline   Reply With Quote
Old 02-13-2020, 11:15 PM   #6573
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by knadles View Post

I have it connected through the USB. Itís not linked to the RME at all. Are you saying I need to disable the MIDI ports on the Mackie? I donít use them anyway. I think theyíre mostly for connecting an XT, which I donít have.
You previously said...

Quote:
in the dialog window, I give it the name "Mackie." Midi in and out show RME Fireface 802 Port 1
Those MIDI ports should be pointing to the Mackie ports when you're setting up the surface in CSI. Not the 802.

The Mackie ports need to be disabled in Reaper's Preferences->MIDI Devices and need to be enabled in the CSI device ports.
Funkybot is online now   Reply With Quote
Old 02-14-2020, 04:57 AM   #6574
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Cragster View Post
Code:
Read TrackAutoMode "1"
Shift+Read GlobalAutoMode "1"
Write TrackAutoMode "3"
Shift+Write GlobalAutoMode "3"
Trim TrackAutoMode "0"
Shift+Trim GlobalAutoMode "0"
Touch TrackAutoMode "2"
Shift+Touch GlobalAutoMode "2"
Latch TrackAutoMode "4"
Shift+Latch GlobalAutoMode "4"
These GlobalAutoMode csi commands are in my zone file (from the previous owner) with modifiers for the automation controls.ive been using my automation old style not through my surface with csi.can anyone give me a rundown on what these are and maybe what they do ? Thanks again.i know i ask alot of questions
https://reaperblog.net/2017/07/reape...des-explained/

MixMonkey is offline   Reply With Quote
Old 02-14-2020, 06:34 AM   #6575
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

Trailing comments now supported, just use "//" followed by the comment:

Code:
Zone aZoneName
    Widget1 anAction // a trailing comment
ZoneEnd
Thanks for the trailing comments

Could we get the display blanking fixed?
MixMonkey is offline   Reply With Quote
Old 02-14-2020, 10:32 AM   #6576
knadles
Human being with feelings
 
knadles's Avatar
 
Join Date: May 2012
Location: Chicago, IL, USA
Posts: 21
Default

Quote:
Originally Posted by Funkybot View Post
Those MIDI ports should be pointing to the Mackie ports when you're setting up the surface in CSI. Not the 802.

The Mackie ports need to be disabled in Reaper's Preferences->MIDI Devices and need to be enabled in the CSI device ports.
Thanks, Funkybot! I'll do that tonight!

Pete
knadles is offline   Reply With Quote
Old 02-14-2020, 12:26 PM   #6577
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,035
Default

New build is up.

First shot at restoring blanks.
__________________
CSI - You can donate here: geoffwaddington.ca
Beta software: https://stash.reaper.fm/v/38349/CSI%20beta.zip
installation and documentation here: https://github.com/malcolmgroves/reaper_csi/wiki
Geoff Waddington is offline   Reply With Quote
Old 02-14-2020, 01:28 PM   #6578
Dberman
Human being with feelings
 
Join Date: Jan 2020
Posts: 28
Default

Quote:
Originally Posted by Funkybot View Post
Happy to hear it works now!

Ok so, without getting too deep into it...S1, Logic, and Cubase modes should all work VERY well. I didn't use Reaper mode because for some reason Behringer didn't map a button. MCU Std and MCU User modes are out because they only use 1 fader and 1 master, whereas the other DAW modes use 8 [virtual] faders and 1 master. The Waveform MCU mode is very bizarre in terms of what buttons they mapped and to which widgets - stay away from that one. So feel free to experiment with the other MCU DAW modes and pick a favorite as a starting point. They should all work pretty well. It's really about what default widgets you want to see and which overlay you want to use.
@Funkybot, I tried most of the modes, and of course there are different mappings. At this point I'm trying to figure out a couple things. The .mst and .zon file you posted are for S1 mode, but when I press buttons in MIDI-OX, the addresses don't always match your widget definitions and actions in the zone file. For example, the button labeled F1 on the X-Touch is 90 36 7f in your widget, but MIDI-OX says it's 90 4a 7f in S1 mode. The Reaper action assigned to the F1 widget in your zone file actually triggers when I press the button labeled Solo, which doesn't match either MIDI address.

Like I said, I'm trying to understand so I can customize on my own. I copied what I thought were the relevant widgets and actions to my original files, but didn't get the same results. Is that because of the MIDI addresses?
Dberman is offline   Reply With Quote
Old 02-14-2020, 01:45 PM   #6579
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by Dberman View Post
@Funkybot, I tried most of the modes, and of course there are different mappings. At this point I'm trying to figure out a couple things. The .mst and .zon file you posted are for S1 mode, but when I press buttons in MIDI-OX, the addresses don't always match your widget definitions and actions in the zone file. For example, the button labeled F1 on the X-Touch is 90 36 7f in your widget, but MIDI-OX says it's 90 4a 7f in S1 mode. The Reaper action assigned to the F1 widget in your zone file actually triggers when I press the button labeled Solo, which doesn't match either MIDI address.

Like I said, I'm trying to understand so I can customize on my own. I copied what I thought were the relevant widgets and actions to my original files, but didn't get the same results. Is that because of the MIDI addresses?
Are you using the overlays? I can't emphasize this enough, but the buttons literally change depending on the mode!

So the button labeled F1 on the X-Touch surface stops being F1 in Studio One mode, in that mode, it's actually now the MCU "Read" button, which is why the address changes.

To further complicate things, some DAW modes further reassign actions to different widgets. The thing to understand is basically this...

1. MCU is a fixed protocol. There's a set number of buttons that are intended to relate to set actions. The button names correspond to the action (Play is Play, Read is Read, etc.). So one MCU.mst should technically work for all MCU surfaces without further modification. This assumes no user customization is needed - like how I want to reassign Zoom and make it a Shift button.

2. The X-Touch One doesn't have fixed buttons like it initially seems. Each MCU mode will literally reassign buttons. So one MCU mode may take the F1 button and either keep it F1, while a different mode may take that same physical button and turn it into the MCU Read button via the software, or a Marker Back button, etc. Most of the time, the only way to know which MCU button is currently in effect is to look at the device overlay for that particular mode. This is why your address is changing. That F1 button your seeing is really now a Read button. You'd only know by looking at the overlay.

3. For instance, none of the modes expose the MCU "Save" button. The MCU protocol has a button called "Save." It doesn't exist in the X-Touch One...ECXEPT in MCU Waveform mode. There, the MCU "Save" button has been assigned to the Write action in Waveform. Why didn't they just use the MCU "Write" button? No effing clue. Has to be a Waveform specific thing. Or someone at Behringer was on mushrooms while they were coding the buttons.

So my advice to you is this:

1. Pick Logic, S1, or Cubase mode to start (look at the overlays for the available functions and pick the one that most fits your workflow).

2. Once you do that, use the overlay for that MCU mode to determine the widget names. Note: if you bought it second hand or otherwise don't have the overlays handy, you can download them from Behringer.

3. Now, if you want to change an action, find the button name in the overlay, and edit that action in the zone. Example: let's say you pick Logic mode. You're X-Touch will be set to MCU Logic, you'll have the Logic overlay on...now let's say you want the "Group" button to work as an Undo button instead. You'll open the .zon file, find the "Group" widget, and edit the action to use Reaper's undo action instead.

Last edited by Funkybot; 02-14-2020 at 01:52 PM.
Funkybot is online now   Reply With Quote
Old 02-14-2020, 07:14 PM   #6580
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

First shot at restoring blanks.
Sorry for the late response, been out all evening

Only had a quick look, but menu blanking seems to be working again

Unused 'spaces' (when there are less than 8 sends or FX slots) now blank whatever info was displayed prior to entering the Send/FXMenu Zone (I have AutoMap on)

The only way the behaviour differs now, as far as I can tell, is that rows B and C of the C4 now don't blank when I return to the FXMenu, but I can probably take care of that in the Send and FXMenu .zons eith some NoActions.

I'll have a more thorough look this afternoon and report back. Thanks for this Geoff!
MixMonkey is offline   Reply With Quote
Old 02-14-2020, 07:57 PM   #6581
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 410
Default

Quote:
Originally Posted by MixMonkey View Post
thanks for help MixMonkey.ok so i feel dumby. the globalautomode just simply puts all the tracks in that automation mode.hence the GLOBAL part of the command.sometimes i just dont think for a second before i act haha. thank you for answering all my questions and the dumb ones too.
Cragster is offline   Reply With Quote
Old 02-14-2020, 08:04 PM   #6582
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 410
Default

Quote:
Originally Posted by Geoff Waddington View Post
New build is up.

First shot at restoring blanks.
Yes all that should be blank is blank here.thanks Geoff
Cragster is offline   Reply With Quote
Old 02-15-2020, 05:33 AM   #6583
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,035
Default

Quote:
Originally Posted by Funkybot View Post
1. MCU is a fixed protocol. There's a set number of buttons that are intended to relate to set actions. The button names correspond to the action (Play is Play, Read is Read, etc.). So one MCU.mst should technically work for all MCU surfaces without further modification. This assumes no user customization is needed - like how I want to reassign Zoom and make it a Shift button.
Hmmm, shouldn't you be able to leave the .mst alone and do this ?

Code:
Zone "Buttons|"
    Zoom Shift
Zone End
with the caveat that you have now committed the Zoom button to be forever a modifier on this Page.
__________________
CSI - You can donate here: geoffwaddington.ca
Beta software: https://stash.reaper.fm/v/38349/CSI%20beta.zip
installation and documentation here: https://github.com/malcolmgroves/reaper_csi/wiki
Geoff Waddington is offline   Reply With Quote
Old 02-15-2020, 05:34 AM   #6584
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,035
Default

Okay folks, is there anything missing from what we had before, speak up now !!!
__________________
CSI - You can donate here: geoffwaddington.ca
Beta software: https://stash.reaper.fm/v/38349/CSI%20beta.zip
installation and documentation here: https://github.com/malcolmgroves/reaper_csi/wiki
Geoff Waddington is offline   Reply With Quote
Old 02-15-2020, 05:54 AM   #6585
ramses
Human being with feelings
 
Join Date: Jul 2009
Posts: 708
Smile

Quote:
Originally Posted by Geoff Waddington View Post
Okay folks, is there anything missing from what we had before, speak up now !!!
Just a thought. Is everything customized for faders and stuff working in groups of 8 as is? I'm aware the (newish) softube "fader" is supposed to work in groups of 10, so this might be good to have in mind for the beta release...
ramses is offline   Reply With Quote
Old 02-15-2020, 06:38 AM   #6586
Geoff Waddington
Human being with feelings
 
Geoff Waddington's Avatar
 
Join Date: Mar 2009
Location: Dartmouth, Nova Scotia
Posts: 5,035
Default

Quote:
Originally Posted by ramses View Post
Just a thought. Is everything customized for faders and stuff working in groups of 8 as is? I'm aware the (newish) softube "fader" is supposed to work in groups of 10, so this might be good to have in mind for the beta release...
Thanks, already there, here are some Zone excerpts.

MCU:

Code:
        ChannelLeft 	TrackBank "-1"
	ChannelRight    TrackBank "1"
	BankLeft 	TrackBank "-8"
	BankRight 	TrackBank "8"
Softube:

Code:
        ChannelLeft 	TrackBank "-1"
	ChannelRight     TrackBank "1"
	BankLeft 	TrackBank "-10"
	BankRight 	TrackBank "10"
That's what CSI (Control Surface Integrator) is all about

If you have both, you can really have some fun
__________________
CSI - You can donate here: geoffwaddington.ca
Beta software: https://stash.reaper.fm/v/38349/CSI%20beta.zip
installation and documentation here: https://github.com/malcolmgroves/reaper_csi/wiki
Geoff Waddington is offline   Reply With Quote
Old 02-15-2020, 07:09 AM   #6587
knadles
Human being with feelings
 
knadles's Avatar
 
Join Date: May 2012
Location: Chicago, IL, USA
Posts: 21
Default

That worked! Thank you!
knadles is offline   Reply With Quote
Old 02-15-2020, 07:26 AM   #6588
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 410
Default

Quote:
Originally Posted by Geoff Waddington View Post
Okay folks, is there anything missing from what we had before, speak up now !!!
Evrything seems to be as it was here..
Cragster is offline   Reply With Quote
Old 02-15-2020, 08:33 AM   #6589
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by Geoff Waddington View Post
Okay folks, is there anything missing from what we had before, speak up now !!!
All good here.
Funkybot is online now   Reply With Quote
Old 02-15-2020, 09:42 AM   #6590
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by Geoff Waddington View Post
Hmmm, shouldn't you be able to leave the .mst alone and do this ?

Code:
Zone "Buttons|"
    Zoom Shift
Zone End
with the caveat that you have now committed the Zoom button to be forever a modifier on this Page.
Thanks for the tip. I haven't played around with shift buttons yet. I think I just assumed assumed CSI looked for a widget called Shift, and that's what enabled the modifier functionality. I didn't realize Shift needed to be assigned to a widget in a zone, and that any button could be given that functionality. That's handy. Thanks again for the tip! You saved me some troubleshooting.
Funkybot is online now   Reply With Quote
Old 02-15-2020, 11:21 AM   #6591
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Geoff Waddington View Post
Okay folks, is there anything missing from what we had before, speak up now !!!
All good here There are some differences in behaviour from what we had before, but these all centre around C4 Zone organisation and so aren't really anything to hold up the overall project.

One thing I did think, if you don't consider it too pedantic. With the Actions:
Code:
ToggleMapSelectedTrackSends 
ToggleMapSelectedTrackFX 
ToggleMapSelectedTrackFXMenu 
ToggleMapFocusedFX 
MapSelectedTrackSendsToWidgets 
MapSelectedTrackFXToWidgets 
MapSelectedTrackFXToMenu 
MapFocusedFXToWidgets
Shouldn't the 'Toggle' version of the Action use the same following text as the related 'Map' Action? eg:

Code:
ToggleMapSelectedTrackSends
should be:
Code:
ToggleMapSelectedTrackSendsToWidgets
Just been caught out by this whilst trying out different workflow behaviour. Not a big deal, but seems more consistent.
MixMonkey is offline   Reply With Quote
Old 02-15-2020, 11:29 AM   #6592
Dberman
Human being with feelings
 
Join Date: Jan 2020
Posts: 28
Default

Quote:
Originally Posted by Funkybot View Post
Are you using the overlays? I can't emphasize this enough, but the buttons literally change depending on the mode!
I have all the overlays, but I wasn't relying on them because my ultimate goal is my own customized layout. As always, I really appreciate the thoroughness and clarity of your advice.

Quote:
So my advice to you is this:

1. Pick Logic, S1, or Cubase mode to start (look at the overlays for the available functions and pick the one that most fits your workflow).

2. Once you do that, use the overlay for that MCU mode to determine the widget names. Note: if you bought it second hand or otherwise don't have the overlays handy, you can download them from Behringer.

3. Now, if you want to change an action, find the button name in the overlay, and edit that action in the zone. Example: let's say you pick Logic mode. You're X-Touch will be set to MCU Logic, you'll have the Logic overlay on...now let's say you want the "Group" button to work as an Undo button instead. You'll open the .zon file, find the "Group" widget, and edit the action to use Reaper's undo action instead.
So, the step I was not comprehending is leaving the .mst alone and making my changes in the .zon file. I'm pretty certain this will give me exactly what I want, since I've had everything working at one time or another. Thank you again.
Dberman is offline   Reply With Quote
Old 02-15-2020, 11:38 AM   #6593
Dberman
Human being with feelings
 
Join Date: Jan 2020
Posts: 28
Default

Quote:
Originally Posted by Dberman View Post
I have all the overlays, but I wasn't relying on them because my ultimate goal is my own customized layout. As always, I really appreciate the thoroughness and clarity of your advice.
So, now that I've actually LOOKED at the overlays, teh Cubase layout is about 90% of what I want. Geez, nothing like making this harder than it needs to be. Thanks again, @Funybot.
Dberman is offline   Reply With Quote
Old 02-15-2020, 11:44 AM   #6594
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Dberman View Post
So, the step I was not comprehending is leaving the .mst alone and making my changes in the .zon file. I'm pretty certain this will give me exactly what I want, since I've had everything working at one time or another. Thank you again.
As long as the X-Touch One mode you pick outputs something useful for all the controls and this reflected in the .mst file, everything else can be changed in the .zon file.

The reason it's a good idea to pick a mode that comes with the unit (as opposed to one you've edited yourself, MCUser mode for instance) is that anyone else can use your .mst file and .zon files, beacause they'll be starting from the same place

In a way, that's the advantage of the original Mackie units, the MCU, XT and C4. The assignments are what they are- thay can't be changed. So as long as someone else uses the same widget names in their .zon files, they'll work with the corresponding .mst file and hence the unit itself.
MixMonkey is offline   Reply With Quote
Old 02-15-2020, 12:17 PM   #6595
Cragster
Human being with feelings
 
Join Date: Apr 2019
Location: Quakertown PA USA
Posts: 410
Smile

Speaking of passing on zone and mst files on to the next or new person ... Geoff if you would like me to whip up a good/full/tested/complete with following comments detailing what each button does Icon ProX mst/zone file to include with your CSI finished project i can definitely do that. Just stantard reaper functions no custom or obscure actions.i got a pretty good handle on this(most times haha). Im seeing not many here using the ProX but i know thats one of the included surfaces in your CSI. Just let me know and ill work it up and post it . Thanks for ur help
Cragster is offline   Reply With Quote
Old 02-15-2020, 12:31 PM   #6596
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by Dberman View Post
So, now that I've actually LOOKED at the overlays, teh Cubase layout is about 90% of what I want. Geez, nothing like making this harder than it needs to be. Thanks again, @Funybot.
I may switch over to that one myself. There's things about each mode I like. As I was going through the effort of setting up the X-Touch One, I put together some documentation that may be helpful so I'll share:

https://docs.google.com/spreadsheets...it?usp=sharing

It's mostly just the .mst in a list form, but it includes information like whether or not a widget exist in the X-Touch, which mode if so, and how some of the widgets/buttons are repurposed in other modes. It's not 100% complete, but has been helpful here as I advance with the .zon.
Funkybot is online now   Reply With Quote
Old 02-15-2020, 01:02 PM   #6597
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

@FunkyBot

Regarding the X-Touch One, am I right in understanding that when the X-Touch one is in one of the DAW modes (S1 or Cubase, say) that the channel left and right buttons change the MIDI output of the 'channel' related functions on the unit (fader, pan, mute etc) so that they can address different channels within the set of 8 that has been selected by the bank left/right buttons?

Also, when the master button is pressed the channel functions address what is effectively the ninth fader on an MCU?

Just trying to get an idea of the unit uses the MCU protocol with only one channel.
MixMonkey is offline   Reply With Quote
Old 02-15-2020, 01:10 PM   #6598
ramses
Human being with feelings
 
Join Date: Jul 2009
Posts: 708
Default

Quote:
Originally Posted by Geoff Waddington View Post
Thanks, already there, here are some Zone excerpts.

MCU:

Code:
        ChannelLeft 	TrackBank "-1"
	ChannelRight    TrackBank "1"
	BankLeft 	TrackBank "-8"
	BankRight 	TrackBank "8"
Softube:

Code:
        ChannelLeft 	TrackBank "-1"
	ChannelRight     TrackBank "1"
	BankLeft 	TrackBank "-10"
	BankRight 	TrackBank "10"
That's what CSI (Control Surface Integrator) is all about

If you have both, you can really have some fun
Amazing, thanks!
ramses is offline   Reply With Quote
Old 02-15-2020, 03:27 PM   #6599
Funkybot
Human being with feelings
 
Join Date: Jul 2007
Posts: 1,290
Default

Quote:
Originally Posted by MixMonkey View Post
@FunkyBot

Regarding the X-Touch One, am I right in understanding that when the X-Touch one is in one of the DAW modes (S1 or Cubase, say) that the channel left and right buttons change the MIDI output of the 'channel' related functions on the unit (fader, pan, mute etc) so that they can address different channels within the set of 8 that has been selected by the bank left/right buttons?

Also, when the master button is pressed the channel functions address what is effectively the ninth fader on an MCU?

Just trying to get an idea of the unit uses the MCU protocol with only one channel.
Thatís exactly it.
Funkybot is online now   Reply With Quote
Old 02-15-2020, 03:43 PM   #6600
MixMonkey
Human being with feelings
 
MixMonkey's Avatar
 
Join Date: Sep 2017
Location: London, England.
Posts: 1,382
Default

Quote:
Originally Posted by Funkybot View Post
Thatís exactly it.
Thanks for the confirmation

Now I think I've got my head around it a bit more, a couple of questions if you've got the time.

Do you intend to use this channel switching ability with CSI? or is there a better way of moving track to track in Reaper with just a single, fixed channel definition on the X-Touch One?

I ask because there are a number of these single fader devices available and it would be good to have a common game plan for them if possible (probably a wild hope)
MixMonkey is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 07:41 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.