Old 11-16-2022, 02:48 PM   #1
jack461
Human being with feelings
 
jack461's Avatar
 
Join Date: Nov 2013
Location: France
Posts: 185
Default Can't stop this JSFX

I have this stupidely written JSFX, that I cannot stop once run.
Does this qualify as a bug ?
Code:
desc:Menu-Test
@init
@gfx
gfx_showmenu("Is|This|A|Bug?");
PS: don't run that, unless you are ready to reboot your computer...

J. Jack.
jack461 is offline   Reply With Quote
Old 11-16-2022, 04:41 PM   #2
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 15,809
Default

Hmm what OS and version? Here on macOS 10.14 or Windows 10, it is very easy (though slightly annoying, sure) to close the window and then delete the plug-in...
Justin is offline   Reply With Quote
Old 11-17-2022, 01:08 AM   #3
jack461
Human being with feelings
 
jack461's Avatar
 
Join Date: Nov 2013
Location: France
Posts: 185
Default

Thanks, Justin.

I'm on macOS 10.14.6 (Mojave) on a MacBook Pro Retina 15' end 2013
2.3 GHz i7.

I may have options like "run the FX when REAPER is not the front application", so whatever I do or try to select, like closing the window, making the plug-in inactive, trying to quit REAPER from inside REAPER, trying to force REAPER to quit from the Apple menu or the activity monitor, the pop-up immediately reappears and cancels the action. The only thing that works is the "off" button.

I post here my REAPER.ini in case it is useful.

J. Jack.
Attached Files
File Type: ini reaper.ini (15.2 KB, 135 views)

Last edited by jack461; 11-17-2022 at 01:15 AM.
jack461 is offline   Reply With Quote
Old 11-17-2022, 07:31 PM   #4
Justin
Administrator
 
Justin's Avatar
 
Join Date: Jan 2005
Location: NYC
Posts: 15,809
Default

Hmm try very quickly doubleclicking the red close button on the FX window?

Or if that doesn't work, hold Escape down and then click the close button. Or just hold Escape and it'll get there eventually:

Justin is offline   Reply With Quote
Old 11-18-2022, 03:07 AM   #5
jack461
Human being with feelings
 
jack461's Avatar
 
Join Date: Nov 2013
Location: France
Posts: 185
Default

Quote:
Originally Posted by Justin View Post
Hmm try very quickly doubleclicking the red close button on the FX window?

Or if that doesn't work, hold Escape down and then click the close button. Or just hold Escape and it'll get there eventually:
Thanks for the detailed explanation. In about an hour of experimenting, I've never been fast enough to double-click the close button of the TX window. However, I twice succeded in hitting the remove effect button. Also holding the "escape" key also works, although after a while.

Now, what seems strange to me is that the plug-in, or at least its graphical interface, seems to stay active even when it is bypassed, with the track muted, and the whole FX chain is off (FX button red in the track). Is this systematic, or just a consequence of some of my settings ?

J. Jack.
jack461 is offline   Reply With Quote
Old 11-19-2022, 02:18 AM   #6
Tale
Human being with feelings
 
Tale's Avatar
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 3,669
Default

Quote:
Originally Posted by jack461 View Post
Now, what seems strange to me is that the plug-in, or at least its graphical interface, seems to stay active even when it is bypassed, with the track muted, and the whole FX chain is off (FX button red in the track). Is this systematic, or just a consequence of some of my settings ?
AFAIK @gfx is active whenever the GUI is visible, regardless of whether the plugin is bypassed.
Tale is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:04 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.