Go Back   Cockos Incorporated Forums > REAPER Forums > REAPER Compatibility

Reply
 
Thread Tools Display Modes
Old 12-29-2018, 04:09 PM   #1
Eiradiana
Human being with feelings
 
Join Date: Dec 2018
Posts: 2
Default iRig Keys I/O latency with standalones and in Reaper

Hello everybody,

I wanted to share my experience with my newly bought IK iRig Keys I/O 49 which I think is pretty wonderful in a lot of ways.

I've been using it with 2 rigs in different configurations :
- as a midi Controller on my main rig with i5-2500K o/ced @4,3Ghz / 8GB RAM / Full SSD coupled with a Focusrite Scarlett 2i4. I add to that a CASIO PX-200 for the lested touch I need when I play real piano.
- as a midi controller and with the builtin audio interface on my Surface Pro 4 2016 core m3 (2Ghz at full perf) / 4GB Ram / SSD 128GB + SD Card 256GB UHS-I where I store my VST Data.

In the first configuration when the Scarlett 2i4 does most of the job, everything is fine on Reaper 5.963. I have a wonderful low latency perfect for everything (drums, bass, piano, 80's synth, etc...).

In the second case, I'm having different troubles on the Surface Pro 4. The iRig Keys I/O works without ASIO drivers from IK Multimedia. It works with WASAPI shared or exclusive mode, or with ASIO4ALL. I'm having low latency audio when I use standalone Vst like UVI Workstation, IK SampleTank or NI Kontakt. It's not perfect, so I'd really like to use Reaper and all its features to help me on stage or in rehearsal.

But as soon as I enter Reaper 5.963 on the Surface Pro 4, the parameters don't seem to apply the same way :
- in WASAPI mode :
1) "Shared mode" doesn't work at all.
2) "Exclusive mode" won't give me something more than 1 sample buffering : everything is extremely long (like 10x times too long) with lots of cracks and everything.
3) "Exclusive mode (polled)" works, except the latency is too high (around 20ms - 40ms and it is in flow). And changing buffer size doesn't do anything.Why ? It works great in standalone vst listed above !

- in ASIO4ALL : I use as outputs only the iRig Keys I/O's : it works great with low latency but I have lots of cracks and when I change the buffer size in ASIO4ALL, it doesn't really change anything. When I do that with my focusrite, I can clearly spot the difference between 64, 128, 192, 256 samples. Here I can't.

Overall, it seems there is a problem with the support of this builtin interface in Reaper because I can't reproduce the problem in UVI Workstation, NI Kontakt or IK Sampletank 3. Do you agree ?

Anyone has seen this kind of behaviour previously ?

Thanks in advance for any ideas you'd like to share.

Otherwise, Reaper and I are a perfect match and I'm really happy to begin my journey within its community.

Best Regards !

Last edited by Eiradiana; 01-04-2019 at 05:28 AM.
Eiradiana is offline   Reply With Quote
Old 01-11-2019, 08:31 AM   #2
Eiradiana
Human being with feelings
 
Join Date: Dec 2018
Posts: 2
Default

Hi,
A friend of mine, professional user of Reaper, found something to make it work on Surface Pro 4.
The problem seems to come from the Windows Mixer.
If I tell Windows in the notification area to use the Surface pro 4 builtin speaker (Realtek High Definition Audio) instead of the iRig Keys outputs, suddenly, the cracks disappear and I can use UVI Workstation and Miroslav Phliharmonik in Reaper with no latency at all, in ASIO4ALL at 128 samples.

The surface pro 4 core m3 / 4GB and this iRig Keys 49 alone allowed me to perform live yesterday. It's a really interesting, lightweight, fully configurable setup that only needs the irig Keys 49 bag for transport, because the surface pro 4 has the perfect size to fit inside, below or on top. Here are some pics of the setup on stage :
https://photos.app.goo.gl/4d2uMtHMToM4NSR48

You just have to get the surface pro 4 integrated support to go behind the irig iPad support because the surface pro 4 is just 1,5-2 mm too wide to stand in it (see last photo). Then it stands perfectly.

The only problem I encountered was on extremely complex sounds : the power of this version of surface pro 4 couldn't manage a big polyphony (above 50) or a lot of effects. That said, I could use EQ, Drive, SparkVerb and Delay easily on multiple sounds from UVI Augmented Piano and PX V8. Sounds from IK Multimedia are easier because they often are a lot lighter for the CPU and RAM.

Overall, you can have equivalent sounds than those of a Nord stage Clavia for a third of the price and a tenth of a weight !

Has anyone tried this ?

Last edited by Eiradiana; 01-11-2019 at 08:36 AM.
Eiradiana is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 02:47 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.