Old 02-18-2019, 01:15 PM   #1
chopsbbq
Human being with feelings
 
Join Date: May 2014
Posts: 4
Default Overlapping MIDI notes automatically joined

Hi,

All overlapping MIDI notes (same pitch, new note start before previous note end) are automatically joined by Reaper.

This for instance makes it very difficult if not impossible to do drum rolls, as that would require the first stick (or finger) to be lifted before the second hits the drumpad.

I have been browsing the forum for hours and tried all recommendations of prior threads to no avail. Settings are the following:
-Record Midi overdub
-Automatically correct overlapping notes: OFF
-Display 14bit MSB/... as single entry in event list: off

Strange is that while recording, I see the two overlapping notes displayed on the timeline, but that the second overlapping note however disappears after note release (after which Reaper supposedly joins both notes).

I have made a 20-second video to demonstrate this (piano roll notes as triangles):
https://youtu.be/Ssx-wzYlBUk
You can see the second note appear as I hit it, but then disappearing subsequently.
My apologies for the deep sigh at the end, it's a bit of a difficult period.

And a second video, where piano roll notes are displayed as rectangles:
https://youtu.be/NSRwlZJMsts

Best regards
chopsbbq is offline   Reply With Quote
Old 02-18-2019, 04:28 PM   #2
nofish
Human being with feelings
 
nofish's Avatar
 
Join Date: Oct 2007
Location: home is where the heart is
Posts: 8,455
Default

Quote:
Originally Posted by chopsbbq View Post
-Automatically correct overlapping notes: OFF
Have you tried with this setting ON already?
(Not sure if it helps, just an idea...)
nofish is offline   Reply With Quote
Old 02-18-2019, 05:42 PM   #3
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 2,142
Default

I can approximate the behavior with the Virtual MIDI Keyboard and some input fx to transpose notes to same pitch. I guess overlapping notes are handled a little differently when recording than while editing, gluing, or writing with script (SetAllEvents).

After a quick experiment, it looks like something like midiOverlappingNoteKiller, a VST by Insert Piz Here, might be helpful in the input FX chain in this case. I don't know if there is a JS plugin for this...

Edit. This issue seems to be in overdub mode only? Record input(audio or MIDI) or record output(MIDI) seems capable of producing overlapping notes.

Last edited by FnA; 02-18-2019 at 07:04 PM.
FnA is offline   Reply With Quote
Old 02-18-2019, 11:03 PM   #4
chopsbbq
Human being with feelings
 
Join Date: May 2014
Posts: 4
Default

Quote:
Originally Posted by nofish View Post
Have you tried with this setting ON already?
(Not sure if it helps, just an idea...)
The eventual result is the same whether the setting is ON or OFF. With the setting ON, the second overlapping note does not appear in an intermediary step. With the setting OFF, it temporarily does but then disappears after release of the note (as seen in the video).

Quote:
Originally Posted by FnA View Post
I can approximate the behavior with the Virtual MIDI Keyboard and some input fx to transpose notes to same pitch. I guess overlapping notes are handled a little differently when recording than while editing, gluing, or writing with script (SetAllEvents).

After a quick experiment, it looks like something like midiOverlappingNoteKiller, a VST by Insert Piz Here, might be helpful in the input FX chain in this case. I don't know if there is a JS plugin for this...

Edit. This issue seems to be in overdub mode only? Record input(audio or MIDI) or record output(MIDI) seems capable of producing overlapping notes.
You're right, this issue is only in overdub mode, and not in replace (or record audio) mode. Do I understand correctly that you in your approximation experience the same behavior?

Plugins might be an idea to circumvent this, although I haven't found any that would suit this purpose. 'Insert Piz's website seems to be down but his midiOverlappingNoteKiller seems from its description to be doing the opposite (ie in fact also remove overlapping notes). In addition, aren't plugins applied as a subsequent step after the midi event, and therefore not able to prevent the midi event of 2 notes being joined?

Thank you for the input, it inspired new thought streams.

Best regards,
Bart
chopsbbq is offline   Reply With Quote
Old 02-19-2019, 04:54 AM   #5
FnA
Human being with feelings
 
FnA's Avatar
 
Join Date: Jun 2012
Posts: 2,142
Default

I think the behavior is the same.

I’ve heard of this trouble with piz website. I got them before that. Maybe you can still get around it somehow.
https://www.kvraudio.com/forum/viewtopic.php?t=490010

The plugin caused a note off to be sent at the time of the overlapping notes note on. So reaper overdubbed two notes. Some theories went through my mind that this would not solve all problems, or maybe an unequal number of note ons and offs might result, etc, but maybe worth a try if you can get it.

I’m curious. Does the drum pad have the ability to hold two note offs? You can end both notes where you like, in other than overdub?
FnA is offline   Reply With Quote
Old 02-19-2019, 11:10 AM   #6
chopsbbq
Human being with feelings
 
Join Date: May 2014
Posts: 4
Default

Thanks to your ideas I found a way to circumvent this when working with finger pads, such as the Korg padKontrol in my case. Note that this only addresses overlaps for one instrument (eg snare), but this could be expanded for more instruments by mapping these to different channels and applying the same approach.

1) In the padKontrol mapping, dedicate 2 of the pads for each of the instrument you would have overlapping notes (eg the snare). Do however map them to 2 different midi notes, with the second pad concerned a semitone higher than the first.

2) Use the built in Reaper plug in 'Midi router/transpose' to transpose the second pad one semitone lower, so that both pads are eventually routed to the same note. This plugin should fixed to only transpose the second pad, by indicating the pad value in both the 'note min' and 'note max' parameter (D#2 for instance is note value 39).

Alternatively, to (2), you could have the second pad mapped to the same instrument within your instrument VST (and eg to different articulations). I use Superior drummer 2 however, for which there is no relevant alternative articulation I could map it to.

It works, but it would perhaps by nice to fix this in the Reaper code directly as this circumvention of the issue is quite cumbersome for what seems to me a basic functionality. Giving credit to the developers though that in the many years I've been using this DAW this is the first and only issue that seemingly cannot be resolved in the software settings.
chopsbbq is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 09:51 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.